mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Manfred Spraul <manfred@colorfullife.com>
To: Andrew Morton <akpm@linux-foundation.org>,
	Davidlohr Bueso <dave@stgolabs.net>,
	Dmitry Vyukov <dvyukov@google.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
	1vier1@web.de, Kees Cook <keescook@chromium.org>,
	Davidlohr Bueso <dbueso@suse.de>,
	Manfred Spraul <manfred@colorfullife.com>
Subject: [PATCH 08/12] lib/rhashtable: simplify bucket_table_alloc()
Date: Mon,  9 Jul 2018 17:10:15 +0200	[thread overview]
Message-ID: <20180709151019.1336-9-manfred@colorfullife.com> (raw)
In-Reply-To: <20180709151019.1336-1-manfred@colorfullife.com>

From: Davidlohr Bueso <dave@stgolabs.net>

As of commit ce91f6ee5b3b ("mm: kvmalloc does not fallback to vmalloc for
incompatible gfp flags") we can simplify the caller and trust kvzalloc() to
just do the right thing. For the case of the GFP_ATOMIC context, we can
drop the __GFP_NORETRY flag for obvious reasons, and for the __GFP_NOWARN
case, however, it is changed such that the caller passes the flag instead
of making bucket_table_alloc() handle it.

This slightly changes the gfp flags passed on to nested_table_alloc() as
it will now also use GFP_ATOMIC | __GFP_NOWARN. However, I consider this a
positive consequence as for the same reasons we want nowarn semantics in
bucket_table_alloc().

Signed-off-by: Davidlohr Bueso <dbueso@suse.de>
Acked-by: Michal Hocko <mhocko@suse.com>

(commit id extended to 12 digits, line wraps updated)
Signed-off-by: Manfred Spraul <manfred@colorfullife.com>
---
 lib/rhashtable.c | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/lib/rhashtable.c b/lib/rhashtable.c
index 9427b5766134..083f871491a1 100644
--- a/lib/rhashtable.c
+++ b/lib/rhashtable.c
@@ -175,10 +175,7 @@ static struct bucket_table *bucket_table_alloc(struct rhashtable *ht,
 	int i;
 
 	size = sizeof(*tbl) + nbuckets * sizeof(tbl->buckets[0]);
-	if (gfp != GFP_KERNEL)
-		tbl = kzalloc(size, gfp | __GFP_NOWARN | __GFP_NORETRY);
-	else
-		tbl = kvzalloc(size, gfp);
+	tbl = kvzalloc(size, gfp);
 
 	size = nbuckets;
 
@@ -459,7 +456,7 @@ static int rhashtable_insert_rehash(struct rhashtable *ht,
 
 	err = -ENOMEM;
 
-	new_tbl = bucket_table_alloc(ht, size, GFP_ATOMIC);
+	new_tbl = bucket_table_alloc(ht, size, GFP_ATOMIC | __GFP_NOWARN);
 	if (new_tbl == NULL)
 		goto fail;
 
-- 
2.17.1


  parent reply	other threads:[~2018-07-09 15:13 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-07-09 15:10 [PATCH 0/12 V2] ipc: cleanups & bugfixes, rhashtable update Manfred Spraul
2018-07-09 15:10 ` [PATCH 01/12] ipc: reorganize initialization of kern_ipc_perm.id Manfred Spraul
2018-07-10 22:08   ` Davidlohr Bueso
2018-07-09 15:10 ` [PATCH 02/12] ipc: reorganize initialization of kern_ipc_perm.seq Manfred Spraul
2018-07-09 15:10 ` [PATCH 03/12] ipc/util.c: Use ipc_rcu_putref() for failues in ipc_addid() Manfred Spraul
2018-07-09 15:10 ` [PATCH 04/12] ipc: Rename ipcctl_pre_down_nolock() Manfred Spraul
2018-07-09 19:49   ` Davidlohr Bueso
2018-07-09 15:10 ` [PATCH 05/12] ipc/util.c: correct comment in ipc_obtain_object_check Manfred Spraul
2018-07-09 18:46   ` Davidlohr Bueso
2018-07-09 15:10 ` [PATCH 06/12] ipc: rename ipc_lock() to ipc_lock_idr() Manfred Spraul
2018-07-11 19:38   ` Davidlohr Bueso
2018-07-09 15:10 ` [PATCH 07/12] ipc_idr_alloc refactoring Manfred Spraul
2018-07-11 19:52   ` Davidlohr Bueso
2018-07-11 20:00     ` Dmitry Vyukov
2018-07-09 15:10 ` Manfred Spraul [this message]
2018-07-09 15:10 ` [PATCH 09/12] lib/rhashtable: guarantee initial hashtable allocation Manfred Spraul
2018-07-09 15:10 ` [PATCH 10/12] ipc: get rid of ids->tables_initialized hack Manfred Spraul
2018-07-09 15:10 ` [PATCH 11/12] ipc: simplify ipc initialization Manfred Spraul
2018-07-09 21:42   ` Andrew Morton
2018-07-09 23:55     ` Davidlohr Bueso
2018-07-09 15:10 ` [PATCH 12/12] ipc/util.c: Further ipc_idr_alloc cleanups Manfred Spraul
2018-07-09 17:05   ` Dmitry Vyukov
2018-07-09 18:22     ` Manfred Spraul
2018-07-09 18:31       ` Dmitry Vyukov
2018-07-09 20:09 ` [PATCH 0/12 V2] ipc: cleanups & bugfixes, rhashtable update Davidlohr Bueso
2018-07-10  4:44   ` Manfred Spraul
2018-07-10 22:10     ` Davidlohr Bueso

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180709151019.1336-9-manfred@colorfullife.com \
    --to=manfred@colorfullife.com \
    --cc=1vier1@web.de \
    --cc=akpm@linux-foundation.org \
    --cc=dave@stgolabs.net \
    --cc=dbueso@suse.de \
    --cc=dvyukov@google.com \
    --cc=keescook@chromium.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®