mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* Getting the instruction pointer on a per arch basis
@ 2018-07-31 22:32 Nick Desaulniers
  2018-07-31 23:09 ` Nick Desaulniers
  0 siblings, 1 reply; 6+ messages in thread
From: Nick Desaulniers @ 2018-07-31 22:32 UTC (permalink / raw)
  To: LKML; +Cc: Pirama Arumuga Nainar, Greg Hackmann, Mark Salyzyn

I'm currently looking into cleaning up the code duplication between
current_text_addr() and _THIS_IP_, virtually every implementation of
current_text_addr() and _THIS_IP_ itself are basically:

#define _THIS_IP_ ({ __label__ _l; _l: &&_l; })

For a few arch's, they have inline assembly instead (for
current_text_addr()).  Examples:
* s390
* sh
* ia64
* x86 (um and 32b)
* c6x
* sparc

I have a patch that cuts down on the duplication, but I don't
understand why the few arch specific implementations are necessary.  I
could reduce the duplication further if it's ok to just use the
statement expression.

Does anyone know why this is the case?
-- 
Thanks,
~Nick Desaulniers

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2018-08-06  5:25 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-07-31 22:32 Getting the instruction pointer on a per arch basis Nick Desaulniers
2018-07-31 23:09 ` Nick Desaulniers
2018-08-01  1:33   ` Randy Dunlap
2018-08-01  5:40   ` Martin Schwidefsky
2018-08-01 18:21     ` Nick Desaulniers
2018-08-06  5:24       ` Martin Schwidefsky

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®