mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Peter Zijlstra <peterz@infradead.org>
To: Qais Yousef <qais.yousef@arm.com>
Cc: Ingo Molnar <mingo@redhat.com>,
	Steven Rostedt <rostedt@goodmis.org>,
	linux-kernel@vger.kernel.org,
	Pavankumar Kondeti <pkondeti@codeaurora.org>,
	Sebastian Andrzej Siewior <bigeasy@linutronix.de>,
	Uwe Kleine-Konig <u.kleine-koenig@pengutronix.de>
Subject: Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint
Date: Mon, 6 May 2019 11:08:59 +0200	[thread overview]
Message-ID: <20190506090859.GK2606@hirez.programming.kicks-ass.net> (raw)
In-Reply-To: <20190505115732.9844-5-qais.yousef@arm.com>

On Sun, May 05, 2019 at 12:57:29PM +0100, Qais Yousef wrote:

> +/*
> + * Following tracepoints are not exported in tracefs and provide hooking
> + * mechanisms only for testing and debugging purposes.
> + */
> +DECLARE_TRACE(sched_load_rq,
> +	TP_PROTO(int cpu, const char *path, struct sched_avg *avg),
> +	TP_ARGS(cpu, path, avg));
> +

> +DECLARE_TRACE(sched_load_se,
> +       TP_PROTO(int cpu, const char *path, struct sched_entity *se),
> +       TP_ARGS(cpu, path, se));
> +

> +DECLARE_TRACE(sched_overutilized,
> +       TP_PROTO(int overutilized),
> +       TP_ARGS(overutilized));

This doesn't generate any actual userspace because of the lack of
DEFINE_EVENT() ?

> diff --git a/kernel/sched/sched_tracepoints.h b/kernel/sched/sched_tracepoints.h
> new file mode 100644
> index 000000000000..f4ded705118e
> --- /dev/null
> +++ b/kernel/sched/sched_tracepoints.h
> @@ -0,0 +1,39 @@

Like with the other newly introduced header files, this one is lacking
the normal include guard.

> +/* SPDX-License-Identifier: GPL-2.0 */
> +/*
> + * Scheduler tracepoints that are probe-able only and aren't exported ABI in
> + * tracefs.
> + */
> +
> +#include <trace/events/sched.h>
> +
> +#define SCHED_TP_PATH_LEN		64
> +
> +
> +static __always_inline void sched_tp_load_cfs_rq(struct cfs_rq *cfs_rq)
> +{
> +	if (trace_sched_load_rq_enabled()) {
> +		int cpu = cpu_of(rq_of(cfs_rq));
> +		char path[SCHED_TP_PATH_LEN];
> +
> +		cfs_rq_tg_path(cfs_rq, path, SCHED_TP_PATH_LEN);
> +		trace_sched_load_rq(cpu, path, &cfs_rq->avg);
> +	}
> +}
> +
> +static __always_inline void sched_tp_load_rt_rq(struct rq *rq)
> +{
> +	if (trace_sched_load_rq_enabled()) {
> +		int cpu = cpu_of(rq);
> +
> +		trace_sched_load_rq(cpu, NULL, &rq->avg_rt);
> +	}
> +}
> +
> +static __always_inline void sched_tp_load_dl_rq(struct rq *rq)
> +{
> +	if (trace_sched_load_rq_enabled()) {
> +		int cpu = cpu_of(rq);
> +
> +		trace_sched_load_rq(cpu, NULL, &rq->avg_dl);
> +	}
> +}

> +static __always_inline void sched_tp_load_se(struct sched_entity *se)
> +{
> +       if (trace_sched_load_se_enabled()) {
> +               struct cfs_rq *gcfs_rq = group_cfs_rq(se);
> +               struct cfs_rq *cfs_rq = cfs_rq_of(se);
> +               char path[SCHED_TP_PATH_LEN];
> +               int cpu = cpu_of(rq_of(cfs_rq));
> +
> +               cfs_rq_tg_path(gcfs_rq, path, SCHED_TP_PATH_LEN);
> +               trace_sched_load_se(cpu, path, se);
> +       }
> +}

These functions really should be called trace_*()

Also; I _really_ hate how fat they are. Why can't we do simple straight
forward things like:

	trace_pelt_cfq(cfq);
	trace_pelt_rq(rq);
	trace_pelt_se(se);

And then have the thing attached to the event do the fat bits like
extract the path and whatnot.

  reply	other threads:[~2019-05-06  9:09 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-05-05 11:57 [PATCH 0/7] Add new tracepoints required for EAS testing Qais Yousef
2019-05-05 11:57 ` [PATCH 1/7] sched: autogroup: Make autogroup_path() always available Qais Yousef
2019-05-05 11:57 ` [PATCH 2/7] sched: fair: move helper functions into fair.h Qais Yousef
2019-05-05 11:57 ` [PATCH 3/7] sched: fair.h: add a new cfs_rq_tg_path() Qais Yousef
2019-05-05 11:57 ` [PATCH 4/7] sched: Add sched_load_rq tracepoint Qais Yousef
2019-05-06  9:08   ` Peter Zijlstra [this message]
2019-05-06  9:18     ` Peter Zijlstra
2019-05-08 13:38       ` Qais Yousef
2019-05-06 13:52     ` Steven Rostedt
2019-05-06 14:42       ` Qais Yousef
2019-05-06 14:46         ` Steven Rostedt
2019-05-06 15:33           ` Qais Yousef
2019-05-06 16:01             ` Steven Rostedt
2019-05-06 17:23               ` Qais Yousef
2019-05-06 14:38     ` Qais Yousef
2019-05-10  8:51   ` Dietmar Eggemann
2019-05-10  9:14     ` Qais Yousef
2019-05-05 11:57 ` [PATCH 5/7] sched: Add sched_load_se tracepoint Qais Yousef
2019-05-05 11:57 ` [PATCH 6/7] sched: Add sched_overutilized tracepoint Qais Yousef
2019-05-05 11:57 ` [PATCH 7/7] sched: export the newly added tracepoints Qais Yousef

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190506090859.GK2606@hirez.programming.kicks-ass.net \
    --to=peterz@infradead.org \
    --cc=bigeasy@linutronix.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=pkondeti@codeaurora.org \
    --cc=qais.yousef@arm.com \
    --cc=rostedt@goodmis.org \
    --cc=u.kleine-koenig@pengutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome