From: Sakari Ailus <sakari.ailus@linux.intel.com>
To: Hans Verkuil <hverkuil-cisco@xs4all.nl>
Cc: Jacopo Mondi <jacopo@jmondi.org>,
Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
"open list:MEDIA INPUT INFRASTRUCTURE (V4L/DVB)"
<linux-media@vger.kernel.org>,
open list <linux-kernel@vger.kernel.org>
Subject: Re: [RFC 2/5] media: v4l2-ctrl: Document V4L2_CID_LOCATION
Date: Thu, 15 Aug 2019 18:12:31 +0300 [thread overview]
Message-ID: <20190815151231.GA6012@kekkonen.localdomain> (raw)
In-Reply-To: <cb36e8a0-b941-ff37-e58c-0f9b7f62116a@xs4all.nl>
Hi Hans,
On Thu, Aug 15, 2019 at 04:40:03PM +0200, Hans Verkuil wrote:
> On 8/15/19 4:34 PM, Jacopo Mondi wrote:
> > Hi Hans,
> >
> > On Thu, Aug 15, 2019 at 04:14:38PM +0200, Hans Verkuil wrote:
> >> On 8/15/19 4:10 PM, Hans Verkuil wrote:
> >>> On 8/15/19 12:43 AM, Laurent Pinchart wrote:
> >>>> Hi Jacopo,
> >>>>
> >>>> Thank you for the patch.
> >>>>
> >>>> On Wed, Aug 14, 2019 at 10:28:12PM +0200, Jacopo Mondi wrote:
> >>>>> Add documentation for the V4L2_CID_LOCATION camera control. The newly
> >>>>> added read-only control reports the camera device mounting position.
> >>>>>
> >>>>> Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
> >>>>> ---
> >>>>> .../media/uapi/v4l/ext-ctrls-camera.rst | 23 +++++++++++++++++++
> >>>>> 1 file changed, 23 insertions(+)
> >>>>>
> >>>>> diff --git a/Documentation/media/uapi/v4l/ext-ctrls-camera.rst b/Documentation/media/uapi/v4l/ext-ctrls-camera.rst
> >>>>> index 51c1d5c9eb00..fc0a02eee6d4 100644
> >>>>> --- a/Documentation/media/uapi/v4l/ext-ctrls-camera.rst
> >>>>> +++ b/Documentation/media/uapi/v4l/ext-ctrls-camera.rst
> >>>>> @@ -510,6 +510,29 @@ enum v4l2_scene_mode -
> >>>>> value down. A value of zero stops the motion if one is in progress
> >>>>> and has no effect otherwise.
> >>>>>
> >>>>> +``V4L2_CID_LOCATION (integer)``
> >>>>
> >>>> Maybe V4L2_CID_CAMERA_SENSOR_LOCATION ? Same for the values below.
> >>>
> >>> Probably a better name, if a bit long. But we might need other location
> >>> controls in the future (e.g. flash location), so CID_LOCATION is just too
> >>> generic.
> >>
> >
> > Thanks for the feedback.
> >
> >> Note that the location defines themselves can most likely be used with any
> >> LOCATION control, so V4L2_LOCATION_FRONT would be fine with any control.
> >>
> >
> > What do you think instead of the control type? Would a single integer
> > control do or an integer menu one would be better? I see merit in both
> > proposals actually...
>
> Single integer. It's read-only, so it just reports the location.
>
> It would be different if this was a writable control: then you need to
> know which locations are possible to set, and that requires a menu type.
>
> But it doesn't make sense to set the location from software. However, the
> location might change as a result of other changes: e.g. if the camera
> has motor control of the tilt and the tilt changes from forward facing to
> downward facing, then the driver might change the location from FRONT
> to DOWN. A convoluted example perhaps, but this is just brainstorming.
When the camera points to another direction than directly away from the
surface, then we need another property to describe that. Location tells
where the camera is... well, located. :-)
--
Sakari Ailus
sakari.ailus@linux.intel.com
next prev parent reply other threads:[~2019-08-15 15:15 UTC|newest]
Thread overview: 47+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-08-14 20:28 [RFC 0/5] media: v4l2-ctrls: Add camera 'location' support Jacopo Mondi
2019-08-14 20:28 ` [RFC 1/5] media: dt-bindings: Document 'location' property Jacopo Mondi
2019-08-14 22:40 ` Laurent Pinchart
2019-08-15 6:56 ` Sakari Ailus
2019-08-15 12:55 ` Laurent Pinchart
2019-08-15 12:55 ` Jacopo Mondi
2019-08-15 12:58 ` Laurent Pinchart
2019-09-01 17:24 ` Pavel Machek
2019-09-02 8:02 ` Laurent Pinchart
2019-09-02 8:11 ` Pavel Machek
2019-08-14 20:28 ` [RFC 2/5] media: v4l2-ctrl: Document V4L2_CID_LOCATION Jacopo Mondi
2019-08-14 22:43 ` Laurent Pinchart
2019-08-15 12:58 ` Jacopo Mondi
2019-08-15 14:10 ` Hans Verkuil
2019-08-15 14:14 ` Hans Verkuil
2019-08-15 14:34 ` Jacopo Mondi
2019-08-15 14:40 ` Hans Verkuil
2019-08-15 15:12 ` Sakari Ailus [this message]
2019-09-01 17:24 ` Pavel Machek
2019-09-02 8:00 ` Laurent Pinchart
2019-09-02 8:06 ` Pavel Machek
2019-09-02 8:19 ` Laurent Pinchart
2019-09-02 8:27 ` Pavel Machek
2019-09-02 8:53 ` Laurent Pinchart
2019-09-02 9:41 ` Jacopo Mondi
2019-08-15 7:00 ` Sakari Ailus
2019-08-15 12:59 ` Laurent Pinchart
2019-08-15 13:08 ` Sakari Ailus
2019-08-15 13:10 ` Laurent Pinchart
2019-08-15 13:15 ` Sakari Ailus
2019-08-15 13:19 ` Laurent Pinchart
2019-08-15 13:30 ` Hans Verkuil
2019-08-15 13:48 ` Laurent Pinchart
2019-08-15 14:02 ` Jacopo Mondi
2019-08-14 20:28 ` [RFC 3/5] media: v4l2-ctrls: Add support for V4L2_CID_LOCATION Jacopo Mondi
2019-08-14 22:53 ` Laurent Pinchart
2019-08-15 13:02 ` Jacopo Mondi
2019-08-15 13:03 ` Laurent Pinchart
2019-08-15 13:41 ` Hans Verkuil
2019-08-15 13:50 ` Jacopo Mondi
2019-08-15 14:12 ` Hans Verkuil
2019-08-15 13:23 ` Hans Verkuil
2019-08-15 13:50 ` Jacopo Mondi
2019-08-14 20:28 ` [RFC 4/5] media: i2c: ov5670: Report the camera location Jacopo Mondi
2019-08-14 23:03 ` Laurent Pinchart
2019-08-15 7:04 ` Sakari Ailus
2019-08-14 20:28 ` [RFC 5/5] media: i2c: ov13858: " Jacopo Mondi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190815151231.GA6012@kekkonen.localdomain \
--to=sakari.ailus@linux.intel.com \
--cc=hverkuil-cisco@xs4all.nl \
--cc=jacopo@jmondi.org \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=mchehab@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®