From: Sam Ravnborg <sam@ravnborg.org>
To: Mihail Atanassov <Mihail.Atanassov@arm.com>
Cc: "dri-devel@lists.freedesktop.org"
<dri-devel@lists.freedesktop.org>,
Jernej Skrabec <jernej.skrabec@siol.net>,
Neil Armstrong <narmstrong@baylibre.com>,
David Airlie <airlied@linux.ie>,
Daniel Vetter <daniel.vetter@ffwll.ch>,
Jonas Karlman <jonas@kwiboo.se>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
nd <nd@arm.com>
Subject: Re: [PATCH] drm: Rename drm_bridge->dev to drm
Date: Thu, 5 Dec 2019 19:29:27 +0100 [thread overview]
Message-ID: <20191205182927.GA27091@ravnborg.org> (raw)
In-Reply-To: <20191205163028.19941-1-mihail.atanassov@arm.com>
Hi Mihail.
On Thu, Dec 05, 2019 at 04:30:45PM +0000, Mihail Atanassov wrote:
> The 'dev' name causes some confusion with 'struct device' [1][2], so use
> 'drm' instead since this seems to be the prevalent name for 'struct
> drm_device' members.
Thanks for doing this - it helps readability.
checkpatch complained:
-:107: CHECK:PARENTHESIS_ALIGNMENT: Alignment should match open parenthesis
#107: FILE: drivers/gpu/drm/bridge/nxp-ptn3460.c:251:
+ ret = drm_connector_init(bridge->drm, &ptn_bridge->connector,
&ptn3460_connector_funcs, DRM_MODE_CONNECTOR_LVDS);
-:133: CHECK:PARENTHESIS_ALIGNMENT: Alignment should match open parenthesis
#133: FILE: drivers/gpu/drm/bridge/parade-ps8622.c:491:
+ ret = drm_connector_init(bridge->drm, &ps8622->connector,
&ps8622_connector_funcs, DRM_MODE_CONNECTOR_LVDS);
But this seems unrelated to your changes - so should be ignored.
Browsed the patch and throw it after my build check script.
All looked good.
Acked-by: Sam Ravnborg <sam@ravnborg.org>
Sam
next prev parent reply other threads:[~2019-12-05 18:29 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-12-05 16:30 Mihail Atanassov
2019-12-05 18:20 ` Thomas Zimmermann
2019-12-06 11:25 ` Mihail Atanassov
2019-12-06 11:59 ` Thomas Zimmermann
2019-12-10 10:12 ` Daniel Vetter
2019-12-10 13:28 ` Mihail Atanassov
2019-12-10 22:12 ` Daniel Vetter
2019-12-05 18:29 ` Sam Ravnborg [this message]
2019-12-10 15:11 ` [PATCH] drm: remove drm_bridge->dev Mihail Atanassov
2019-12-10 15:25 ` Thomas Zimmermann
2019-12-10 15:26 ` Thomas Zimmermann
2019-12-11 7:38 ` Thomas Zimmermann
2019-12-11 11:01 ` Mihail Atanassov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20191205182927.GA27091@ravnborg.org \
--to=sam@ravnborg.org \
--cc=Mihail.Atanassov@arm.com \
--cc=airlied@linux.ie \
--cc=daniel.vetter@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=jernej.skrabec@siol.net \
--cc=jonas@kwiboo.se \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-kernel@vger.kernel.org \
--cc=narmstrong@baylibre.com \
--cc=nd@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®