mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/2] staging: vt6656: Refactor the vnt_vt3184_init function
@ 2020-04-11 12:51 Oscar Carter
  2020-04-11 12:51 ` [PATCH 1/2] staging: vt6656: Remove duplicate code in " Oscar Carter
  2020-04-11 12:51 ` [PATCH 2/2] staging: vt6656: Remove unnecessary local variable initialization Oscar Carter
  0 siblings, 2 replies; 3+ messages in thread
From: Oscar Carter @ 2020-04-11 12:51 UTC (permalink / raw)
  To: Forest Bond, Greg Kroah-Hartman
  Cc: Oscar Carter, Malcolm Priestley, Quentin Deslandes,
	Amir Mahdi Ghorbanian, devel, linux-kernel

This patch series makes a refactor of the vnt_vt3184_init function through
two patches.

The first one removes duplicate code in the if statements because
different branches are almost the same.

The second patch remove unnecessary local variable initialization.

Oscar Carter (2):
  staging: vt6656: Remove duplicate code in vnt_vt3184_init function
  staging: vt6656: Remove unnecessary local variable initialization

 drivers/staging/vt6656/baseband.c | 54 ++++++++-----------------------
 1 file changed, 13 insertions(+), 41 deletions(-)

--
2.20.1


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2020-04-11 12:52 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-04-11 12:51 [PATCH 0/2] staging: vt6656: Refactor the vnt_vt3184_init function Oscar Carter
2020-04-11 12:51 ` [PATCH 1/2] staging: vt6656: Remove duplicate code in " Oscar Carter
2020-04-11 12:51 ` [PATCH 2/2] staging: vt6656: Remove unnecessary local variable initialization Oscar Carter

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®