From: Josh Poimboeuf <jpoimboe@redhat.com>
To: Julien Thierry <jthierry@redhat.com>
Cc: Matt Helsley <mhelsley@vmware.com>,
linux-kernel@vger.kernel.org,
Peter Zijlstra <peterz@infradead.org>,
Miroslav Benes <mbenes@suse.cz>,
Steven Rostedt <rostedt@goodmis.org>
Subject: Re: [RFC][PATCH 4/5] objtool: Enable compilation of objtool for all architectures
Date: Fri, 15 May 2020 15:51:35 -0500 [thread overview]
Message-ID: <20200515205135.5pknexlld53oicu5@treble> (raw)
In-Reply-To: <e369f0a9-30fc-5754-8cff-bf238ab0b716@redhat.com>
On Wed, May 13, 2020 at 05:55:31PM +0100, Julien Thierry wrote:
> > > Since the stuff under arch/missing is only weak symbols to make up for
> > > missing subcmd implementations, can we put everything in a file
> > > subcmd_defaults.c (name up for debate!) that would be always be compiled an
> > > linked. And some SUBCMD_XXX is set to "y", the corresponding object file
> > > gets compiled and overrides the weak symbols from subcmd_defaults.c .
> >
> > Hmm, I like keeping them separated along similar lines to the other
> > code because it makes it easier to see the intended correspondence and
> > likely will keep the files more readable / smaller. I could
> > just move them out of arch/missing and into missing_check.c and so forth.
> >
> > What do you think of that?
> >
>
> I do prefer that to the introduction of an arch/missing.
>
> Still, I'm not sure I see much benefit in splitting those small
> implementations in separate files, but it's not a problem either. This seems
> more a matter of taste rather than one approach working better than the
> other. So it's more up to what the maintainer prefer! :)
For now I'd prefer getting rid of the 'missing' arch and just having a
single top-level weak.c which has all the weak functions in it. Keeps
the clutter down :-)
Down the road, if the number of weak functions got out of hand then we
could look at splitting them up into multiple files.
--
Josh
next prev parent reply other threads:[~2020-05-15 20:51 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-05-11 17:35 [RFC][PATCH 0/5] Enable objtool multiarch build Matt Helsley
2020-05-11 17:35 ` [RFC][PATCH 1/5] objtool: Exit successfully when requesting help Matt Helsley
2020-05-15 19:52 ` Josh Poimboeuf
2020-05-18 18:33 ` Matt Helsley
2020-05-11 17:35 ` [RFC][PATCH 2/5] objtool: Move struct objtool_file into arch-independent header Matt Helsley
2020-05-12 17:04 ` Julien Thierry
2020-05-12 18:07 ` Matt Helsley
2020-05-11 17:35 ` [RFC][PATCH 3/5] objtool: Add support for relocations without addends Matt Helsley
2020-05-12 17:04 ` Julien Thierry
2020-05-13 16:26 ` Matt Helsley
2020-05-13 16:55 ` Julien Thierry
2020-05-14 21:09 ` Matt Helsley
2020-05-15 20:33 ` Josh Poimboeuf
2020-05-18 19:14 ` Matt Helsley
2020-05-11 17:35 ` [RFC][PATCH 4/5] objtool: Enable compilation of objtool for all architectures Matt Helsley
2020-05-12 17:04 ` Julien Thierry
2020-05-13 15:59 ` Matt Helsley
2020-05-13 16:55 ` Julien Thierry
2020-05-15 20:51 ` Josh Poimboeuf [this message]
2020-05-18 18:26 ` Matt Helsley
2020-05-15 20:56 ` Josh Poimboeuf
2020-05-18 19:20 ` Matt Helsley
2020-05-18 19:50 ` Matt Helsley
2020-05-18 22:27 ` Josh Poimboeuf
2020-05-19 17:48 ` Matt Helsley
2020-05-11 17:35 ` [RFC][PATCH 5/5] objtool: Report missing support for subcommands Matt Helsley
2020-05-15 21:04 ` Josh Poimboeuf
2020-05-18 18:29 ` Matt Helsley
2020-05-12 17:04 ` [RFC][PATCH 0/5] Enable objtool multiarch build Julien Thierry
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200515205135.5pknexlld53oicu5@treble \
--to=jpoimboe@redhat.com \
--cc=jthierry@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mbenes@suse.cz \
--cc=mhelsley@vmware.com \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®