mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/4] futex: Minor code improvements
@ 2020-05-27 15:47 André Almeida
  2020-05-27 15:47 ` [PATCH 1/4] futex: Remove put_futex_key() André Almeida
                   ` (3 more replies)
  0 siblings, 4 replies; 5+ messages in thread
From: André Almeida @ 2020-05-27 15:47 UTC (permalink / raw)
  To: linux-kernel, tglx, peterz
  Cc: mingo, dvhart, kernel, krisman, André Almeida

Hello,

This series aims to make some small code improvements that I found in
futex.c, removing some lines and trying to make the code easier to read
and understand.

All commits tested with futex tests from kselftest.

André Almeida (4):
  futex: Remove put_futex_key()
  futex: Remove needless goto's
  futex: Remove unused or redundant includes
  futex: Consistently use fshared as boolean

 kernel/futex.c | 115 +++++++++++--------------------------------------
 1 file changed, 26 insertions(+), 89 deletions(-)

-- 
2.26.2


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2020-05-27 15:48 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-27 15:47 [PATCH 0/4] futex: Minor code improvements André Almeida
2020-05-27 15:47 ` [PATCH 1/4] futex: Remove put_futex_key() André Almeida
2020-05-27 15:47 ` [PATCH 2/4] futex: Remove needless goto's André Almeida
2020-05-27 15:47 ` [PATCH 3/4] futex: Remove unused or redundant includes André Almeida
2020-05-27 15:47 ` [PATCH 4/4] futex: Consistently use fshared as boolean André Almeida

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®