mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Baolin Wang <baolin.wang@linux.alibaba.com>
Cc: Christoph Hellwig <hch@lst.de>,
	axboe@kernel.dk, ming.lei@redhat.com, baolin.wang7@gmail.com,
	linux-block@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH RESEND 3/5] block: Add a new helper to attempt to merge a bio
Date: Mon, 17 Aug 2020 14:24:40 +0200	[thread overview]
Message-ID: <20200817122440.GA2213@lst.de> (raw)
In-Reply-To: <20200817121002.GB79836@VM20190228-100.tbsite.net>

On Mon, Aug 17, 2020 at 08:10:02PM +0800, Baolin Wang wrote:
> On Mon, Aug 17, 2020 at 08:26:34AM +0200, Christoph Hellwig wrote:
> > On Mon, Aug 17, 2020 at 12:09:17PM +0800, Baolin Wang wrote:
> > > There are lots of duplicated code when trying to merge a bio from
> > > plug list and sw queue, we can introduce a new helper to attempt
> > > to merge a bio, which can simplify the blk_mq_bio_list_merge()
> > > and blk_attempt_plug_merge().
> > 
> > Looks sensible, but two comments:
> > 
> > > +enum bio_merge_status blk_attempt_bio_merge(struct request_queue *q,
> > > +					    struct request *rq,
> > > +					    struct bio *bio,
> > > +					    unsigned int nr_segs)
> > > +{
> > > +	bool merged = false;
> > > +
> > > +	if (!blk_rq_merge_ok(rq, bio))
> > > +		return BIO_MERGE_NONE;
> > > +
> > > +	switch (blk_try_merge(rq, bio)) {
> > > +	case ELEVATOR_BACK_MERGE:
> > > +		merged = bio_attempt_back_merge(rq, bio, nr_segs);
> > > +		break;
> > > +	case ELEVATOR_FRONT_MERGE:
> > > +		merged = bio_attempt_front_merge(rq, bio, nr_segs);
> > > +		break;
> > > +	case ELEVATOR_DISCARD_MERGE:
> > > +		merged = bio_attempt_discard_merge(q, rq, bio);
> > > +		break;
> > 
> > Can't we also switch the bio_attempt_*merge helpers to return
> > enum bio_merge_status to simplify this a bit?
> 
> Yes, will do.
> 
> > 
> > Also I think these helpers can be marked static now, although I didn't
> > actually apply your series, so I might have missed something.
> 
> Cause this function will be used by blk_mq_bio_list_merge() in
> blk-mq-sched.c, it should be exported.

Shouldn't blk_mq_bio_list_merge move to blk-merge.c as well?

  reply	other threads:[~2020-08-17 12:24 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-08-17  4:09 [PATCH RESEND 0/5] Some clean-ups for bio merge Baolin Wang
2020-08-17  4:09 ` [PATCH RESEND 1/5] block: Move bio merge related functions into blk-merge.c Baolin Wang
2020-08-17  6:15   ` Christoph Hellwig
2020-08-17  4:09 ` [PATCH RESEND 2/5] block: Remove redundant blk_mq_sched_allow_merge() validation Baolin Wang
2020-08-17  6:22   ` Christoph Hellwig
2020-08-17 12:06     ` Baolin Wang
2020-08-17  4:09 ` [PATCH RESEND 3/5] block: Add a new helper to attempt to merge a bio Baolin Wang
2020-08-17  6:26   ` Christoph Hellwig
2020-08-17 12:10     ` Baolin Wang
2020-08-17 12:24       ` Christoph Hellwig [this message]
2020-08-18  3:30         ` Baolin Wang
2020-08-17  7:55   ` kernel test robot
2020-08-17  7:55   ` [PATCH] block: fix boolconv.cocci warnings kernel test robot
2020-08-17  4:09 ` [PATCH RESEND 4/5] block: Remove blk_mq_attempt_merge() function Baolin Wang
2020-08-17  6:31   ` Christoph Hellwig
2020-08-17 12:10     ` Baolin Wang
2020-08-17  4:09 ` [PATCH RESEND 5/5] block: Remove __blk_mq_sched_bio_merge() helper Baolin Wang
2020-08-17  6:32   ` Christoph Hellwig
2020-08-17 12:14     ` Baolin Wang
2020-08-17 12:26       ` Christoph Hellwig
2020-08-18  3:29         ` Baolin Wang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200817122440.GA2213@lst.de \
    --to=hch@lst.de \
    --cc=axboe@kernel.dk \
    --cc=baolin.wang7@gmail.com \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=ming.lei@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome