From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
To: Vincent Mailhol <mailhol.vincent@wanadoo.fr>
Cc: linux-kernel@vger.kernel.org, netdev@vger.kernel.org,
linux-can@vger.kernel.org,
Wolfgang Grandegger <wg@grandegger.com>,
Marc Kleine-Budde <mkl@pengutronix.de>,
"David S . Miller" <davem@davemloft.net>,
Jakub Kicinski <kuba@kernel.org>,
Masahiro Yamada <masahiroy@kernel.org>,
Arunachalam Santhanam <arunachalam.santhanam@in.bosch.com>,
Oliver Neukum <oneukum@suse.com>,
"open list:USB ACM DRIVER" <linux-usb@vger.kernel.org>
Subject: Re: [PATCH v2 5/6] can: usb: etas_es58X: add support for ETAS ES58X CAN USB interfaces
Date: Wed, 30 Sep 2020 18:18:38 +0200 [thread overview]
Message-ID: <20200930161838.GB1663344@kroah.com> (raw)
In-Reply-To: <20200930144602.10290-6-mailhol.vincent@wanadoo.fr>
On Wed, Sep 30, 2020 at 11:45:32PM +0900, Vincent Mailhol wrote:
> + num_element =
> + es58x_msg_num_element(es58x_dev->dev,
> + bulk_rx_loopback_msg->rx_loopback_msg,
> + msg_len);
> + if (unlikely(num_element <= 0))
> + return num_element;
Meta-comment on your use of 'unlikely' everywhere. Please drop it, it's
only to be used if you can actually measure the difference in a
benchmark. You are dealing with USB devices, which are really really
slow here. Also, humans make horrible guessers for this type of thing,
the compiler and CPU can get this right much more often than we can, and
we had the numbers for it (someone measured that 80-90% of our usages of
these markings are actually wrong on modern cpus).
So just drop them all, it makes the code simpler to read and understand,
and the cpu can actually go faster.
thanks,
greg k-h
next prev parent reply other threads:[~2020-09-30 16:18 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-09-26 17:57 [PATCH 0/6] can: add support for ETAS ES58X CAN USB Vincent Mailhol
2020-09-26 17:57 ` [PATCH 1/6] can: dev: can_get_echo_skb(): prevent call to kfree_skb() in hard IRQ context Vincent Mailhol
2020-09-26 17:57 ` [PATCH 2/6] can: dev: add a helper function to get the correct length of Classical frames Vincent Mailhol
2020-09-26 17:57 ` [PATCH 3/6] can: dev: __can_get_echo_skb(): fix the return length Vincent Mailhol
2020-09-26 17:57 ` [PATCH 4/6] can: dev: add a helper function to calculate the duration of one bit Vincent Mailhol
2020-09-26 17:57 ` [PATCH 5/6] can: usb: etas_es58X: add support for ETAS ES58X CAN USB interfaces Vincent Mailhol
2020-09-26 17:57 ` [PATCH 6/6] USB: cdc-acm: blacklist ETAS ES58X device Vincent Mailhol
2020-09-27 5:45 ` Greg Kroah-Hartman
2020-09-27 5:52 ` Greg Kroah-Hartman
2020-09-29 2:15 ` Vincent Mailhol
2020-09-30 14:45 ` [PATCH v2 0/6] can: add support for ETAS ES58X CAN USB Vincent Mailhol
2020-09-30 14:45 ` [PATCH v2 1/6] can: dev: can_get_echo_skb(): prevent call to kfree_skb() in hard IRQ context Vincent Mailhol
2020-09-30 14:45 ` [PATCH v2 2/6] can: dev: add a helper function to get the correct length of Classical frames Vincent Mailhol
2020-09-30 15:21 ` Marc Kleine-Budde
2020-10-01 15:45 ` [PATCH v2 2/6] can: dev: add a helper function Vincent Mailhol
2020-10-01 15:51 ` Marc Kleine-Budde
2020-09-30 14:45 ` [PATCH v2 3/6] can: dev: __can_get_echo_skb(): fix the return length Vincent Mailhol
2020-09-30 14:45 ` [PATCH v2 4/6] can: dev: add a helper function to calculate the duration of one bit Vincent Mailhol
2020-09-30 14:45 ` [PATCH v2 5/6] can: usb: etas_es58X: add support for ETAS ES58X CAN USB interfaces Vincent Mailhol
2020-09-30 16:18 ` Greg Kroah-Hartman [this message]
2020-10-01 15:56 ` Vincent Mailhol
2020-09-30 14:45 ` [PATCH v2 6/6] usb: cdc-acm: add quirk to blacklist ETAS ES58X devices Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 0/7] can: add support for ETAS ES58X CAN USB Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 1/7] can: dev: can_get_echo_skb(): prevent call to kfree_skb() in hard IRQ context Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 2/7] can: dev: fix type of get_can_dlc() and get_canfd_dlc() macros Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 3/7] can: dev: add a helper function to get the correct length of Classical frames Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 4/7] can: dev: __can_get_echo_skb(): fix the return length Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 5/7] can: dev: add a helper function to calculate the duration of one bit Vincent Mailhol
2020-10-04 11:06 ` Marc Kleine-Budde
2020-10-04 11:10 ` Marc Kleine-Budde
2020-10-02 15:41 ` [PATCH v3 6/7] can: usb: etas_es58X: add support for ETAS ES58X CAN USB interfaces Vincent Mailhol
2020-10-04 12:06 ` Marc Kleine-Budde
2020-10-10 8:12 ` Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 7/7] usb: cdc-acm: add quirk to blacklist ETAS ES58X devices Vincent Mailhol
2020-10-05 11:14 ` Greg Kroah-Hartman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200930161838.GB1663344@kroah.com \
--to=gregkh@linuxfoundation.org \
--cc=arunachalam.santhanam@in.bosch.com \
--cc=davem@davemloft.net \
--cc=kuba@kernel.org \
--cc=linux-can@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=mailhol.vincent@wanadoo.fr \
--cc=masahiroy@kernel.org \
--cc=mkl@pengutronix.de \
--cc=netdev@vger.kernel.org \
--cc=oneukum@suse.com \
--cc=wg@grandegger.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®