From: Vincent Mailhol <mailhol.vincent@wanadoo.fr>
To: Marc Kleine-Budde <mkl@pengutronix.de>,
linux-kernel@vger.kernel.org, netdev@vger.kernel.org,
linux-can@vger.kernel.org,
Wolfgang Grandegger <wg@grandegger.com>,
"David S . Miller" <davem@davemloft.net>
Cc: Vincent Mailhol <mailhol.vincent@wanadoo.fr>,
Jakub Kicinski <kuba@kernel.org>,
Oliver Neukum <oneukum@suse.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Masahiro Yamada <masahiroy@kernel.org>,
Arunachalam Santhanam <arunachalam.santhanam@in.bosch.com>
Subject: Re: [PATCH v2 2/6] can: dev: add a helper function
Date: Fri, 2 Oct 2020 00:45:31 +0900 [thread overview]
Message-ID: <20201001154531.3217-1-mailhol.vincent@wanadoo.fr> (raw)
In-Reply-To: <1798400d-abc1-e6dd-2d19-41e82ca6e43e@pengutronix.de>
> > +static inline int get_can_len(struct sk_buff *skb)
>
> make this return an u8
> make the skb const
>
> > +{
> > + struct canfd_frame *cf =3D (struct canfd_frame *)skb->data;
>
> const
>
> > +
> > + if (can_is_canfd_skb(skb))
> > + return min_t(__u8, cf->len, CANFD_MAX_DLEN);
>
> u8
>
> > + else if (cf->can_id & CAN_RTR_FLAG)
> > + return 0;
> > + else
> > + return min_t(__u8, cf->len, CAN_MAX_DLEN);
>
> u8
Noted. All those changes will be addressed in v3 series.
Thank you.
As a side note, macros get_can_dlc() and get_canfd_dlc of the same
file (include/linux/can/dev.h) also use __u8 instead of u8. Do you
want me to add a patch to change these as below?
/*
* get_can_dlc(value) - helper macro to cast a given data length code (dlc)
- * to __u8 and ensure the dlc value to be max. 8 bytes.
+ * to u8 and ensure the dlc value to be max. 8 bytes.
*
* To be used in the CAN netdriver receive path to ensure conformance with
* ISO 11898-1 Chapter 8.4.2.3 (DLC field)
*/
-#define get_can_dlc(i) (min_t(__u8, (i), CAN_MAX_DLC))
-#define get_canfd_dlc(i) (min_t(__u8, (i), CANFD_MAX_DLC))
+#define get_can_dlc(i) (min_t(u8, (i), CAN_MAX_DLC))
+#define get_canfd_dlc(i) (min_t(u8, (i), CANFD_MAX_DLC))
/* Check for outgoing skbs that have not been created by the CAN subsystem */
static inline bool can_skb_headroom_valid(struct net_device *dev,
next prev parent reply other threads:[~2020-10-01 15:46 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-09-26 17:57 [PATCH 0/6] can: add support for ETAS ES58X CAN USB Vincent Mailhol
2020-09-26 17:57 ` [PATCH 1/6] can: dev: can_get_echo_skb(): prevent call to kfree_skb() in hard IRQ context Vincent Mailhol
2020-09-26 17:57 ` [PATCH 2/6] can: dev: add a helper function to get the correct length of Classical frames Vincent Mailhol
2020-09-26 17:57 ` [PATCH 3/6] can: dev: __can_get_echo_skb(): fix the return length Vincent Mailhol
2020-09-26 17:57 ` [PATCH 4/6] can: dev: add a helper function to calculate the duration of one bit Vincent Mailhol
2020-09-26 17:57 ` [PATCH 5/6] can: usb: etas_es58X: add support for ETAS ES58X CAN USB interfaces Vincent Mailhol
2020-09-26 17:57 ` [PATCH 6/6] USB: cdc-acm: blacklist ETAS ES58X device Vincent Mailhol
2020-09-27 5:45 ` Greg Kroah-Hartman
2020-09-27 5:52 ` Greg Kroah-Hartman
2020-09-29 2:15 ` Vincent Mailhol
2020-09-30 14:45 ` [PATCH v2 0/6] can: add support for ETAS ES58X CAN USB Vincent Mailhol
2020-09-30 14:45 ` [PATCH v2 1/6] can: dev: can_get_echo_skb(): prevent call to kfree_skb() in hard IRQ context Vincent Mailhol
2020-09-30 14:45 ` [PATCH v2 2/6] can: dev: add a helper function to get the correct length of Classical frames Vincent Mailhol
2020-09-30 15:21 ` Marc Kleine-Budde
2020-10-01 15:45 ` Vincent Mailhol [this message]
2020-10-01 15:51 ` [PATCH v2 2/6] can: dev: add a helper function Marc Kleine-Budde
2020-09-30 14:45 ` [PATCH v2 3/6] can: dev: __can_get_echo_skb(): fix the return length Vincent Mailhol
2020-09-30 14:45 ` [PATCH v2 4/6] can: dev: add a helper function to calculate the duration of one bit Vincent Mailhol
2020-09-30 14:45 ` [PATCH v2 5/6] can: usb: etas_es58X: add support for ETAS ES58X CAN USB interfaces Vincent Mailhol
2020-09-30 16:18 ` Greg Kroah-Hartman
2020-10-01 15:56 ` Vincent Mailhol
2020-09-30 14:45 ` [PATCH v2 6/6] usb: cdc-acm: add quirk to blacklist ETAS ES58X devices Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 0/7] can: add support for ETAS ES58X CAN USB Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 1/7] can: dev: can_get_echo_skb(): prevent call to kfree_skb() in hard IRQ context Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 2/7] can: dev: fix type of get_can_dlc() and get_canfd_dlc() macros Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 3/7] can: dev: add a helper function to get the correct length of Classical frames Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 4/7] can: dev: __can_get_echo_skb(): fix the return length Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 5/7] can: dev: add a helper function to calculate the duration of one bit Vincent Mailhol
2020-10-04 11:06 ` Marc Kleine-Budde
2020-10-04 11:10 ` Marc Kleine-Budde
2020-10-02 15:41 ` [PATCH v3 6/7] can: usb: etas_es58X: add support for ETAS ES58X CAN USB interfaces Vincent Mailhol
2020-10-04 12:06 ` Marc Kleine-Budde
2020-10-10 8:12 ` Vincent Mailhol
2020-10-02 15:41 ` [PATCH v3 7/7] usb: cdc-acm: add quirk to blacklist ETAS ES58X devices Vincent Mailhol
2020-10-05 11:14 ` Greg Kroah-Hartman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20201001154531.3217-1-mailhol.vincent@wanadoo.fr \
--to=mailhol.vincent@wanadoo.fr \
--cc=arunachalam.santhanam@in.bosch.com \
--cc=davem@davemloft.net \
--cc=gregkh@linuxfoundation.org \
--cc=kuba@kernel.org \
--cc=linux-can@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=masahiroy@kernel.org \
--cc=mkl@pengutronix.de \
--cc=netdev@vger.kernel.org \
--cc=oneukum@suse.com \
--cc=wg@grandegger.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®