From: Masami Hiramatsu <mhiramat@kernel.org>
To: Borislav Petkov <bp@alien8.de>
Cc: Andy Lutomirski <luto@amacapital.net>, X86 ML <x86@kernel.org>,
LKML <linux-kernel@vger.kernel.org>
Subject: Re: [RFC PATCH v0 03/19] x86/insn: Add an insn_decode() API
Date: Fri, 27 Nov 2020 14:54:23 +0900 [thread overview]
Message-ID: <20201127145423.53415b1e90007355159d718d@kernel.org> (raw)
In-Reply-To: <20201126175011.GE31565@zn.tnic>
On Thu, 26 Nov 2020 18:50:11 +0100
Borislav Petkov <bp@alien8.de> wrote:
> On Thu, Nov 26, 2020 at 10:37:09AM +0900, Masami Hiramatsu wrote:
> > BTW, the instruction validation depends on who needs it, because to
> > check the all invalid ops, we need more information in the x86-opcode-map.txt
> > and it will bloat up the table size and consumes more time to analysis.
>
> Yes, the decoder is supposed to serve the kernel's needs, not be a
> general purpose one.
>
> > (Moreover, it depends on the processor generation -- older processor will
> > not support VEX prefix, those are invalid)
>
> Why does the processor VEX support matter? Isn't the decoder supposed to
> decode any instruction it knows about, regardless of the CPU it runs on?
Hm, you meant the "invalid" means "that can not be decoded" ?
Then it is OK. I Thought "invalid" means "the processor can not execute
(some exception will occur)".
>
> > OK, then could you use -1 instead of 1? It may allow us to expand it
> > to return error code in the future.
>
> Ok, sure.
Thanks!
>
> > I think insn_get_prefixes() can be used independently, because x86
> > perfix bytes is very complex.
>
> Yah, it all depends on what API interfaces we want to give to users and
> make those other helpers internal. Time and usecases will tell.
>
> Thx.
>
> --
> Regards/Gruss,
> Boris.
>
> https://people.kernel.org/tglx/notes-about-netiquette
--
Masami Hiramatsu <mhiramat@kernel.org>
next prev parent reply other threads:[~2020-11-27 5:54 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-11-24 10:19 [RFC PATCH v0 00/19] " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 01/19] x86/insn: Rename insn_decode() to insn_decode_regs() Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 02/19] x86/insn: Add @buf_len param to insn_init() kernel-doc comment Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 03/19] x86/insn: Add an insn_decode() API Borislav Petkov
2020-11-25 16:53 ` Masami Hiramatsu
2020-11-25 19:25 ` Borislav Petkov
2020-11-26 1:37 ` Masami Hiramatsu
2020-11-26 17:50 ` Borislav Petkov
2020-11-27 5:54 ` Masami Hiramatsu [this message]
2020-11-24 10:19 ` [RFC PATCH v0 04/19] x86/insn-eval: Handle return values from the decoder Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 05/19] x86/boot/compressed/sev-es: Convert to insn_decode() Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 06/19] perf/x86/intel/ds: Check insn_get_length() retval Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 07/19] perf/x86/intel/ds: Check return values of insn decoder functions Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 08/19] x86/alternative: Use insn_decode() Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 09/19] x86/mce: Convert to insn_decode() Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 10/19] x86/kprobes: " Borislav Petkov
2020-11-25 17:19 ` Masami Hiramatsu
2020-11-24 10:19 ` [RFC PATCH v0 11/19] x86/sev-es: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 12/19] x86/traps: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 13/19] x86/uprobes: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 14/19] x86/tools/insn_decoder_test: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 15/19] tools/objtool: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 16/19] x86/tools/insn_sanity: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 17/19] tools/perf: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 18/19] x86/insn: Remove kernel_insn_init() Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 19/19] x86/insn: Make insn_complete() static Borislav Petkov
2020-11-24 17:46 ` [RFC PATCH v0 00/19] x86/insn: Add an insn_decode() API Borislav Petkov
2020-11-25 8:03 ` Masami Hiramatsu
2020-11-27 17:45 ` Andy Lutomirski
2020-11-27 22:35 ` Borislav Petkov
2020-11-29 8:50 ` Masami Hiramatsu
2020-11-30 13:44 ` Borislav Petkov
2020-11-30 17:21 ` Masami Hiramatsu
2020-12-02 18:04 ` Borislav Petkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20201127145423.53415b1e90007355159d718d@kernel.org \
--to=mhiramat@kernel.org \
--cc=bp@alien8.de \
--cc=linux-kernel@vger.kernel.org \
--cc=luto@amacapital.net \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome