From: Borislav Petkov <bp@alien8.de>
To: Masami Hiramatsu <mhiramat@kernel.org>
Cc: Andy Lutomirski <luto@amacapital.net>, X86 ML <x86@kernel.org>,
LKML <linux-kernel@vger.kernel.org>
Subject: Re: [RFC PATCH v0 00/19] x86/insn: Add an insn_decode() API
Date: Mon, 30 Nov 2020 14:44:42 +0100 [thread overview]
Message-ID: <20201130134442.GB6019@zn.tnic> (raw)
In-Reply-To: <20201129175005.7e07a9f799e888ffd5f4ed67@kernel.org>
On Sun, Nov 29, 2020 at 05:50:05PM +0900, Masami Hiramatsu wrote:
> Good point. I think we can return, e.g. -EFAULT if we failed in
> get_next(). Then, we can read out next page, for example.
Why -EFAULT?
Running this
size = 1;
ret = insn_decode(&insn, b, size, INSN_MODE_64)
i.e., buffer size is 1:
./arch/x86/tools/insn_sanity: Success: decoded and checked 10000 random instructions with 0 errors (seed:0x9994a137)
insn buffer:
0x48 0xcf 0x48 0x83 0x90 0x90 0x90 0x90 0x90 0x90 0x90 0x90 0x90 0x90 0x90
supplied buf size: 15, ret 0
supplied buf size: 2, ret 0
supplied buf size: 3, ret 0
supplied buf size: 4, ret 0
insn_decode: entry
insn_decode: will get_length
insn_get_immediate: getting immediate
insn_get_displacement: getting displacement
insn_get_sib: getting sib
insn_get_modrm: entry
insn_get_opcode: entry
insn_get_prefixes: entry, prefixes->got: 0
insn_get_prefixes: 1
insn_get_prefixes: REX
insn_get_prefixes: VEX
insn_get_prefixes: validate_next: 0
insn_get_prefixes: insn->next_byte: 0x7ffec297c3e1, insn->end_kaddr: 0x7ffec297c3e1
insn_get_prefixes: errored out
supplied buf size: 1, ret -22
is caught in validate_next() where ->next_byte == ->end_kaddr.
I'm thinking we should return EOF here, to denote that we're reached the
end and then propagate that error up the callchain.
We don't have "define EOF" in the kernel but we can designate one for
the insn decoder, perhaps
#define EOF -1
as stdio.h does:
/* The value returned by fgetc and similar functions to indicate the
end of the file. */
#define EOF (-1)
Hmm, but then the callers would need to know EOF too so maybe EIO or
something.
In any case, it should be a value which callers should be able to use to
get told that input buffer is truncated...
Thx.
--
Regards/Gruss,
Boris.
https://people.kernel.org/tglx/notes-about-netiquette
next prev parent reply other threads:[~2020-11-30 13:45 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-11-24 10:19 Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 01/19] x86/insn: Rename insn_decode() to insn_decode_regs() Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 02/19] x86/insn: Add @buf_len param to insn_init() kernel-doc comment Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 03/19] x86/insn: Add an insn_decode() API Borislav Petkov
2020-11-25 16:53 ` Masami Hiramatsu
2020-11-25 19:25 ` Borislav Petkov
2020-11-26 1:37 ` Masami Hiramatsu
2020-11-26 17:50 ` Borislav Petkov
2020-11-27 5:54 ` Masami Hiramatsu
2020-11-24 10:19 ` [RFC PATCH v0 04/19] x86/insn-eval: Handle return values from the decoder Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 05/19] x86/boot/compressed/sev-es: Convert to insn_decode() Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 06/19] perf/x86/intel/ds: Check insn_get_length() retval Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 07/19] perf/x86/intel/ds: Check return values of insn decoder functions Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 08/19] x86/alternative: Use insn_decode() Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 09/19] x86/mce: Convert to insn_decode() Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 10/19] x86/kprobes: " Borislav Petkov
2020-11-25 17:19 ` Masami Hiramatsu
2020-11-24 10:19 ` [RFC PATCH v0 11/19] x86/sev-es: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 12/19] x86/traps: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 13/19] x86/uprobes: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 14/19] x86/tools/insn_decoder_test: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 15/19] tools/objtool: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 16/19] x86/tools/insn_sanity: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 17/19] tools/perf: " Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 18/19] x86/insn: Remove kernel_insn_init() Borislav Petkov
2020-11-24 10:19 ` [RFC PATCH v0 19/19] x86/insn: Make insn_complete() static Borislav Petkov
2020-11-24 17:46 ` [RFC PATCH v0 00/19] x86/insn: Add an insn_decode() API Borislav Petkov
2020-11-25 8:03 ` Masami Hiramatsu
2020-11-27 17:45 ` Andy Lutomirski
2020-11-27 22:35 ` Borislav Petkov
2020-11-29 8:50 ` Masami Hiramatsu
2020-11-30 13:44 ` Borislav Petkov [this message]
2020-11-30 17:21 ` Masami Hiramatsu
2020-12-02 18:04 ` Borislav Petkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20201130134442.GB6019@zn.tnic \
--to=bp@alien8.de \
--cc=linux-kernel@vger.kernel.org \
--cc=luto@amacapital.net \
--cc=mhiramat@kernel.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®