* [PATCH] swiotlb: manipulate orig_addr when tlb_addr has offset [not found] <CGME20210510083139epcas2p211d9bee16e5e8f8ea34e606c83ac3a55@epcas2p2.samsung.com> @ 2021-05-10 8:30 ` Chanho Park 2021-05-10 8:44 ` Christoph Hellwig 0 siblings, 1 reply; 3+ messages in thread From: Chanho Park @ 2021-05-10 8:30 UTC (permalink / raw) To: Konrad Rzeszutek Wilk, Christoph Hellwig Cc: Marek Szyprowski, Robin Murphy, iommu, linux-kernel, Bumyong Lee, Chanho Park From: Bumyong Lee <bumyong.lee@samsung.com> in case of driver wants to sync part of ranges with offset, swiotlb_tbl_sync_single() copies from orig_addr base to tlb_addr with offset it makes data mismatch it removed from "swiotlb: don't modify orig_addr in swiotlb_tbl_sync_single", but it have to be recovered 1. Get dma_addr_t from dma_map_single() dma_addr_t tlb_addr = dma_map_single(dev, vaddr, vsize, DMA_TO_DEVICE); |<---------------vsize------------->| +-----------------------------------+ | | original buffer +-----------------------------------+ vaddr swiotlb_align_offset |<----->|<---------------vsize------------->| +-------+-----------------------------------+ | | | swiotlb buffer +-------+-----------------------------------+ tlb_addr 2. Do something 3. Sync dma_addr_t through dma_sync_single_for_device(..) dma_sync_single_for_device(dev, tlb_addr + offset, size, DMA_TO_DEVICE); Error case. copy data to original buffer. but it is from base addr in original buffer |<----->|<- offset ->|<- size ->| +-------+-----------------------------------+ | | |##########| | swiotlb buffer +-------+-----------------------------------+ tlb_addr swiotlb_align_offset |<----->|<- offset ->|<- size ->| +-------+-----------------------------------+ | | |##########| | swiotlb buffer +-------+-----------------------------------+ tlb_addr |<- size ->| +-----------------------------------+ |##########| | original buffer +-----------------------------------+ vaddr FIX. copy data to original buffer. but it is from base addr in original buffer swiotlb_align_offset |<----->|<- offset ->|<- size ->| +-------+-----------------------------------+ | | |##########| | swiotlb buffer +-------+-----------------------------------+ tlb_addr |<- offset ->|<- size ->| +-----------------------------------+ | |##########| | original buffer +-----------------------------------+ vaddr Fixes: 16fc3cef33a0 ("swiotlb: don't modify orig_addr in swiotlb_tbl_sync_single") Signed-off-by: Bumyong Lee <bumyong.lee@samsung.com> Signed-off-by: Chanho Park <chanho61.park@samsung.com> --- kernel/dma/swiotlb.c | 8 ++++++++ 1 file changed, 8 insertions(+) diff --git a/kernel/dma/swiotlb.c b/kernel/dma/swiotlb.c index 8ca7d505d61c..e8243725e298 100644 --- a/kernel/dma/swiotlb.c +++ b/kernel/dma/swiotlb.c @@ -334,6 +334,7 @@ void __init swiotlb_exit(void) io_tlb_default_mem = NULL; } +static unsigned int swiotlb_align_offset(struct device *dev, u64 addr); /* * Bounce: copy the swiotlb buffer from or back to the original dma location */ @@ -346,10 +347,17 @@ static void swiotlb_bounce(struct device *dev, phys_addr_t tlb_addr, size_t size size_t alloc_size = mem->slots[index].alloc_size; unsigned long pfn = PFN_DOWN(orig_addr); unsigned char *vaddr = phys_to_virt(tlb_addr); + unsigned int tlb_offset; if (orig_addr == INVALID_PHYS_ADDR) return; + tlb_offset = (unsigned int)tlb_addr & (IO_TLB_SIZE - 1); + tlb_offset -= swiotlb_align_offset(dev, orig_addr); + + orig_addr += tlb_offset; + alloc_size -= tlb_offset; + if (size > alloc_size) { dev_WARN_ONCE(dev, 1, "Buffer overflow detected. Allocation size: %zu. Mapping size: %zu.\n", -- 2.31.1 ^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] swiotlb: manipulate orig_addr when tlb_addr has offset 2021-05-10 8:30 ` [PATCH] swiotlb: manipulate orig_addr when tlb_addr has offset Chanho Park @ 2021-05-10 8:44 ` Christoph Hellwig 2021-05-10 9:04 ` Chanho Park 0 siblings, 1 reply; 3+ messages in thread From: Christoph Hellwig @ 2021-05-10 8:44 UTC (permalink / raw) To: Chanho Park Cc: Konrad Rzeszutek Wilk, Christoph Hellwig, Marek Szyprowski, Robin Murphy, iommu, linux-kernel, Bumyong Lee On Mon, May 10, 2021 at 05:30:57PM +0900, Chanho Park wrote: > +static unsigned int swiotlb_align_offset(struct device *dev, u64 addr); Please just move swiotlb_align_offset up to avoid the forward declaration. > /* > * Bounce: copy the swiotlb buffer from or back to the original dma location > */ > @@ -346,10 +347,17 @@ static void swiotlb_bounce(struct device *dev, phys_addr_t tlb_addr, size_t size > size_t alloc_size = mem->slots[index].alloc_size; > unsigned long pfn = PFN_DOWN(orig_addr); > unsigned char *vaddr = phys_to_virt(tlb_addr); > + unsigned int tlb_offset; > > if (orig_addr == INVALID_PHYS_ADDR) > return; > > + tlb_offset = (unsigned int)tlb_addr & (IO_TLB_SIZE - 1); > + tlb_offset -= swiotlb_align_offset(dev, orig_addr); Nit: I'd write this as: tlb_offset = (tlb_addr & (IO_TLB_SIZE - 1)) - swiotlb_align_offset(dev, orig_addr); as there is no need for the cast, and just having a single assignment is easier to follow. ^ permalink raw reply [flat|nested] 3+ messages in thread
* RE: [PATCH] swiotlb: manipulate orig_addr when tlb_addr has offset 2021-05-10 8:44 ` Christoph Hellwig @ 2021-05-10 9:04 ` Chanho Park 0 siblings, 0 replies; 3+ messages in thread From: Chanho Park @ 2021-05-10 9:04 UTC (permalink / raw) To: 'Christoph Hellwig' Cc: 'Konrad Rzeszutek Wilk', 'Marek Szyprowski', 'Robin Murphy', iommu, linux-kernel, 'Bumyong Lee' (RESEND due to wrong encrypted message setting) Hi, > On Mon, May 10, 2021 at 05:30:57PM +0900, Chanho Park wrote: > > +static unsigned int swiotlb_align_offset(struct device *dev, u64 > > +addr); > > Please just move swiotlb_align_offset up to avoid the forward declaration. Okay. I'll move the position of the function next patch. > > > /* > > * Bounce: copy the swiotlb buffer from or back to the original dma > location > > */ > > @@ -346,10 +347,17 @@ static void swiotlb_bounce(struct device *dev, > phys_addr_t tlb_addr, size_t size > > size_t alloc_size = mem->slots[index].alloc_size; > > unsigned long pfn = PFN_DOWN(orig_addr); > > unsigned char *vaddr = phys_to_virt(tlb_addr); > > + unsigned int tlb_offset; > > > > if (orig_addr == INVALID_PHYS_ADDR) > > return; > > > > + tlb_offset = (unsigned int)tlb_addr & (IO_TLB_SIZE - 1); > > + tlb_offset -= swiotlb_align_offset(dev, orig_addr); > > Nit: I'd write this as: > > tlb_offset = (tlb_addr & (IO_TLB_SIZE - 1)) - > swiotlb_align_offset(dev, orig_addr); > > as there is no need for the cast, and just having a single assignment is > easier to follow. Great. It can be a single assignment as you suggested. Best Regards, Chanho Park ^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2021-05-10 9:04 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
[not found] <CGME20210510083139epcas2p211d9bee16e5e8f8ea34e606c83ac3a55@epcas2p2.samsung.com>
2021-05-10 8:30 ` [PATCH] swiotlb: manipulate orig_addr when tlb_addr has offset Chanho Park
2021-05-10 8:44 ` Christoph Hellwig
2021-05-10 9:04 ` Chanho Park
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®