* [PATCH] driver core: replace open-coded device_lock_assert()
@ 2021-05-12 14:10 Julian Wiedmann
0 siblings, 0 replies; only message in thread
From: Julian Wiedmann @ 2021-05-12 14:10 UTC (permalink / raw)
To: Greg Kroah-Hartman; +Cc: Rafael J. Wysocki, linux-kernel, Julian Wiedmann
Using the right wrapper makes it easier to associate this assert
statement with the device_[un]lock() helpers.
Signed-off-by: Julian Wiedmann <jwi@linux.ibm.com>
---
drivers/base/core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/base/core.c b/drivers/base/core.c
index 4a8bf8cda52b..bfa3536d48df 100644
--- a/drivers/base/core.c
+++ b/drivers/base/core.c
@@ -3437,7 +3437,7 @@ bool kill_device(struct device *dev)
* to run while we are tearing out the bus/class/sysfs from
* underneath the device.
*/
- lockdep_assert_held(&dev->mutex);
+ device_lock_assert(dev);
if (dev->p->dead)
return false;
--
2.25.1
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2021-05-12 14:11 UTC | newest]
Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-05-12 14:10 [PATCH] driver core: replace open-coded device_lock_assert() Julian Wiedmann
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®