From: Maximilian Luz <luzmaximilian@gmail.com>
To: platform-driver-x86@vger.kernel.org
Cc: Maximilian Luz <luzmaximilian@gmail.com>,
Hans de Goede <hdegoede@redhat.com>,
Mark Gross <markgross@kernel.org>,
linux-kernel@vger.kernel.org
Subject: [PATCH 0/3] platform/surface: aggregator: Clean up client device removal
Date: Thu, 28 Oct 2021 02:22:40 +0200 [thread overview]
Message-ID: <20211028002243.1586083-1-luzmaximilian@gmail.com> (raw)
Remove some duplicate code for Surface Aggregator client device removal and
rename a function for consistency.
Maximilian Luz (3):
platform/surface: aggregator: Make client device removal more generic
platform/surface: aggregator_registry: Use generic client removal
function
platform/surface: aggregator_registry: Rename device registration
function
drivers/platform/surface/aggregator/bus.c | 24 +++++---------
drivers/platform/surface/aggregator/bus.h | 3 --
drivers/platform/surface/aggregator/core.c | 3 +-
.../surface/surface_aggregator_registry.c | 32 ++++++-------------
include/linux/surface_aggregator/device.h | 9 ++++++
5 files changed, 28 insertions(+), 43 deletions(-)
--
2.33.1
next reply other threads:[~2021-10-28 0:23 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-10-28 0:22 Maximilian Luz [this message]
2021-10-28 0:22 ` [PATCH 1/3] platform/surface: aggregator: Make client device removal more generic Maximilian Luz
2021-10-28 0:22 ` [PATCH 2/3] platform/surface: aggregator_registry: Use generic client removal function Maximilian Luz
2021-10-28 0:22 ` [PATCH 3/3] platform/surface: aggregator_registry: Rename device registration function Maximilian Luz
2021-10-28 7:56 ` [PATCH 0/3] platform/surface: aggregator: Clean up client device removal Hans de Goede
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20211028002243.1586083-1-luzmaximilian@gmail.com \
--to=luzmaximilian@gmail.com \
--cc=hdegoede@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=markgross@kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®