mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/3] platform/surface: aggregator: Clean up client device removal
@ 2021-10-28  0:22 Maximilian Luz
  2021-10-28  0:22 ` [PATCH 1/3] platform/surface: aggregator: Make client device removal more generic Maximilian Luz
                   ` (3 more replies)
  0 siblings, 4 replies; 5+ messages in thread
From: Maximilian Luz @ 2021-10-28  0:22 UTC (permalink / raw)
  To: platform-driver-x86
  Cc: Maximilian Luz, Hans de Goede, Mark Gross, linux-kernel

Remove some duplicate code for Surface Aggregator client device removal and
rename a function for consistency.

Maximilian Luz (3):
  platform/surface: aggregator: Make client device removal more generic
  platform/surface: aggregator_registry: Use generic client removal
    function
  platform/surface: aggregator_registry: Rename device registration
    function

 drivers/platform/surface/aggregator/bus.c     | 24 +++++---------
 drivers/platform/surface/aggregator/bus.h     |  3 --
 drivers/platform/surface/aggregator/core.c    |  3 +-
 .../surface/surface_aggregator_registry.c     | 32 ++++++-------------
 include/linux/surface_aggregator/device.h     |  9 ++++++
 5 files changed, 28 insertions(+), 43 deletions(-)

-- 
2.33.1


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2021-10-28  7:57 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-10-28  0:22 [PATCH 0/3] platform/surface: aggregator: Clean up client device removal Maximilian Luz
2021-10-28  0:22 ` [PATCH 1/3] platform/surface: aggregator: Make client device removal more generic Maximilian Luz
2021-10-28  0:22 ` [PATCH 2/3] platform/surface: aggregator_registry: Use generic client removal function Maximilian Luz
2021-10-28  0:22 ` [PATCH 3/3] platform/surface: aggregator_registry: Rename device registration function Maximilian Luz
2021-10-28  7:56 ` [PATCH 0/3] platform/surface: aggregator: Clean up client device removal Hans de Goede

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®