* [PATCH] block: Use REQ_OP_WRITE instead of its integer constant 1 in op_is_write()
@ 2021-11-15 21:58 Bean Huo
2021-11-16 1:30 ` Chaitanya Kulkarni
0 siblings, 1 reply; 2+ messages in thread
From: Bean Huo @ 2021-11-15 21:58 UTC (permalink / raw)
To: axboe, linux-block, linux-kernel; +Cc: Bean Huo
From: Bean Huo <beanhuo@micron.com>
Use the enums REQ_OP_WRITE in op_is_write() to make it less maintenance
requirement and more readable
Signed-off-by: Bean Huo <beanhuo@micron.com>
---
include/linux/blk_types.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/linux/blk_types.h b/include/linux/blk_types.h
index fe065c394fff..5b5924a7e754 100644
--- a/include/linux/blk_types.h
+++ b/include/linux/blk_types.h
@@ -463,7 +463,7 @@ static inline void bio_set_op_attrs(struct bio *bio, unsigned op,
static inline bool op_is_write(unsigned int op)
{
- return (op & 1);
+ return (op & REQ_OP_WRITE);
}
/*
--
2.25.1
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2021-11-16 1:38 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-11-15 21:58 [PATCH] block: Use REQ_OP_WRITE instead of its integer constant 1 in op_is_write() Bean Huo
2021-11-16 1:30 ` Chaitanya Kulkarni
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome