* [PATCH] btrfs: add missing function name in btrfs_log_new_name() kernel-doc comment
@ 2022-05-26 4:39 Bagas Sanjaya
0 siblings, 0 replies; only message in thread
From: Bagas Sanjaya @ 2022-05-26 4:39 UTC (permalink / raw)
To: linux-doc
Cc: Bagas Sanjaya, Filipe Manana, Chris Mason, Josef Bacik,
David Sterba, linux-btrfs, linux-kernel
kernel test robot reported kernel-doc warning:
>> fs/btrfs/tree-log.c:6792: warning: This comment starts with '/**', but isn't a kernel-doc comment. Refer Documentation/doc-guide/kernel-doc.rst
* Update the log after adding a new name for an inode.
This has side-effect warning when invoking kernel-doc script directly:
fs/btrfs/tree-log.c:6957: warning: missing initial short description on line:
* Update the log after adding a new name for an inode.
These warnings above are caused by missing function name in the kernel-doc
comment of btrfs_log_new_name().
Fix these by adding the function name into short description on the comment
block.
Link: https://lore.kernel.org/linux-doc/202205260024.TLEp6Pj2-lkp@intel.com/
Fixes: d5f5bd546552a9 ("btrfs: pass the dentry to btrfs_log_new_name() instead of the inode")
Cc: Filipe Manana <fdmanana@suse.com>
Cc: Chris Mason <clm@fb.com>
Cc: Josef Bacik <josef@toxicpanda.com>
Cc: David Sterba <dsterba@suse.com>
Cc: linux-btrfs@vger.kernel.org
Cc: linux-kernel@vger.kernel.org
Signed-off-by: Bagas Sanjaya <bagasdotme@gmail.com>
---
fs/btrfs/tree-log.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/fs/btrfs/tree-log.c b/fs/btrfs/tree-log.c
index 370388fadf960a..d25cbe61fdb669 100644
--- a/fs/btrfs/tree-log.c
+++ b/fs/btrfs/tree-log.c
@@ -6954,7 +6954,7 @@ void btrfs_record_snapshot_destroy(struct btrfs_trans_handle *trans,
}
/**
- * Update the log after adding a new name for an inode.
+ * btrfs_log_new_name() - Update the log after adding a new name for an inode.
*
* @trans: Transaction handle.
* @old_dentry: The dentry associated with the old name and the old
base-commit: babf0bb978e3c9fce6c4eba6b744c8754fd43d8e
--
An old man doll... just what I always wanted! - Clara
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2022-05-26 4:40 UTC | newest]
Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-05-26 4:39 [PATCH] btrfs: add missing function name in btrfs_log_new_name() kernel-doc comment Bagas Sanjaya
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®