From: Zhen Lei <thunder.leizhen@huawei.com>
To: Josh Poimboeuf <jpoimboe@kernel.org>,
Jiri Kosina <jikos@kernel.org>, Miroslav Benes <mbenes@suse.cz>,
Petr Mladek <pmladek@suse.com>,
Joe Lawrence <joe.lawrence@redhat.com>,
<live-patching@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
Masahiro Yamada <masahiroy@kernel.org>,
Alexei Starovoitov <ast@kernel.org>, Jiri Olsa <jolsa@kernel.org>,
Kees Cook <keescook@chromium.org>,
Andrew Morton <akpm@linux-foundation.org>,
"Luis Chamberlain" <mcgrof@kernel.org>,
<linux-modules@vger.kernel.org>,
"Steven Rostedt" <rostedt@goodmis.org>,
Ingo Molnar <mingo@redhat.com>
Cc: Zhen Lei <thunder.leizhen@huawei.com>
Subject: [PATCH v5 00/10] kallsyms: Optimizes the performance of lookup symbols
Date: Fri, 23 Sep 2022 19:20:23 +0800 [thread overview]
Message-ID: <20220923112033.1958-1-thunder.leizhen@huawei.com> (raw)
v4 --> v5:
1. In scripts/kallsyms.c, we use an extra field to hold type and eventually
put it together with name in write_src().
2. Generate a new table kallsyms_best_token_table[], so that we compress a
symbol in the kernel using a process similar to compress_symbol().
3. Remove helper sym_name(), and rename field 'sym[]' to 'name[]' in
scripts/kallsyms.c
4. Add helper __kallsyms_lookup_compressed_name() to avoid duplicate code in
functions kallsyms_lookup_name() and kallsyms_on_each_match_symbol().
5. Add a new parameter "const char *modname" to module_kallsyms_on_each_symbol(),
this makes the code logic clearer.
6. Delete the parameter 'struct module *' in the hook function associated with
kallsyms_on_each_symbol(), it's unused now.
v3 --> v4:
1. Move the declaration of function kallsyms_sym_address() to linux/kallsyms.h,
fix a build warning.
v2 --> v3:
1. Improve test cases, perform complete functional tests on functions
kallsyms_lookup_name(), kallsyms_on_each_symbol() and
kallsyms_on_each_match_symbol().
2. Add patch [PATCH v3 2/8] scripts/kallsyms: ensure that all possible
combinations are compressed.
3. The symbol type is not compressed regardless of whether
CONFIG_KALLSYMS_ALL is set or not. The memory overhead is increased
by less than 20KiB if CONFIG_KALLSYMS_ALL=n.
4. Discard [PATCH v2 3/8] kallsyms: Adjust the types of some local variables
v1 --> v2:
Add self-test facility
v1:
Currently, to search for a symbol, we need to expand the symbols in
'kallsyms_names' one by one, and then use the expanded string for
comparison. This is very slow.
In fact, we can first compress the name being looked up and then use
it for comparison when traversing 'kallsyms_names'.
This patch series optimizes the performance of function kallsyms_lookup_name(),
and function klp_find_object_symbol() in the livepatch module. Based on the
test results, the performance overhead is reduced to 5%. That is, the
performance of these functions is improved by 20 times.
To avoid increasing the kernel size in non-debug mode, the optimization is only
for the case CONFIG_KALLSYMS_ALL=y.
Zhen Lei (10):
scripts/kallsyms: rename build_initial_tok_table()
scripts/kallsyms: don't compress symbol types
scripts/kallsyms: remove helper sym_name() and cleanup
scripts/kallsyms: generate kallsyms_best_token_table[]
kallsyms: Improve the performance of kallsyms_lookup_name()
kallsyms: Add helper kallsyms_on_each_match_symbol()
livepatch: Use kallsyms_on_each_match_symbol() to improve performance
livepatch: Improve the search performance of
module_kallsyms_on_each_symbol()
kallsyms: Delete an unused parameter related to
kallsyms_on_each_symbol()
kallsyms: Add self-test facility
include/linux/kallsyms.h | 12 +-
include/linux/module.h | 4 +-
init/Kconfig | 13 ++
kernel/Makefile | 1 +
kernel/kallsyms.c | 167 ++++++++++++++-
kernel/kallsyms_internal.h | 1 +
kernel/kallsyms_selftest.c | 421 +++++++++++++++++++++++++++++++++++++
kernel/livepatch/core.c | 31 ++-
kernel/module/kallsyms.c | 15 +-
kernel/trace/ftrace.c | 3 +-
scripts/kallsyms.c | 88 +++++---
11 files changed, 694 insertions(+), 62 deletions(-)
create mode 100644 kernel/kallsyms_selftest.c
--
2.25.1
next reply other threads:[~2022-09-23 11:22 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-09-23 11:20 Zhen Lei [this message]
2022-09-23 11:20 ` [PATCH v5 01/10] scripts/kallsyms: rename build_initial_tok_table() Zhen Lei
2022-09-23 11:20 ` [PATCH v5 02/10] scripts/kallsyms: don't compress symbol types Zhen Lei
2022-09-23 11:20 ` [PATCH v5 03/10] scripts/kallsyms: remove helper sym_name() and cleanup Zhen Lei
2022-09-23 11:20 ` [PATCH v5 04/10] scripts/kallsyms: generate kallsyms_best_token_table[] Zhen Lei
2022-09-23 11:20 ` [PATCH v5 05/10] kallsyms: Improve the performance of kallsyms_lookup_name() Zhen Lei
2022-09-23 11:20 ` [PATCH v5 06/10] kallsyms: Add helper kallsyms_on_each_match_symbol() Zhen Lei
2022-09-23 11:20 ` [PATCH v5 07/10] livepatch: Use kallsyms_on_each_match_symbol() to improve performance Zhen Lei
2022-09-23 11:20 ` [PATCH v5 08/10] livepatch: Improve the search performance of module_kallsyms_on_each_symbol() Zhen Lei
2022-09-24 1:11 ` Leizhen (ThunderTown)
2022-09-24 12:10 ` Leizhen (ThunderTown)
2022-09-23 11:20 ` [PATCH v5 09/10] kallsyms: Delete an unused parameter related to kallsyms_on_each_symbol() Zhen Lei
2022-09-23 11:20 ` [PATCH v5 10/10] kallsyms: Add self-test facility Zhen Lei
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20220923112033.1958-1-thunder.leizhen@huawei.com \
--to=thunder.leizhen@huawei.com \
--cc=akpm@linux-foundation.org \
--cc=ast@kernel.org \
--cc=jikos@kernel.org \
--cc=joe.lawrence@redhat.com \
--cc=jolsa@kernel.org \
--cc=jpoimboe@kernel.org \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-modules@vger.kernel.org \
--cc=live-patching@vger.kernel.org \
--cc=masahiroy@kernel.org \
--cc=mbenes@suse.cz \
--cc=mcgrof@kernel.org \
--cc=mingo@redhat.com \
--cc=pmladek@suse.com \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®