From: "Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
To: linux-serial@vger.kernel.org,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Jiri Slaby <jirislaby@kernel.org>,
linux-kernel@vger.kernel.org
Cc: "Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
Subject: [PATCH 1/8] serial: Use ARRAY_SIZE() with iso7816 reserved array
Date: Thu, 9 Mar 2023 10:09:16 +0200 [thread overview]
Message-ID: <20230309080923.11778-2-ilpo.jarvinen@linux.intel.com> (raw)
In-Reply-To: <20230309080923.11778-1-ilpo.jarvinen@linux.intel.com>
Instead of a literal, size the for loop iteration based on the actual
array using ARRAY_SIZE().
Signed-off-by: Ilpo Järvinen <ilpo.jarvinen@linux.intel.com>
---
drivers/tty/serial/serial_core.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/tty/serial/serial_core.c b/drivers/tty/serial/serial_core.c
index 2bd32c8ece39..ee2aabcc8943 100644
--- a/drivers/tty/serial/serial_core.c
+++ b/drivers/tty/serial/serial_core.c
@@ -15,6 +15,7 @@
#include <linux/init.h>
#include <linux/console.h>
#include <linux/gpio/consumer.h>
+#include <linux/kernel.h>
#include <linux/of.h>
#include <linux/proc_fs.h>
#include <linux/seq_file.h>
@@ -1491,7 +1492,7 @@ static int uart_set_iso7816_config(struct uart_port *port,
* There are 5 words reserved for future use. Check that userspace
* doesn't put stuff in there to prevent breakages in the future.
*/
- for (i = 0; i < 5; i++)
+ for (i = 0; i < ARRAY_SIZE(iso7816.reserved); i++)
if (iso7816.reserved[i])
return -EINVAL;
--
2.30.2
next prev parent reply other threads:[~2023-03-09 8:10 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-03-09 8:09 [PATCH 0/8] serial: Core cleanups Ilpo Järvinen
2023-03-09 8:09 ` Ilpo Järvinen [this message]
2023-03-09 8:09 ` [PATCH 2/8] serial: Use B0 instead of implicit zero assumption Ilpo Järvinen
2023-03-09 8:09 ` [PATCH 3/8] serial: Remove extern from func prototypes in headers Ilpo Järvinen
2023-03-09 8:09 ` [PATCH 4/8] serial: Move uart_change_speed() earlier Ilpo Järvinen
2023-03-09 8:09 ` [PATCH 5/8] serial: Rename uart_change_speed() to uart_change_line_settings() Ilpo Järvinen
2023-03-09 8:09 ` [PATCH 6/8] serial: Make hw_stopped bool Ilpo Järvinen
2023-03-09 8:09 ` [PATCH 7/8] serial: Rename hw_stopped to old_hw_stopped & improve logic Ilpo Järvinen
2023-03-09 8:09 ` [PATCH 8/8] serial: Remove uart_wait_until_sent() forward declaration Ilpo Järvinen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230309080923.11778-2-ilpo.jarvinen@linux.intel.com \
--to=ilpo.jarvinen@linux.intel.com \
--cc=gregkh@linuxfoundation.org \
--cc=jirislaby@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-serial@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®