mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/8] serial: Core cleanups
@ 2023-03-09  8:09 Ilpo Järvinen
  2023-03-09  8:09 ` [PATCH 1/8] serial: Use ARRAY_SIZE() with iso7816 reserved array Ilpo Järvinen
                   ` (7 more replies)
  0 siblings, 8 replies; 9+ messages in thread
From: Ilpo Järvinen @ 2023-03-09  8:09 UTC (permalink / raw)
  To: linux-serial, Greg Kroah-Hartman, Jiri Slaby
  Cc: linux-kernel, Ilpo Järvinen

Serial core cleanups.

Ilpo Järvinen (8):
  serial: Use ARRAY_SIZE() with iso7816 reserved array
  serial: Use B0 instead of implicit zero assumption
  serial: Remove extern from func prototypes in headers
  serial: Move uart_change_speed() earlier
  serial: Rename uart_change_speed() to uart_change_line_settings()
  serial: Make hw_stopped bool
  serial: Rename hw_stopped to old_hw_stopped & improve logic
  serial: Remove uart_wait_until_sent() forward declaration

 drivers/tty/serial/serial_core.c | 113 +++++++++++++++----------------
 include/linux/serial_8250.h      |  41 +++++------
 include/linux/serial_core.h      |  15 ++--
 3 files changed, 80 insertions(+), 89 deletions(-)

-- 
2.30.2


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2023-03-09  8:13 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-03-09  8:09 [PATCH 0/8] serial: Core cleanups Ilpo Järvinen
2023-03-09  8:09 ` [PATCH 1/8] serial: Use ARRAY_SIZE() with iso7816 reserved array Ilpo Järvinen
2023-03-09  8:09 ` [PATCH 2/8] serial: Use B0 instead of implicit zero assumption Ilpo Järvinen
2023-03-09  8:09 ` [PATCH 3/8] serial: Remove extern from func prototypes in headers Ilpo Järvinen
2023-03-09  8:09 ` [PATCH 4/8] serial: Move uart_change_speed() earlier Ilpo Järvinen
2023-03-09  8:09 ` [PATCH 5/8] serial: Rename uart_change_speed() to uart_change_line_settings() Ilpo Järvinen
2023-03-09  8:09 ` [PATCH 6/8] serial: Make hw_stopped bool Ilpo Järvinen
2023-03-09  8:09 ` [PATCH 7/8] serial: Rename hw_stopped to old_hw_stopped & improve logic Ilpo Järvinen
2023-03-09  8:09 ` [PATCH 8/8] serial: Remove uart_wait_until_sent() forward declaration Ilpo Järvinen

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®