mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [RESEND PATCH 0/2] ARC: fix THREAD_SHIFT and rename 16KSTACKS
@ 2023-05-25 16:08 Min-Hua Chen
  2023-05-25 16:08 ` [RESEND PATCH 1/2] ARC: fix incorrect THREAD_SHIFT definition Min-Hua Chen
  2023-05-25 16:08 ` [RESEND PATCH 2/2] ARC: rename 16KSTACKS to DEBUG_STACKS Min-Hua Chen
  0 siblings, 2 replies; 3+ messages in thread
From: Min-Hua Chen @ 2023-05-25 16:08 UTC (permalink / raw)
  To: Vineet Gupta; +Cc: linux-snps-arc, linux-kernel, Min-Hua Chen

Hi,

When I read the arch/arc code, I first noticed that the
definition of THREAD_SHIFT looks incorrect and the
description of 16KSTACKS looks confusing because there are
multiple definitions of PAGE_SHIFT. So I submit
these patches to address the issues I found.


Min-Hua Chen (2):
  ARC: fix incorrect THREAD_SHIFT definition
  ARC: rename 16KSTACKS to DEBUG_STACKS

 arch/arc/Kconfig.debug             | 7 ++++---
 arch/arc/include/asm/thread_info.h | 4 ++--
 2 files changed, 6 insertions(+), 5 deletions(-)

-- 
2.34.1


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2023-05-25 16:09 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-05-25 16:08 [RESEND PATCH 0/2] ARC: fix THREAD_SHIFT and rename 16KSTACKS Min-Hua Chen
2023-05-25 16:08 ` [RESEND PATCH 1/2] ARC: fix incorrect THREAD_SHIFT definition Min-Hua Chen
2023-05-25 16:08 ` [RESEND PATCH 2/2] ARC: rename 16KSTACKS to DEBUG_STACKS Min-Hua Chen

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®