* [PATCH] KVM: x86: Update the variable naming in kvm_x86_ops.sched_in()
@ 2023-10-17 23:26 Mingwei Zhang
2023-10-18 1:16 ` Sean Christopherson
0 siblings, 1 reply; 2+ messages in thread
From: Mingwei Zhang @ 2023-10-17 23:26 UTC (permalink / raw)
To: Sean Christopherson, Paolo Bonzini
Cc: H. Peter Anvin, kvm, linux-kernel, Mingwei Zhang
Update the variable with name 'kvm' in kvm_x86_ops.sched_in() to 'vcpu' to
avoid confusions. Variable naming in KVM has a clear convention that 'kvm'
refers to pointer of type 'struct kvm *', while 'vcpu' refers to pointer of
type 'struct kvm_vcpu *'.
Fix this 9-year old naming issue for fun.
Signed-off-by: Mingwei Zhang <mizhang@google.com>
---
arch/x86/include/asm/kvm_host.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/include/asm/kvm_host.h b/arch/x86/include/asm/kvm_host.h
index 7c228ae05df0..394e1a31c02c 100644
--- a/arch/x86/include/asm/kvm_host.h
+++ b/arch/x86/include/asm/kvm_host.h
@@ -1703,7 +1703,7 @@ struct kvm_x86_ops {
void (*request_immediate_exit)(struct kvm_vcpu *vcpu);
- void (*sched_in)(struct kvm_vcpu *kvm, int cpu);
+ void (*sched_in)(struct kvm_vcpu *vcpu, int cpu);
/*
* Size of the CPU's dirty log buffer, i.e. VMX's PML buffer. A zero
base-commit: 437bba5ad2bba00c2056c896753a32edf80860cc
--
2.42.0.655.g421f12c284-goog
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH] KVM: x86: Update the variable naming in kvm_x86_ops.sched_in()
2023-10-17 23:26 [PATCH] KVM: x86: Update the variable naming in kvm_x86_ops.sched_in() Mingwei Zhang
@ 2023-10-18 1:16 ` Sean Christopherson
0 siblings, 0 replies; 2+ messages in thread
From: Sean Christopherson @ 2023-10-18 1:16 UTC (permalink / raw)
To: Sean Christopherson, Paolo Bonzini, Mingwei Zhang
Cc: H. Peter Anvin, kvm, linux-kernel
On Tue, 17 Oct 2023 23:26:10 +0000, Mingwei Zhang wrote:
> Update the variable with name 'kvm' in kvm_x86_ops.sched_in() to 'vcpu' to
> avoid confusions. Variable naming in KVM has a clear convention that 'kvm'
> refers to pointer of type 'struct kvm *', while 'vcpu' refers to pointer of
> type 'struct kvm_vcpu *'.
>
> Fix this 9-year old naming issue for fun.
>
> [...]
Applied to kvm-x86 misc, thanks!
[1/1] KVM: x86: Update the variable naming in kvm_x86_ops.sched_in()
https://github.com/kvm-x86/linux/commit/5a989bbead4c
--
https://github.com/kvm-x86/linux/tree/next
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2023-10-18 1:17 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-10-17 23:26 [PATCH] KVM: x86: Update the variable naming in kvm_x86_ops.sched_in() Mingwei Zhang
2023-10-18 1:16 ` Sean Christopherson
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®