mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 1/2] x86/percpu: Rename percpu_stable_op() to __raw_cpu_read_stable()
@ 2024-05-20  8:09 Uros Bizjak
  2024-05-20  8:09 ` [PATCH 2/2] x86/percpu: Move some percpu accessors around to reduce ifdeffery Uros Bizjak
  2024-05-21  8:21 ` [tip: x86/percpu] x86/percpu: Rename percpu_stable_op() to __raw_cpu_read_stable() tip-bot2 for Uros Bizjak
  0 siblings, 2 replies; 4+ messages in thread
From: Uros Bizjak @ 2024-05-20  8:09 UTC (permalink / raw)
  To: linux-kernel, x86
  Cc: Uros Bizjak, Thomas Gleixner, Ingo Molnar, Borislav Petkov,
	Dave Hansen, H. Peter Anvin

Rename percpu_stable_op() to __raw_cpu_read_stable() to be
in line with other read/write percpu accessors.

No functional change intended.

Signed-off-by: Uros Bizjak <ubizjak@gmail.com>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Ingo Molnar <mingo@kernel.org>
Cc: Borislav Petkov <bp@alien8.de>
Cc: Dave Hansen <dave.hansen@linux.intel.com>
Cc: "H. Peter Anvin" <hpa@zytor.com>
---
 arch/x86/include/asm/percpu.h | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/arch/x86/include/asm/percpu.h b/arch/x86/include/asm/percpu.h
index c77393cd0273..39762fcfe328 100644
--- a/arch/x86/include/asm/percpu.h
+++ b/arch/x86/include/asm/percpu.h
@@ -190,10 +190,10 @@ do {									\
 
 #endif /* CONFIG_USE_X86_SEG_SUPPORT */
 
-#define percpu_stable_op(size, op, _var)				\
+#define __raw_cpu_read_stable(size, _var)				\
 ({									\
 	__pcpu_type_##size pfo_val__;					\
-	asm(__pcpu_op2_##size(op, __force_percpu_arg(a[var]), "%[val]")	\
+	asm(__pcpu_op2_##size("mov", __force_percpu_arg(a[var]), "%[val]") \
 	    : [val] __pcpu_reg_##size("=", pfo_val__)			\
 	    : [var] "i" (&(_var)));					\
 	(typeof(_var))(unsigned long) pfo_val__;			\
@@ -480,9 +480,9 @@ do {									\
 
 #define this_cpu_read_const(pcp)	__raw_cpu_read_const(pcp)
 
-#define this_cpu_read_stable_1(pcp)	percpu_stable_op(1, "mov", pcp)
-#define this_cpu_read_stable_2(pcp)	percpu_stable_op(2, "mov", pcp)
-#define this_cpu_read_stable_4(pcp)	percpu_stable_op(4, "mov", pcp)
+#define this_cpu_read_stable_1(pcp)	__raw_cpu_read_stable(1, pcp)
+#define this_cpu_read_stable_2(pcp)	__raw_cpu_read_stable(2, pcp)
+#define this_cpu_read_stable_4(pcp)	__raw_cpu_read_stable(4, pcp)
 
 #define raw_cpu_add_1(pcp, val)		percpu_add_op(1, , (pcp), val)
 #define raw_cpu_add_2(pcp, val)		percpu_add_op(2, , (pcp), val)
@@ -535,7 +535,7 @@ do {									\
  * 32 bit must fall back to generic operations.
  */
 #ifdef CONFIG_X86_64
-#define this_cpu_read_stable_8(pcp)	percpu_stable_op(8, "mov", pcp)
+#define this_cpu_read_stable_8(pcp)	__raw_cpu_read_stable(8, pcp)
 
 #define raw_cpu_add_8(pcp, val)			percpu_add_op(8, , (pcp), val)
 #define raw_cpu_and_8(pcp, val)			percpu_binary_op(8, , "and", (pcp), val)
-- 
2.45.1


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2024-05-21  8:21 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-05-20  8:09 [PATCH 1/2] x86/percpu: Rename percpu_stable_op() to __raw_cpu_read_stable() Uros Bizjak
2024-05-20  8:09 ` [PATCH 2/2] x86/percpu: Move some percpu accessors around to reduce ifdeffery Uros Bizjak
2024-05-21  8:21   ` [tip: x86/percpu] " tip-bot2 for Uros Bizjak
2024-05-21  8:21 ` [tip: x86/percpu] x86/percpu: Rename percpu_stable_op() to __raw_cpu_read_stable() tip-bot2 for Uros Bizjak

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®