mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [for-next][PATCH] function_graph: Rename BYTE_NUMBER to CHAR_NUMBER in selftests
@ 2024-06-06 16:49 Steven Rostedt
  0 siblings, 0 replies; only message in thread
From: Steven Rostedt @ 2024-06-06 16:49 UTC (permalink / raw)
  To: LKML; +Cc: Masami Hiramatsu, Mark Rutland, Mathieu Desnoyers


  git://git.kernel.org/pub/scm/linux/kernel/git/trace/linux-trace.git
ftrace/for-next

Head SHA1: 1af19b7c01061172f943ac247409626af0ba0867


Steven Rostedt (Google) (1):
      function_graph: Rename BYTE_NUMBER to CHAR_NUMBER in selftests

----
 kernel/trace/trace_selftest.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
---------------------------
commit 1af19b7c01061172f943ac247409626af0ba0867
Author: Steven Rostedt (Google) <rostedt@goodmis.org>
Date:   Thu Jun 6 08:18:46 2024 -0400

    function_graph: Rename BYTE_NUMBER to CHAR_NUMBER in selftests
    
    The function_graph selftests checks various size variables to pass from
    the entry of the function to the exit. It tests 1, 2, 4 and 8 byte words.
    The 1 byte macro was called BYTE_NUMBER but that is used in the sh
    architecture: arch/sh/include/asm/bitops-op32.h
    
    Just rename the macro to CHAR_NUMBER.
    
    Link: https://lore.kernel.org/linux-trace-kernel/20240606081846.4cb82dc4@gandalf.local.home
    
    Cc: Masami Hiramatsu <mhiramat@kernel.org>
    Cc: Mark Rutland <mark.rutland@arm.com>
    Cc: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
    Fixes: 47c3c70aa3697 ("function_graph: Add selftest for passing local variables")
    Reported-by: kernel test robot <lkp@intel.com>
    Closes: https://lore.kernel.org/oe-kbuild-all/202406061744.rZDXfRrG-lkp@intel.com/
    Signed-off-by: Steven Rostedt (Google) <rostedt@goodmis.org>

diff --git a/kernel/trace/trace_selftest.c b/kernel/trace/trace_selftest.c
index 369efc569238..adf0f436d84b 100644
--- a/kernel/trace/trace_selftest.c
+++ b/kernel/trace/trace_selftest.c
@@ -758,7 +758,7 @@ trace_selftest_startup_function(struct tracer *trace, struct trace_array *tr)
 
 #ifdef CONFIG_DYNAMIC_FTRACE
 
-#define BYTE_NUMBER 123
+#define CHAR_NUMBER 123
 #define SHORT_NUMBER 12345
 #define WORD_NUMBER 1234567890
 #define LONG_NUMBER 1234567890123456789LL
@@ -789,7 +789,7 @@ static __init int store_entry(struct ftrace_graph_ent *trace,
 
 	switch (size) {
 	case 1:
-		*(char *)p = BYTE_NUMBER;
+		*(char *)p = CHAR_NUMBER;
 		break;
 	case 2:
 		*(short *)p = SHORT_NUMBER;
@@ -830,7 +830,7 @@ static __init void store_return(struct ftrace_graph_ret *trace,
 
 	switch (fixture->store_size) {
 	case 1:
-		expect = BYTE_NUMBER;
+		expect = CHAR_NUMBER;
 		found = *(char *)p;
 		break;
 	case 2:

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2024-06-06 16:48 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-06-06 16:49 [for-next][PATCH] function_graph: Rename BYTE_NUMBER to CHAR_NUMBER in selftests Steven Rostedt

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®