mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v2 0/3] kunit: Improve the readability and functionality of macro
@ 2024-07-11 19:37 Eric Chan
  2024-07-11 19:39 ` [PATCH v2 1/3] kunit: Fix the comment of KUNIT_ASSERT_STRNEQ as assertion Eric Chan
                   ` (2 more replies)
  0 siblings, 3 replies; 7+ messages in thread
From: Eric Chan @ 2024-07-11 19:37 UTC (permalink / raw)
  To: brendan.higgins, davidgow, rmoar
  Cc: linux-kselftest, kunit-dev, linux-kernel, ericchancf

This series let kunit macro more neat and clear.
Fix comment and rename the macro.
Also introduce new type of assertion marco for functionality.
This is a follow-up to [0](v1).

v1 -> v2: [PATCH 2/3] changed KUNIT_ASSERT to KUNIT_FAIL_AND_ABORT 
[0] https://lore.kernel.org/lkml/20240710170448.1399967-1-ericchancf@google.com/

Eric Chan (3):
  kunit: Fix the comment of KUNIT_ASSERT_STRNEQ as assertion
  kunit: Rename KUNIT_ASSERT_FAILURE to KUNIT_FAIL_AND_ABORT for
    readability
  kunit: Introduce KUNIT_ASSERT_MEMEQ and KUNIT_ASSERT_MEMNEQ macros

 drivers/input/tests/input_test.c |  2 +-
 include/kunit/assert.h           |  2 +-
 include/kunit/test.h             | 71 ++++++++++++++++++++++++++++++--
 3 files changed, 70 insertions(+), 5 deletions(-)

-- 
2.45.2.993.g49e7a77208-goog

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2024-07-12  6:32 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-07-11 19:37 [PATCH v2 0/3] kunit: Improve the readability and functionality of macro Eric Chan
2024-07-11 19:39 ` [PATCH v2 1/3] kunit: Fix the comment of KUNIT_ASSERT_STRNEQ as assertion Eric Chan
2024-07-12  6:30   ` David Gow
2024-07-11 19:39 ` [PATCH v2 2/3] kunit: Rename KUNIT_ASSERT_FAILURE to KUNIT_FAIL_AND_ABORT for readability Eric Chan
2024-07-12  6:31   ` David Gow
2024-07-11 19:39 ` [PATCH v2 3/3] kunit: Introduce KUNIT_ASSERT_MEMEQ and KUNIT_ASSERT_MEMNEQ macros Eric Chan
2024-07-12  6:31   ` David Gow

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®