mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dave Hansen <dave.hansen@linux.intel.com>
To: linux-kernel@vger.kernel.org
Cc: x86@kernel.org,tglx@linutronix.de,bp@alien8.de,rafael@kernel.org,lenb@kernel.org,dave.jiang@intel.com,irenic.rajneesh@gmail.com,david.e.box@intel.com,Dave
	Hansen <dave.hansen@linux.intel.com>
Subject: [PATCH 00/11] x86/cpu: Centralize and standardize CPUID leaf naming
Date: Wed, 20 Nov 2024 11:53:27 -0800	[thread overview]
Message-ID: <20241120195327.26E06A69@davehans-spike.ostc.intel.com> (raw)

I noticed that the MWAIT code was rather haphazard in how it deals
with CPUID leaf levels.  As a result, there were a ton of unnecessary
checks for ->cpuid_level.  It is truly the worst offender because
there's arch/x86, intel_idle and ACPI that want to poke at it.

Move several of the leaf definitions to one place (cpuid.h).  Use
the definitions to get rid of magic numbers.  Simplify the code
when the CPUID feature level dependencies can be used.  Lastly,
change all the leaf names to be consistent.

This does not get *ALL* the leaves.  The topology and cache ones
are left along for now, but they can also be converted over.

It's obviously right in the middle of the merge window, so no
rush on looking at this.  I just wanted to get it into everyone's
review queues.  Barring any big issues I'm planning to apply this
to one of the tip branches after -rc1 drops.

 arch/x86/events/intel/pt.c            |    5 +++--
 arch/x86/events/intel/pt.h            |    3 ---
 arch/x86/include/asm/cpuid.h          |    7 +++++++
 arch/x86/include/asm/fpu/xstate.h     |    4 ----
 arch/x86/include/asm/mwait.h          |    1 -
 arch/x86/kernel/acpi/cstate.c         |    5 +++--
 arch/x86/kernel/cpu/common.c          |    7 ++++---
 arch/x86/kernel/fpu/xstate.c          |   26 +++++++++++---------------
 arch/x86/kernel/hpet.c                |    6 ++----
 arch/x86/kernel/process.c             |    3 ++-
 arch/x86/kernel/smpboot.c             |    5 ++---
 arch/x86/kernel/tsc.c                 |   23 +++++++++++------------
 arch/x86/xen/enlighten_pv.c           |    5 +++--
 drivers/acpi/acpi_pad.c               |    5 ++---
 drivers/dma/ioat/dca.c                |    8 +++++---
 drivers/idle/intel_idle.c             |    6 ++----
 drivers/platform/x86/intel/pmc/core.c |    7 ++++---
 17 files changed, 61 insertions(+), 65 deletions(-)


             reply	other threads:[~2024-11-20 19:53 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-11-20 19:53 Dave Hansen [this message]
2024-11-20 19:53 ` [PATCH 01/11] x86/cpu: Move MWAIT leaf definition to common header Dave Hansen
2024-11-26  3:20   ` Zhao Liu
2024-11-20 19:53 ` [PATCH 02/11] x86/cpu: Use MWAIT leaf definition Dave Hansen
2024-11-26  3:24   ` Zhao Liu
2024-11-20 19:53 ` [PATCH 03/11] x86/cpu: Remove unnecessary MwAIT leaf checks Dave Hansen
2024-11-20 19:53 ` [PATCH 04/11] x86/acpi: Check MWAIT feature instead of CPUID level Dave Hansen
2024-11-21 15:33   ` Sean Christopherson
2024-11-21 21:46     ` Dave Hansen
2024-11-20 19:53 ` [PATCH 05/11] x86/cpu: Refresh DCA leaf reading code Dave Hansen
2024-11-26  4:11   ` Zhao Liu
2024-11-26  3:55     ` Dave Hansen
2024-11-20 19:53 ` [PATCH 06/11] x86/cpu: Move TSC CPUID leaf definition Dave Hansen
2024-11-26  4:23   ` Zhao Liu
2024-11-20 19:53 ` [PATCH 07/11] x86/tsc: Move away from TSC leaf magic numbers Dave Hansen
2024-11-20 19:53 ` [PATCH 08/11] x86/tsc: Remove CPUID "frequency" " Dave Hansen
2024-11-26  4:37   ` Zhao Liu
2024-11-20 19:53 ` [PATCH 09/11] x86/fpu: Move CPUID leaf definitions to common code Dave Hansen
2024-11-26  4:43   ` Zhao Liu
2024-11-20 19:53 ` [PATCH 10/11] x86/fpu: Remove unnecessary CPUID level check Dave Hansen
2024-11-21 15:45   ` Sean Christopherson
2024-11-22 17:46     ` Dave Hansen
2024-11-20 19:53 ` [PATCH 11/11] x86/cpu: Make all all CPUID leaf names consistent Dave Hansen
2024-11-20 20:23   ` Dave Jiang
  -- strict thread matches above, loose matches on Subject: below --
2024-10-30 21:33 [PATCH 00/11] x86/cpu: Centralize and standardize CPUID leaf naming Dave Hansen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20241120195327.26E06A69@davehans-spike.ostc.intel.com \
    --to=dave.hansen@linux.intel.com \
    --cc=bp@alien8.de \
    --cc=dave.jiang@intel.com \
    --cc=david.e.box@intel.com \
    --cc=irenic.rajneesh@gmail.com \
    --cc=lenb@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®