mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] kbuild: Fix names of .tmp_vmlinux kallsyms files
@ 2024-11-23 13:22 Sedat Dilek
  2024-11-26 15:00 ` Masahiro Yamada
  0 siblings, 1 reply; 4+ messages in thread
From: Sedat Dilek @ 2024-11-23 13:22 UTC (permalink / raw)
  To: Masahiro Yamada, Nathan Chancellor, Nicolas Schier, linux-kbuild,
	linux-kernel
  Cc: Sedat Dilek

For details, see thread "kbuild-next: .tmp vmlinux syms files"

INFO: This patch is against Linux v6.12.

Link: https://lore.kernel.org/all/CA+icZUXvu0Kw8RH1ZGBKgYGG-8u9x8BbsEkjtm4vSVKkXPTg+Q@mail.gmail.com/

Signed-off-by: Sedat Dilek <sedat.dilek@gmail.com>
---
 scripts/link-vmlinux.sh | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/scripts/link-vmlinux.sh b/scripts/link-vmlinux.sh
index a9b3f34a78d2..c9088436baff 100755
--- a/scripts/link-vmlinux.sh
+++ b/scripts/link-vmlinux.sh
@@ -203,8 +203,8 @@ kallsymso=
 strip_debug=
 
 if is_enabled CONFIG_KALLSYMS; then
-	true > .tmp_vmlinux.kallsyms0.syms
-	kallsyms .tmp_vmlinux.kallsyms0.syms .tmp_vmlinux0.kallsyms
+	true > .tmp_vmlinux0.kallsyms.syms
+	kallsyms .tmp_vmlinux0.kallsyms.syms .tmp_vmlinux0.kallsyms
 fi
 
 if is_enabled CONFIG_KALLSYMS || is_enabled CONFIG_DEBUG_INFO_BTF; then
@@ -231,14 +231,14 @@ if is_enabled CONFIG_KALLSYMS; then
 	# Generate section listing all symbols and add it into vmlinux
 	# It's a four step process:
 	# 0)  Generate a dummy __kallsyms with empty symbol list.
-	# 1)  Link .tmp_vmlinux.kallsyms1 so it has all symbols and sections,
+	# 1)  Link .tmp_vmlinux1.kallsyms so it has all symbols and sections,
 	#     with a dummy __kallsyms.
-	#     Running kallsyms on that gives us .tmp_kallsyms1.o with
+	#     Running kallsyms on that gives us .tmp_vmlinux1.kallsyms.o with
 	#     the right size
-	# 2)  Link .tmp_vmlinux.kallsyms2 so it now has a __kallsyms section of
+	# 2)  Link .tmp_vmlinux2.kallsyms so it now has a __kallsyms section of
 	#     the right size, but due to the added section, some
 	#     addresses have shifted.
-	#     From here, we generate a correct .tmp_vmlinux.kallsyms2.o
+	#     From here, we generate a correct .tmp_vmlinux2.kallsyms.o
 	# 3)  That link may have expanded the kernel image enough that
 	#     more linker branch stubs / trampolines had to be added, which
 	#     introduces new names, which further expands kallsyms. Do another
-- 
2.45.2


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] kbuild: Fix names of .tmp_vmlinux kallsyms files
  2024-11-23 13:22 [PATCH] kbuild: Fix names of .tmp_vmlinux kallsyms files Sedat Dilek
@ 2024-11-26 15:00 ` Masahiro Yamada
  2024-11-26 15:12   ` Sedat Dilek
  0 siblings, 1 reply; 4+ messages in thread
From: Masahiro Yamada @ 2024-11-26 15:00 UTC (permalink / raw)
  To: Sedat Dilek; +Cc: Nathan Chancellor, Nicolas Schier, linux-kbuild, linux-kernel

On Sat, Nov 23, 2024 at 10:22 PM Sedat Dilek <sedat.dilek@gmail.com> wrote:
>
> For details, see thread "kbuild-next: .tmp vmlinux syms files"
>
> INFO: This patch is against Linux v6.12.
>
> Link: https://lore.kernel.org/all/CA+icZUXvu0Kw8RH1ZGBKgYGG-8u9x8BbsEkjtm4vSVKkXPTg+Q@mail.gmail.com/

This is not the right way to input a commit description.




>
> Signed-off-by: Sedat Dilek <sedat.dilek@gmail.com>
> ---
>  scripts/link-vmlinux.sh | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/scripts/link-vmlinux.sh b/scripts/link-vmlinux.sh
> index a9b3f34a78d2..c9088436baff 100755
> --- a/scripts/link-vmlinux.sh
> +++ b/scripts/link-vmlinux.sh
> @@ -203,8 +203,8 @@ kallsymso=
>  strip_debug=
>
>  if is_enabled CONFIG_KALLSYMS; then
> -       true > .tmp_vmlinux.kallsyms0.syms
> -       kallsyms .tmp_vmlinux.kallsyms0.syms .tmp_vmlinux0.kallsyms
> +       true > .tmp_vmlinux0.kallsyms.syms
> +       kallsyms .tmp_vmlinux0.kallsyms.syms .tmp_vmlinux0.kallsyms

If you aim for naming consistency, this should be

.tmp_vmlinux0.syms



>  fi
>
>  if is_enabled CONFIG_KALLSYMS || is_enabled CONFIG_DEBUG_INFO_BTF; then
> @@ -231,14 +231,14 @@ if is_enabled CONFIG_KALLSYMS; then
>         # Generate section listing all symbols and add it into vmlinux
>         # It's a four step process:
>         # 0)  Generate a dummy __kallsyms with empty symbol list.
> -       # 1)  Link .tmp_vmlinux.kallsyms1 so it has all symbols and sections,
> +       # 1)  Link .tmp_vmlinux1.kallsyms so it has all symbols and sections,
>         #     with a dummy __kallsyms.
> -       #     Running kallsyms on that gives us .tmp_kallsyms1.o with
> +       #     Running kallsyms on that gives us .tmp_vmlinux1.kallsyms.o with
>         #     the right size
> -       # 2)  Link .tmp_vmlinux.kallsyms2 so it now has a __kallsyms section of
> +       # 2)  Link .tmp_vmlinux2.kallsyms so it now has a __kallsyms section of
>         #     the right size, but due to the added section, some
>         #     addresses have shifted.
> -       #     From here, we generate a correct .tmp_vmlinux.kallsyms2.o
> +       #     From here, we generate a correct .tmp_vmlinux2.kallsyms.o
>         # 3)  That link may have expanded the kernel image enough that
>         #     more linker branch stubs / trampolines had to be added, which
>         #     introduces new names, which further expands kallsyms. Do another
> --
> 2.45.2
>


-- 
Best Regards
Masahiro Yamada

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] kbuild: Fix names of .tmp_vmlinux kallsyms files
  2024-11-26 15:00 ` Masahiro Yamada
@ 2024-11-26 15:12   ` Sedat Dilek
  2024-11-26 16:06     ` Sedat Dilek
  0 siblings, 1 reply; 4+ messages in thread
From: Sedat Dilek @ 2024-11-26 15:12 UTC (permalink / raw)
  To: Masahiro Yamada
  Cc: Nathan Chancellor, Nicolas Schier, linux-kbuild, linux-kernel

On Tue, Nov 26, 2024 at 4:01 PM Masahiro Yamada <masahiroy@kernel.org> wrote:
>
> On Sat, Nov 23, 2024 at 10:22 PM Sedat Dilek <sedat.dilek@gmail.com> wrote:
> >
> > For details, see thread "kbuild-next: .tmp vmlinux syms files"
> >
> > INFO: This patch is against Linux v6.12.
> >
> > Link: https://lore.kernel.org/all/CA+icZUXvu0Kw8RH1ZGBKgYGG-8u9x8BbsEkjtm4vSVKkXPTg+Q@mail.gmail.com/
>
> This is not the right way to input a commit description.
>

Hi Masahiro,

I can add a proper commit description in v2.

>
> >
> > Signed-off-by: Sedat Dilek <sedat.dilek@gmail.com>
> > ---
> >  scripts/link-vmlinux.sh | 12 ++++++------
> >  1 file changed, 6 insertions(+), 6 deletions(-)
> >
> > diff --git a/scripts/link-vmlinux.sh b/scripts/link-vmlinux.sh
> > index a9b3f34a78d2..c9088436baff 100755
> > --- a/scripts/link-vmlinux.sh
> > +++ b/scripts/link-vmlinux.sh
> > @@ -203,8 +203,8 @@ kallsymso=
> >  strip_debug=
> >
> >  if is_enabled CONFIG_KALLSYMS; then
> > -       true > .tmp_vmlinux.kallsyms0.syms
> > -       kallsyms .tmp_vmlinux.kallsyms0.syms .tmp_vmlinux0.kallsyms
> > +       true > .tmp_vmlinux0.kallsyms.syms
> > +       kallsyms .tmp_vmlinux0.kallsyms.syms .tmp_vmlinux0.kallsyms
>
> If you aim for naming consistency, this should be
>
> .tmp_vmlinux0.syms
>

OK.
I was thinking of this, too.
I can change this as well.

The rest below is OK?

Thanks for your comments.

Best regards,
-Sedat-

>
>
> >  fi
> >
> >  if is_enabled CONFIG_KALLSYMS || is_enabled CONFIG_DEBUG_INFO_BTF; then
> > @@ -231,14 +231,14 @@ if is_enabled CONFIG_KALLSYMS; then
> >         # Generate section listing all symbols and add it into vmlinux
> >         # It's a four step process:
> >         # 0)  Generate a dummy __kallsyms with empty symbol list.
> > -       # 1)  Link .tmp_vmlinux.kallsyms1 so it has all symbols and sections,
> > +       # 1)  Link .tmp_vmlinux1.kallsyms so it has all symbols and sections,
> >         #     with a dummy __kallsyms.
> > -       #     Running kallsyms on that gives us .tmp_kallsyms1.o with
> > +       #     Running kallsyms on that gives us .tmp_vmlinux1.kallsyms.o with
> >         #     the right size
> > -       # 2)  Link .tmp_vmlinux.kallsyms2 so it now has a __kallsyms section of
> > +       # 2)  Link .tmp_vmlinux2.kallsyms so it now has a __kallsyms section of
> >         #     the right size, but due to the added section, some
> >         #     addresses have shifted.
> > -       #     From here, we generate a correct .tmp_vmlinux.kallsyms2.o
> > +       #     From here, we generate a correct .tmp_vmlinux2.kallsyms.o
> >         # 3)  That link may have expanded the kernel image enough that
> >         #     more linker branch stubs / trampolines had to be added, which
> >         #     introduces new names, which further expands kallsyms. Do another
> > --
> > 2.45.2
> >
>
>
> --
> Best Regards
> Masahiro Yamada

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] kbuild: Fix names of .tmp_vmlinux kallsyms files
  2024-11-26 15:12   ` Sedat Dilek
@ 2024-11-26 16:06     ` Sedat Dilek
  0 siblings, 0 replies; 4+ messages in thread
From: Sedat Dilek @ 2024-11-26 16:06 UTC (permalink / raw)
  To: Masahiro Yamada
  Cc: Nathan Chancellor, Nicolas Schier, linux-kbuild, linux-kernel

On Tue, Nov 26, 2024 at 4:12 PM Sedat Dilek <sedat.dilek@gmail.com> wrote:
>
> On Tue, Nov 26, 2024 at 4:01 PM Masahiro Yamada <masahiroy@kernel.org> wrote:
> >
> > On Sat, Nov 23, 2024 at 10:22 PM Sedat Dilek <sedat.dilek@gmail.com> wrote:
> > >
> > > For details, see thread "kbuild-next: .tmp vmlinux syms files"
> > >
> > > INFO: This patch is against Linux v6.12.
> > >
> > > Link: https://lore.kernel.org/all/CA+icZUXvu0Kw8RH1ZGBKgYGG-8u9x8BbsEkjtm4vSVKkXPTg+Q@mail.gmail.com/
> >
> > This is not the right way to input a commit description.
> >
>
> Hi Masahiro,
>
> I can add a proper commit description in v2.
>
> >
> > >
> > > Signed-off-by: Sedat Dilek <sedat.dilek@gmail.com>
> > > ---
> > >  scripts/link-vmlinux.sh | 12 ++++++------
> > >  1 file changed, 6 insertions(+), 6 deletions(-)
> > >
> > > diff --git a/scripts/link-vmlinux.sh b/scripts/link-vmlinux.sh
> > > index a9b3f34a78d2..c9088436baff 100755
> > > --- a/scripts/link-vmlinux.sh
> > > +++ b/scripts/link-vmlinux.sh
> > > @@ -203,8 +203,8 @@ kallsymso=
> > >  strip_debug=
> > >
> > >  if is_enabled CONFIG_KALLSYMS; then
> > > -       true > .tmp_vmlinux.kallsyms0.syms
> > > -       kallsyms .tmp_vmlinux.kallsyms0.syms .tmp_vmlinux0.kallsyms
> > > +       true > .tmp_vmlinux0.kallsyms.syms
> > > +       kallsyms .tmp_vmlinux0.kallsyms.syms .tmp_vmlinux0.kallsyms
> >
> > If you aim for naming consistency, this should be
> >
> > .tmp_vmlinux0.syms
> >
>
> OK.
> I was thinking of this, too.
> I can change this as well.
>
> The rest below is OK?
>
> Thanks for your comments.
>

Info: Sent v2

Link: https://lore.kernel.org/all/20241126155832.15560-1-sedat.dilek@gmail.com/

> Best regards,
> -Sedat-
>
> >
> >
> > >  fi
> > >
> > >  if is_enabled CONFIG_KALLSYMS || is_enabled CONFIG_DEBUG_INFO_BTF; then
> > > @@ -231,14 +231,14 @@ if is_enabled CONFIG_KALLSYMS; then
> > >         # Generate section listing all symbols and add it into vmlinux
> > >         # It's a four step process:
> > >         # 0)  Generate a dummy __kallsyms with empty symbol list.
> > > -       # 1)  Link .tmp_vmlinux.kallsyms1 so it has all symbols and sections,
> > > +       # 1)  Link .tmp_vmlinux1.kallsyms so it has all symbols and sections,
> > >         #     with a dummy __kallsyms.
> > > -       #     Running kallsyms on that gives us .tmp_kallsyms1.o with
> > > +       #     Running kallsyms on that gives us .tmp_vmlinux1.kallsyms.o with
> > >         #     the right size
> > > -       # 2)  Link .tmp_vmlinux.kallsyms2 so it now has a __kallsyms section of
> > > +       # 2)  Link .tmp_vmlinux2.kallsyms so it now has a __kallsyms section of
> > >         #     the right size, but due to the added section, some
> > >         #     addresses have shifted.
> > > -       #     From here, we generate a correct .tmp_vmlinux.kallsyms2.o
> > > +       #     From here, we generate a correct .tmp_vmlinux2.kallsyms.o
> > >         # 3)  That link may have expanded the kernel image enough that
> > >         #     more linker branch stubs / trampolines had to be added, which
> > >         #     introduces new names, which further expands kallsyms. Do another
> > > --
> > > 2.45.2
> > >
> >
> >
> > --
> > Best Regards
> > Masahiro Yamada

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2024-11-26 16:06 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-11-23 13:22 [PATCH] kbuild: Fix names of .tmp_vmlinux kallsyms files Sedat Dilek
2024-11-26 15:00 ` Masahiro Yamada
2024-11-26 15:12   ` Sedat Dilek
2024-11-26 16:06     ` Sedat Dilek

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®