mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCHv2 00/11] Get rid of PG_reclaim and rename PG_dropbehind
@ 2025-01-15  9:31 Kirill A. Shutemov
  2025-01-15  9:31 ` [PATCHv2 01/11] mm/migrate: Transfer PG_dropbehind to the new folio Kirill A. Shutemov
                   ` (10 more replies)
  0 siblings, 11 replies; 20+ messages in thread
From: Kirill A. Shutemov @ 2025-01-15  9:31 UTC (permalink / raw)
  To: Andrew Morton, Matthew Wilcox (Oracle), Jens Axboe
  Cc: Jason A. Donenfeld, Kirill A. Shutemov, Andi Shyti,
	Chengming Zhou, Christian Brauner, Christophe Leroy,
	Dan Carpenter, David Airlie, David Hildenbrand, Hao Ge,
	Jani Nikula, Johannes Weiner, Joonas Lahtinen, Josef Bacik,
	Masami Hiramatsu, Mathieu Desnoyers, Miklos Szeredi, Nhat Pham,
	Oscar Salvador, Ran Xiaokai, Rodrigo Vivi, Simona Vetter,
	Steven Rostedt, Tvrtko Ursulin, Vlastimil Babka, Yosry Ahmed,
	Yu Zhao, intel-gfx, dri-devel, linux-kernel, linux-fsdevel,
	linux-mm, linux-trace-kernel

Use PG_dropbehind instead of PG_reclaim and remove PG_reclaim.

After removing PG_relcaim, PG_readahead is exclusive user of the page
flag bit.

Once PG_reclaim is gone, we can rename PG_dropbehind to PG_reclaim.

Kirill A. Shutemov (11):
  mm/migrate: Transfer PG_dropbehind to the new folio
  drm/i915/gem: Convert __shmem_writeback() to folios
  drm/i915/gem: Use PG_dropbehind instead of PG_reclaim
  mm/zswap: Use PG_dropbehind instead of PG_reclaim
  mm/truncate: Use folio_set_dropbehind() instead of
    deactivate_file_folio()
  mm/vmscan: Use PG_dropbehind instead of PG_reclaim
  mm/vmscan: Use PG_dropbehind instead of PG_reclaim in
    shrink_folio_list()
  mm/mglru: Check PG_dropbehind instead of PG_reclaim in
    lru_gen_folio_seq()
  mm: Remove PG_reclaim
  mm/vmscan: Do not demote PG_dropbehind folios
  mm: Rename PG_dropbehind to PG_reclaim

 drivers/gpu/drm/i915/gem/i915_gem_shmem.c |  18 ++-
 fs/fuse/dev.c                             |   2 +-
 fs/proc/page.c                            |   2 +-
 include/linux/mm_inline.h                 |  18 +--
 include/linux/page-flags.h                |  23 ++--
 include/linux/pagemap.h                   |   2 +-
 include/trace/events/mmflags.h            |   4 +-
 include/uapi/linux/kernel-page-flags.h    |   2 +-
 mm/filemap.c                              |  46 +++----
 mm/internal.h                             |   1 -
 mm/migrate.c                              |  14 +-
 mm/page-writeback.c                       |  16 +--
 mm/page_io.c                              |  15 +--
 mm/readahead.c                            |   4 +-
 mm/swap.c                                 | 153 +---------------------
 mm/truncate.c                             |   2 +-
 mm/vmscan.c                               |  28 +---
 mm/zswap.c                                |   2 +-
 tools/mm/page-types.c                     |   8 +-
 19 files changed, 65 insertions(+), 295 deletions(-)

-- 
2.45.2


^ permalink raw reply	[flat|nested] 20+ messages in thread

end of thread, other threads:[~2025-01-17  8:42 UTC | newest]

Thread overview: 20+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-01-15  9:31 [PATCHv2 00/11] Get rid of PG_reclaim and rename PG_dropbehind Kirill A. Shutemov
2025-01-15  9:31 ` [PATCHv2 01/11] mm/migrate: Transfer PG_dropbehind to the new folio Kirill A. Shutemov
2025-01-15  9:31 ` [PATCHv2 02/11] drm/i915/gem: Convert __shmem_writeback() to folios Kirill A. Shutemov
2025-01-15  9:31 ` [PATCHv2 03/11] drm/i915/gem: Use PG_dropbehind instead of PG_reclaim Kirill A. Shutemov
2025-01-15  9:31 ` [PATCHv2 04/11] mm/zswap: " Kirill A. Shutemov
2025-01-15  9:31 ` [PATCHv2 05/11] mm/truncate: Use folio_set_dropbehind() instead of deactivate_file_folio() Kirill A. Shutemov
2025-01-15 20:43   ` Yu Zhao
2025-01-15 21:35   ` Matthew Wilcox
2025-01-15 21:46     ` Yu Zhao
2025-01-17  8:38       ` [PATCHv2 05/11] mm/truncate: Use folio_set_dropbehind() instead of deactivate_file_folio()k Kirill A. Shutemov
2025-01-15  9:31 ` [PATCHv2 06/11] mm/vmscan: Use PG_dropbehind instead of PG_reclaim Kirill A. Shutemov
2025-01-15  9:31 ` [PATCHv2 07/11] mm/vmscan: Use PG_dropbehind instead of PG_reclaim in shrink_folio_list() Kirill A. Shutemov
2025-01-15  9:31 ` [PATCHv2 08/11] mm/mglru: Check PG_dropbehind instead of PG_reclaim in lru_gen_folio_seq() Kirill A. Shutemov
2025-01-15  9:31 ` [PATCHv2 09/11] mm: Remove PG_reclaim Kirill A. Shutemov
2025-01-15 20:51   ` Yu Zhao
2025-01-15  9:31 ` [PATCHv2 10/11] mm/vmscan: Do not demote PG_dropbehind folios Kirill A. Shutemov
2025-01-15  9:31 ` [PATCHv2 11/11] mm: Rename PG_dropbehind to PG_reclaim Kirill A. Shutemov
2025-01-15 20:52   ` Yu Zhao
2025-01-16  6:18   ` Christoph Hellwig
2025-01-17  8:42     ` Kirill A. Shutemov

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®