* [PATCH] rust: use host dylib naming in rusttestlib-kernel
@ 2025-02-01 17:40 Tamir Duberstein
2025-02-05 23:05 ` Miguel Ojeda
2025-02-05 23:14 ` Miguel Ojeda
0 siblings, 2 replies; 4+ messages in thread
From: Tamir Duberstein @ 2025-02-01 17:40 UTC (permalink / raw)
To: Miguel Ojeda, Alex Gaynor, Boqun Feng, Gary Guo,
Björn Roy Baron, Benno Lossin, Andreas Hindborg, Alice Ryhl,
Trevor Gross, Fiona Behrens
Cc: rust-for-linux, linux-kernel, Tamir Duberstein
There seems to have been merge skew between commit b2c261fa8629 ("rust:
kbuild: expand rusttest target for macros") and commit 0730422bced5
("rust: use host dylib naming convention to support macOS") ; the latter
replaced `libmacros.so` with `$(libmacros_name)` and the former added an
instance of `libmacros.so`. The former was not yet applied when the
latter was sent, resulting in a stray `libmacros.so`. Replace the stray
with `$(libmacros_name)` to allow `rusttest` to build on macOS.
Fixes: 0730422bced5 ("rust: use host dylib naming convention to support macOS")
---
Signed-off-by: Tamir Duberstein <tamird@gmail.com>
---
rust/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/rust/Makefile b/rust/Makefile
index 71a05a3c895a..9df46daaaf67 100644
--- a/rust/Makefile
+++ b/rust/Makefile
@@ -144,7 +144,7 @@ rusttestlib-kernel: private rustc_target_flags = --extern ffi \
--extern bindings --extern uapi
rusttestlib-kernel: $(src)/kernel/lib.rs \
rusttestlib-bindings rusttestlib-uapi rusttestlib-build_error \
- $(obj)/libmacros.so $(obj)/bindings.o FORCE
+ $(obj)/$(libmacros_name) $(obj)/bindings.o FORCE
+$(call if_changed,rustc_test_library)
rusttestlib-bindings: private rustc_target_flags = --extern ffi
---
base-commit: ceff0757f5dafb5be5205988171809c877b1d3e3
change-id: 20250201-fix-mac-build-again-cb6833a64276
Best regards,
--
Tamir Duberstein <tamird@gmail.com>
^ permalink raw reply [flat|nested] 4+ messages in thread* Re: [PATCH] rust: use host dylib naming in rusttestlib-kernel
2025-02-01 17:40 [PATCH] rust: use host dylib naming in rusttestlib-kernel Tamir Duberstein
@ 2025-02-05 23:05 ` Miguel Ojeda
2025-02-05 23:07 ` Tamir Duberstein
2025-02-05 23:14 ` Miguel Ojeda
1 sibling, 1 reply; 4+ messages in thread
From: Miguel Ojeda @ 2025-02-05 23:05 UTC (permalink / raw)
To: Tamir Duberstein
Cc: Miguel Ojeda, Alex Gaynor, Boqun Feng, Gary Guo,
Björn Roy Baron, Benno Lossin, Andreas Hindborg, Alice Ryhl,
Trevor Gross, Fiona Behrens, rust-for-linux, linux-kernel
On Sat, Feb 1, 2025 at 6:40 PM Tamir Duberstein <tamird@gmail.com> wrote:
>
> Fixes: 0730422bced5 ("rust: use host dylib naming convention to support macOS")
> ---
> Signed-off-by: Tamir Duberstein <tamird@gmail.com>
Spurious `---`, but I have fixed it on my side.
I also noticed another recent message from you with an empty line
between tags too. Something strange is going on with the tags you add.
Cheers,
Miguel
^ permalink raw reply [flat|nested] 4+ messages in thread* Re: [PATCH] rust: use host dylib naming in rusttestlib-kernel
2025-02-05 23:05 ` Miguel Ojeda
@ 2025-02-05 23:07 ` Tamir Duberstein
0 siblings, 0 replies; 4+ messages in thread
From: Tamir Duberstein @ 2025-02-05 23:07 UTC (permalink / raw)
To: Miguel Ojeda
Cc: Miguel Ojeda, Alex Gaynor, Boqun Feng, Gary Guo,
Björn Roy Baron, Benno Lossin, Andreas Hindborg, Alice Ryhl,
Trevor Gross, Fiona Behrens, rust-for-linux, linux-kernel
On Wed, Feb 5, 2025 at 6:05 PM Miguel Ojeda
<miguel.ojeda.sandonis@gmail.com> wrote:
>
> On Sat, Feb 1, 2025 at 6:40 PM Tamir Duberstein <tamird@gmail.com> wrote:
> >
> > Fixes: 0730422bced5 ("rust: use host dylib naming convention to support macOS")
> > ---
> > Signed-off-by: Tamir Duberstein <tamird@gmail.com>
>
> Spurious `---`, but I have fixed it on my side.
>
> I also noticed another recent message from you with an empty line
> between tags too. Something strange is going on with the tags you add.
>
> Cheers,
> Miguel
Thanks for fixing it. I think in this case the SoB came from the b4
cover letter rather than the commit itself, which is why it appeared
after the `---`.
I'll audit to make sure all my commits are properly SoB'd and file a
bug with b4 if necessary.
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] rust: use host dylib naming in rusttestlib-kernel
2025-02-01 17:40 [PATCH] rust: use host dylib naming in rusttestlib-kernel Tamir Duberstein
2025-02-05 23:05 ` Miguel Ojeda
@ 2025-02-05 23:14 ` Miguel Ojeda
1 sibling, 0 replies; 4+ messages in thread
From: Miguel Ojeda @ 2025-02-05 23:14 UTC (permalink / raw)
To: Tamir Duberstein
Cc: Miguel Ojeda, Alex Gaynor, Boqun Feng, Gary Guo,
Björn Roy Baron, Benno Lossin, Andreas Hindborg, Alice Ryhl,
Trevor Gross, Fiona Behrens, rust-for-linux, linux-kernel
On Sat, Feb 1, 2025 at 6:40 PM Tamir Duberstein <tamird@gmail.com> wrote:
>
> There seems to have been merge skew between commit b2c261fa8629 ("rust:
> kbuild: expand rusttest target for macros") and commit 0730422bced5
> ("rust: use host dylib naming convention to support macOS") ; the latter
> replaced `libmacros.so` with `$(libmacros_name)` and the former added an
> instance of `libmacros.so`. The former was not yet applied when the
> latter was sent, resulting in a stray `libmacros.so`. Replace the stray
> with `$(libmacros_name)` to allow `rusttest` to build on macOS.
>
> Fixes: 0730422bced5 ("rust: use host dylib naming convention to support macOS")
> ---
> Signed-off-by: Tamir Duberstein <tamird@gmail.com>
Applied to `rust-fixes` -- thanks!
Cheers,
Miguel
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2025-02-05 23:15 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-02-01 17:40 [PATCH] rust: use host dylib naming in rusttestlib-kernel Tamir Duberstein
2025-02-05 23:05 ` Miguel Ojeda
2025-02-05 23:07 ` Tamir Duberstein
2025-02-05 23:14 ` Miguel Ojeda
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®