* [PATCH 1/2] gpio: latch: use generic device properties @ 2025-02-11 12:08 Bartosz Golaszewski 2025-02-11 12:08 ` [PATCH 2/2] gpio: latch: store the address of pdev->dev in a helper variable Bartosz Golaszewski 2025-02-17 8:47 ` [PATCH 1/2] gpio: latch: use generic device properties Bartosz Golaszewski 0 siblings, 2 replies; 4+ messages in thread From: Bartosz Golaszewski @ 2025-02-11 12:08 UTC (permalink / raw) To: Linus Walleij; +Cc: linux-gpio, linux-kernel, Bartosz Golaszewski From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> Replace calls to OF-specific interface with generic device property getters. This is good practice and also drops implicit run-time dependency on CONFIG_OF. Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> --- drivers/gpio/gpio-latch.c | 9 ++++++--- 1 file changed, 6 insertions(+), 3 deletions(-) diff --git a/drivers/gpio/gpio-latch.c b/drivers/gpio/gpio-latch.c index d7c3b20c8482..722eb5b045f5 100644 --- a/drivers/gpio/gpio-latch.c +++ b/drivers/gpio/gpio-latch.c @@ -44,6 +44,7 @@ #include <linux/module.h> #include <linux/mod_devicetable.h> #include <linux/platform_device.h> +#include <linux/property.h> #include <linux/delay.h> #include "gpiolib.h" @@ -138,9 +139,9 @@ static bool gpio_latch_can_sleep(struct gpio_latch_priv *priv, unsigned int n_la static int gpio_latch_probe(struct platform_device *pdev) { + struct device *dev = &pdev->dev; struct gpio_latch_priv *priv; unsigned int n_latches; - struct device_node *np = pdev->dev.of_node; priv = devm_kzalloc(&pdev->dev, sizeof(*priv), GFP_KERNEL); if (!priv) @@ -172,14 +173,16 @@ static int gpio_latch_probe(struct platform_device *pdev) spin_lock_init(&priv->spinlock); } - of_property_read_u32(np, "setup-duration-ns", &priv->setup_duration_ns); + device_property_read_u32(dev, "setup-duration-ns", + &priv->setup_duration_ns); if (priv->setup_duration_ns > DURATION_NS_MAX) { dev_warn(&pdev->dev, "setup-duration-ns too high, limit to %d\n", DURATION_NS_MAX); priv->setup_duration_ns = DURATION_NS_MAX; } - of_property_read_u32(np, "clock-duration-ns", &priv->clock_duration_ns); + device_property_read_u32(dev, "clock-duration-ns", + &priv->clock_duration_ns); if (priv->clock_duration_ns > DURATION_NS_MAX) { dev_warn(&pdev->dev, "clock-duration-ns too high, limit to %d\n", DURATION_NS_MAX); -- 2.45.2 ^ permalink raw reply [flat|nested] 4+ messages in thread
* [PATCH 2/2] gpio: latch: store the address of pdev->dev in a helper variable 2025-02-11 12:08 [PATCH 1/2] gpio: latch: use generic device properties Bartosz Golaszewski @ 2025-02-11 12:08 ` Bartosz Golaszewski 2025-02-14 9:47 ` Linus Walleij 2025-02-17 8:47 ` [PATCH 1/2] gpio: latch: use generic device properties Bartosz Golaszewski 1 sibling, 1 reply; 4+ messages in thread From: Bartosz Golaszewski @ 2025-02-11 12:08 UTC (permalink / raw) To: Linus Walleij; +Cc: linux-gpio, linux-kernel, Bartosz Golaszewski From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> Make the code a bit more readable by using a helper variable to store the address of pdev->dev in probe(). Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> --- drivers/gpio/gpio-latch.c | 16 ++++++++-------- 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/gpio/gpio-latch.c b/drivers/gpio/gpio-latch.c index 722eb5b045f5..46cdfb08747a 100644 --- a/drivers/gpio/gpio-latch.c +++ b/drivers/gpio/gpio-latch.c @@ -143,22 +143,22 @@ static int gpio_latch_probe(struct platform_device *pdev) struct gpio_latch_priv *priv; unsigned int n_latches; - priv = devm_kzalloc(&pdev->dev, sizeof(*priv), GFP_KERNEL); + priv = devm_kzalloc(dev, sizeof(*priv), GFP_KERNEL); if (!priv) return -ENOMEM; - priv->clk_gpios = devm_gpiod_get_array(&pdev->dev, "clk", GPIOD_OUT_LOW); + priv->clk_gpios = devm_gpiod_get_array(dev, "clk", GPIOD_OUT_LOW); if (IS_ERR(priv->clk_gpios)) return PTR_ERR(priv->clk_gpios); - priv->latched_gpios = devm_gpiod_get_array(&pdev->dev, "latched", GPIOD_OUT_LOW); + priv->latched_gpios = devm_gpiod_get_array(dev, "latched", GPIOD_OUT_LOW); if (IS_ERR(priv->latched_gpios)) return PTR_ERR(priv->latched_gpios); n_latches = priv->clk_gpios->ndescs; priv->n_latched_gpios = priv->latched_gpios->ndescs; - priv->shadow = devm_bitmap_zalloc(&pdev->dev, n_latches * priv->n_latched_gpios, + priv->shadow = devm_bitmap_zalloc(dev, n_latches * priv->n_latched_gpios, GFP_KERNEL); if (!priv->shadow) return -ENOMEM; @@ -176,7 +176,7 @@ static int gpio_latch_probe(struct platform_device *pdev) device_property_read_u32(dev, "setup-duration-ns", &priv->setup_duration_ns); if (priv->setup_duration_ns > DURATION_NS_MAX) { - dev_warn(&pdev->dev, "setup-duration-ns too high, limit to %d\n", + dev_warn(dev, "setup-duration-ns too high, limit to %d\n", DURATION_NS_MAX); priv->setup_duration_ns = DURATION_NS_MAX; } @@ -184,7 +184,7 @@ static int gpio_latch_probe(struct platform_device *pdev) device_property_read_u32(dev, "clock-duration-ns", &priv->clock_duration_ns); if (priv->clock_duration_ns > DURATION_NS_MAX) { - dev_warn(&pdev->dev, "clock-duration-ns too high, limit to %d\n", + dev_warn(dev, "clock-duration-ns too high, limit to %d\n", DURATION_NS_MAX); priv->clock_duration_ns = DURATION_NS_MAX; } @@ -193,11 +193,11 @@ static int gpio_latch_probe(struct platform_device *pdev) priv->gc.ngpio = n_latches * priv->n_latched_gpios; priv->gc.owner = THIS_MODULE; priv->gc.base = -1; - priv->gc.parent = &pdev->dev; + priv->gc.parent = dev; platform_set_drvdata(pdev, priv); - return devm_gpiochip_add_data(&pdev->dev, &priv->gc, priv); + return devm_gpiochip_add_data(dev, &priv->gc, priv); } static const struct of_device_id gpio_latch_ids[] = { -- 2.45.2 ^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH 2/2] gpio: latch: store the address of pdev->dev in a helper variable 2025-02-11 12:08 ` [PATCH 2/2] gpio: latch: store the address of pdev->dev in a helper variable Bartosz Golaszewski @ 2025-02-14 9:47 ` Linus Walleij 0 siblings, 0 replies; 4+ messages in thread From: Linus Walleij @ 2025-02-14 9:47 UTC (permalink / raw) To: Bartosz Golaszewski; +Cc: linux-gpio, linux-kernel, Bartosz Golaszewski On Tue, Feb 11, 2025 at 1:08 PM Bartosz Golaszewski <brgl@bgdev.pl> wrote: > From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> > > Make the code a bit more readable by using a helper variable to store > the address of pdev->dev in probe(). > > Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> Reviewed-by: Linus Walleij <linus.walleij@linaro.org> Yours, Linus Walleij ^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH 1/2] gpio: latch: use generic device properties 2025-02-11 12:08 [PATCH 1/2] gpio: latch: use generic device properties Bartosz Golaszewski 2025-02-11 12:08 ` [PATCH 2/2] gpio: latch: store the address of pdev->dev in a helper variable Bartosz Golaszewski @ 2025-02-17 8:47 ` Bartosz Golaszewski 1 sibling, 0 replies; 4+ messages in thread From: Bartosz Golaszewski @ 2025-02-17 8:47 UTC (permalink / raw) To: Linus Walleij, Bartosz Golaszewski Cc: Bartosz Golaszewski, linux-gpio, linux-kernel From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> On Tue, 11 Feb 2025 13:08:46 +0100, Bartosz Golaszewski wrote: > Replace calls to OF-specific interface with generic device property > getters. This is good practice and also drops implicit run-time > dependency on CONFIG_OF. > > Applied, thanks! [1/2] gpio: latch: use generic device properties commit: 3c998af7ceae2c86b4b0e128d5e47b3c1e1f8f05 [2/2] gpio: latch: store the address of pdev->dev in a helper variable commit: 80bcee25b592b018203be1ddb20ede8d207a552a Best regards, -- Bartosz Golaszewski <bartosz.golaszewski@linaro.org> ^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2025-02-17 8:47 UTC | newest] Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed) -- links below jump to the message on this page -- 2025-02-11 12:08 [PATCH 1/2] gpio: latch: use generic device properties Bartosz Golaszewski 2025-02-11 12:08 ` [PATCH 2/2] gpio: latch: store the address of pdev->dev in a helper variable Bartosz Golaszewski 2025-02-14 9:47 ` Linus Walleij 2025-02-17 8:47 ` [PATCH 1/2] gpio: latch: use generic device properties Bartosz Golaszewski
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®