mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] efi: efibc: change kmalloc(size * count, ...) to kmalloc_array()
@ 2025-03-09  1:27 Ethan Carter Edwards
  2025-03-10 17:23 ` Ard Biesheuvel
  0 siblings, 1 reply; 2+ messages in thread
From: Ethan Carter Edwards @ 2025-03-09  1:27 UTC (permalink / raw)
  To: Ard Biesheuvel
  Cc: linux-efi, linux-kernel, linux-hardening, Ethan Carter Edwards

Open coded arithmetic in allocator arguments is discouraged. Helper
functions like kcalloc or, in this case, kmalloc_array are preferred.

Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments

Signed-off-by: Ethan Carter Edwards <ethan@ethancedwards.com>
---
 drivers/firmware/efi/efibc.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/firmware/efi/efibc.c b/drivers/firmware/efi/efibc.c
index 4f9fb086eab7b0e22252d22e59e5aae55865322d..0a7c764dcc614fbba3cbcd94183dc07939837a03 100644
--- a/drivers/firmware/efi/efibc.c
+++ b/drivers/firmware/efi/efibc.c
@@ -47,7 +47,7 @@ static int efibc_reboot_notifier_call(struct notifier_block *notifier,
 	if (ret || !data)
 		return NOTIFY_DONE;
 
-	wdata = kmalloc(MAX_DATA_LEN * sizeof(efi_char16_t), GFP_KERNEL);
+	wdata = kmalloc_array(MAX_DATA_LEN, sizeof(efi_char16_t), GFP_KERNEL);
 	if (!wdata)
 		return NOTIFY_DONE;
 

---
base-commit: 0a2f889128969dab41861b6e40111aa03dc57014
change-id: 20250308-efibc-kmalloc_array-ba78097a0708

Best regards,
-- 
Ethan Carter Edwards <ethan@ethancedwards.com>


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH] efi: efibc: change kmalloc(size * count, ...) to kmalloc_array()
  2025-03-09  1:27 [PATCH] efi: efibc: change kmalloc(size * count, ...) to kmalloc_array() Ethan Carter Edwards
@ 2025-03-10 17:23 ` Ard Biesheuvel
  0 siblings, 0 replies; 2+ messages in thread
From: Ard Biesheuvel @ 2025-03-10 17:23 UTC (permalink / raw)
  To: Ethan Carter Edwards; +Cc: linux-efi, linux-kernel, linux-hardening

On Sun, 9 Mar 2025 at 02:27, Ethan Carter Edwards
<ethan@ethancedwards.com> wrote:
>
> Open coded arithmetic in allocator arguments is discouraged. Helper
> functions like kcalloc or, in this case, kmalloc_array are preferred.
>
> Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Ethan Carter Edwards <ethan@ethancedwards.com>
> ---
>  drivers/firmware/efi/efibc.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/firmware/efi/efibc.c b/drivers/firmware/efi/efibc.c
> index 4f9fb086eab7b0e22252d22e59e5aae55865322d..0a7c764dcc614fbba3cbcd94183dc07939837a03 100644
> --- a/drivers/firmware/efi/efibc.c
> +++ b/drivers/firmware/efi/efibc.c
> @@ -47,7 +47,7 @@ static int efibc_reboot_notifier_call(struct notifier_block *notifier,
>         if (ret || !data)
>                 return NOTIFY_DONE;
>
> -       wdata = kmalloc(MAX_DATA_LEN * sizeof(efi_char16_t), GFP_KERNEL);
> +       wdata = kmalloc_array(MAX_DATA_LEN, sizeof(efi_char16_t), GFP_KERNEL);
>         if (!wdata)
>                 return NOTIFY_DONE;
>
>
> ---
> base-commit: 0a2f889128969dab41861b6e40111aa03dc57014
> change-id: 20250308-efibc-kmalloc_array-ba78097a0708
>

Queued up in efi/next, thanks.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2025-03-10 17:24 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-03-09  1:27 [PATCH] efi: efibc: change kmalloc(size * count, ...) to kmalloc_array() Ethan Carter Edwards
2025-03-10 17:23 ` Ard Biesheuvel

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®