mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Arnd Bergmann <arnd@kernel.org>
To: Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	Maxime Coquelin <mcoquelin.stm32@gmail.com>,
	Alexandre Torgue <alexandre.torgue@foss.st.com>
Cc: "Krzysztof Kozlowski" <krzysztof.kozlowski@linaro.org>,
	"Andy Shevchenko" <andriy.shevchenko@linux.intel.com>,
	"Arnd Bergmann" <arnd@arndb.de>,
	"Oliver Graute" <oliver.graute@kococonnector.com>,
	"Uwe Kleine-König" <u.kleine-koenig@baylibre.com>,
	"Yu Jiaoliang" <yujiaoliang@vivo.com>,
	linux-input@vger.kernel.org,
	linux-stm32@st-md-mailman.stormreply.com,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org
Subject: [PATCH 03/10] [v2] Input: stmpe-ts - use module alias instead of device table
Date: Wed,  9 Apr 2025 14:22:55 +0200	[thread overview]
Message-ID: <20250409122314.2848028-3-arnd@kernel.org> (raw)
In-Reply-To: <20250409122314.2848028-1-arnd@kernel.org>

From: Arnd Bergmann <arnd@arndb.de>

When compile tested with W=1 on x86_64 with driver as built-in:

  stmpe-ts.c:371:34: error: unused variable 'stmpe_ts_ids' [-Werror,-Wunused-const-variable]

Ideally this would be referenced from the platform_driver, but since
the compatible string is already matched by the mfd driver for its
parent device, that would break probing.

In this case, the of_device_id table just serves as a module alias
for loading the driver, while the device itself is probed using
the platform device name.

Remove the table and instead use a module alias that reflects how
the driver is actually probed.

Link: https://lore.kernel.org/lkml/20240403080702.3509288-8-arnd@kernel.org/
Link: https://lore.kernel.org/lkml/181dbdb8-c050-4966-8cb4-2f39495ff3f9@app.fastmail.com/
Cc: Uwe Kleine-König" <u.kleine-koenig@baylibre.com>
Cc: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
---
v2: use a different approach, hopefully this makes more sense.
---
 drivers/input/touchscreen/stmpe-ts.c | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)

diff --git a/drivers/input/touchscreen/stmpe-ts.c b/drivers/input/touchscreen/stmpe-ts.c
index a94a1997f96b..af0fb38bcfdc 100644
--- a/drivers/input/touchscreen/stmpe-ts.c
+++ b/drivers/input/touchscreen/stmpe-ts.c
@@ -366,12 +366,7 @@ static struct platform_driver stmpe_ts_driver = {
 };
 module_platform_driver(stmpe_ts_driver);
 
-static const struct of_device_id stmpe_ts_ids[] = {
-	{ .compatible = "st,stmpe-ts", },
-	{ },
-};
-MODULE_DEVICE_TABLE(of, stmpe_ts_ids);
-
+MODULE_ALIAS("platform:stmpe-ts");
 MODULE_AUTHOR("Luotao Fu <l.fu@pengutronix.de>");
 MODULE_DESCRIPTION("STMPEXXX touchscreen driver");
 MODULE_LICENSE("GPL");
-- 
2.39.5


  parent reply	other threads:[~2025-04-09 12:23 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-09 12:21 [PATCH 00/10] -Wunused-const-variable warning fixes Arnd Bergmann
2025-04-09 12:22 ` [PATCH 01/10] drm/imagination: avoid unused-const-variable warning Arnd Bergmann
2025-04-09 12:22   ` [PATCH 02/10] [v2] clocksource: atmel_tcb: fix kconfig dependency Arnd Bergmann
2025-04-09 12:47     ` Alexandre Belloni
2025-04-09 15:30     ` Andy Shevchenko
2025-04-09 15:53       ` Arnd Bergmann
2025-04-09 12:22   ` Arnd Bergmann [this message]
2025-04-09 15:33     ` [PATCH 03/10] [v2] Input: stmpe-ts - use module alias instead of device table Andy Shevchenko
2025-04-09 15:49       ` Krzysztof Kozlowski
2025-04-09 12:22   ` [PATCH 04/10] [RESEND] mux: adg792a: remove incorrect of_match_ptr annotation Arnd Bergmann
2025-04-09 15:34     ` Andy Shevchenko
2025-05-01 17:56     ` (subset) " Krzysztof Kozlowski
2025-04-09 12:22   ` [PATCH 05/10] [RESEND] sched: open-code max_rt_runtime definition Arnd Bergmann
2025-04-09 12:22   ` [PATCH 06/10] [RESEND] lockdep: change 'static const' variables to enum values Arnd Bergmann
2025-05-02 14:02     ` Andy Shevchenko
2025-07-11 22:13       ` Boqun Feng
2025-07-19 17:40     ` [tip: locking/core] locking/lockdep: Change " tip-bot2 for Arnd Bergmann
2025-04-09 12:22   ` [PATCH 07/10] [RESEND] ARM: fixmap: make __end_of_early_ioremap_region an enum value Arnd Bergmann
2025-04-09 16:54     ` Andy Shevchenko
2025-04-09 12:23   ` [PATCH 08/10] [RESEND 2] comedi: ni_atmio: avoid warning for unused device_ids[] table Arnd Bergmann
2025-04-09 12:23   ` [PATCH 09/10] [RESEND 2] apm-emulation: hide an unused variable Arnd Bergmann
2025-04-10 11:22   ` [PATCH 01/10] drm/imagination: avoid unused-const-variable warning Matt Coster
2025-04-10 11:56     ` Jani Nikula
2025-04-10 11:58     ` Arnd Bergmann
2025-04-14  6:51     ` Andy Shevchenko
2025-04-22 16:08   ` Matt Coster
2025-04-24 10:04   ` (subset) " Matt Coster
2025-04-09 12:24 ` [PATCH 10/10] [RESEND 3] dma/contiguous: avoid warning about unused size_bytes Arnd Bergmann
2025-04-09 14:35   ` Marek Szyprowski
2025-04-09 14:43     ` Andy Shevchenko
2025-04-09 14:51       ` Arnd Bergmann
2025-04-09 14:57         ` Marek Szyprowski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250409122314.2848028-3-arnd@kernel.org \
    --to=arnd@kernel.org \
    --cc=alexandre.torgue@foss.st.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=arnd@arndb.de \
    --cc=dmitry.torokhov@gmail.com \
    --cc=krzysztof.kozlowski@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-stm32@st-md-mailman.stormreply.com \
    --cc=mcoquelin.stm32@gmail.com \
    --cc=oliver.graute@kococonnector.com \
    --cc=u.kleine-koenig@baylibre.com \
    --cc=yujiaoliang@vivo.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®