From: Marek Szyprowski <m.szyprowski@samsung.com>
To: Arnd Bergmann <arnd@kernel.org>,
Michal Nazarewicz <mina86@mina86.com>,
Arnd Bergmann <arnd@arndb.de>,
Kyungmin Park <kyungmin.park@samsung.com>
Cc: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>,
Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Robin Murphy <robin.murphy@arm.com>,
iommu@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 10/10] [RESEND 3] dma/contiguous: avoid warning about unused size_bytes
Date: Wed, 9 Apr 2025 16:35:57 +0200 [thread overview]
Message-ID: <59af67fa-ca0d-48f6-8b78-b1c694af9dfd@samsung.com> (raw)
In-Reply-To: <20250409122441.2875424-1-arnd@kernel.org>
On 09.04.2025 14:24, Arnd Bergmann wrote:
> From: Arnd Bergmann <arnd@arndb.de>
>
> When building with W=1, this variable is unused for configs with
> CONFIG_CMA_SIZE_SEL_PERCENTAGE=y:
>
> kernel/dma/contiguous.c:67:26: error: 'size_bytes' defined but not used [-Werror=unused-const-variable=]
>
> Change this to a macro to avoid the warning.
>
> Fixes: c64be2bb1c6e ("drivers: add Contiguous Memory Allocator")
> Signed-off-by: Arnd Bergmann <arnd@arndb.de>
Thanks, applied to dma-mapping-fixes branch.
> ---
> v3: use a macro instead of constant
> v2: fix spelling mistake.
> ---
> kernel/dma/contiguous.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/kernel/dma/contiguous.c b/kernel/dma/contiguous.c
> index 055da410ac71..88888f4c1c73 100644
> --- a/kernel/dma/contiguous.c
> +++ b/kernel/dma/contiguous.c
> @@ -64,8 +64,7 @@ struct cma *dma_contiguous_default_area;
> * Users, who want to set the size of global CMA area for their system
> * should use cma= kernel parameter.
> */
> -static const phys_addr_t size_bytes __initconst =
> - (phys_addr_t)CMA_SIZE_MBYTES * SZ_1M;
> +#define size_bytes (CMA_SIZE_MBYTES * SZ_1M)
> static phys_addr_t size_cmdline __initdata = -1;
> static phys_addr_t base_cmdline __initdata;
> static phys_addr_t limit_cmdline __initdata;
Best regards
--
Marek Szyprowski, PhD
Samsung R&D Institute Poland
next prev parent reply other threads:[~2025-04-09 14:36 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-09 12:21 [PATCH 00/10] -Wunused-const-variable warning fixes Arnd Bergmann
2025-04-09 12:22 ` [PATCH 01/10] drm/imagination: avoid unused-const-variable warning Arnd Bergmann
2025-04-09 12:22 ` [PATCH 02/10] [v2] clocksource: atmel_tcb: fix kconfig dependency Arnd Bergmann
2025-04-09 12:47 ` Alexandre Belloni
2025-04-09 15:30 ` Andy Shevchenko
2025-04-09 15:53 ` Arnd Bergmann
2025-04-09 12:22 ` [PATCH 03/10] [v2] Input: stmpe-ts - use module alias instead of device table Arnd Bergmann
2025-04-09 15:33 ` Andy Shevchenko
2025-04-09 15:49 ` Krzysztof Kozlowski
2025-04-09 12:22 ` [PATCH 04/10] [RESEND] mux: adg792a: remove incorrect of_match_ptr annotation Arnd Bergmann
2025-04-09 15:34 ` Andy Shevchenko
2025-05-01 17:56 ` (subset) " Krzysztof Kozlowski
2025-04-09 12:22 ` [PATCH 05/10] [RESEND] sched: open-code max_rt_runtime definition Arnd Bergmann
2025-04-09 12:22 ` [PATCH 06/10] [RESEND] lockdep: change 'static const' variables to enum values Arnd Bergmann
2025-05-02 14:02 ` Andy Shevchenko
2025-07-11 22:13 ` Boqun Feng
2025-07-19 17:40 ` [tip: locking/core] locking/lockdep: Change " tip-bot2 for Arnd Bergmann
2025-04-09 12:22 ` [PATCH 07/10] [RESEND] ARM: fixmap: make __end_of_early_ioremap_region an enum value Arnd Bergmann
2025-04-09 16:54 ` Andy Shevchenko
2025-04-09 12:23 ` [PATCH 08/10] [RESEND 2] comedi: ni_atmio: avoid warning for unused device_ids[] table Arnd Bergmann
2025-04-09 12:23 ` [PATCH 09/10] [RESEND 2] apm-emulation: hide an unused variable Arnd Bergmann
2025-04-10 11:22 ` [PATCH 01/10] drm/imagination: avoid unused-const-variable warning Matt Coster
2025-04-10 11:56 ` Jani Nikula
2025-04-10 11:58 ` Arnd Bergmann
2025-04-14 6:51 ` Andy Shevchenko
2025-04-22 16:08 ` Matt Coster
2025-04-24 10:04 ` (subset) " Matt Coster
2025-04-09 12:24 ` [PATCH 10/10] [RESEND 3] dma/contiguous: avoid warning about unused size_bytes Arnd Bergmann
2025-04-09 14:35 ` Marek Szyprowski [this message]
2025-04-09 14:43 ` Andy Shevchenko
2025-04-09 14:51 ` Arnd Bergmann
2025-04-09 14:57 ` Marek Szyprowski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=59af67fa-ca0d-48f6-8b78-b1c694af9dfd@samsung.com \
--to=m.szyprowski@samsung.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=arnd@arndb.de \
--cc=arnd@kernel.org \
--cc=iommu@lists.linux.dev \
--cc=krzysztof.kozlowski@linaro.org \
--cc=kyungmin.park@samsung.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mina86@mina86.com \
--cc=robin.murphy@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®