mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ingo Molnar <mingo@kernel.org>
To: linux-kernel@vger.kernel.org
Cc: Andy Shevchenko <andy@kernel.org>,
	Arnd Bergmann <arnd@kernel.org>, Borislav Petkov <bp@alien8.de>,
	Juergen Gross <jgross@suse.com>,
	"H . Peter Anvin" <hpa@zytor.com>,
	Kees Cook <keescook@chromium.org>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Mike Rapoport <rppt@kernel.org>,
	Paul Menzel <pmenzel@molgen.mpg.de>,
	Peter Zijlstra <peterz@infradead.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@kernel.org>,
	David Woodhouse <dwmw@amazon.co.uk>
Subject: [PATCH 26/29] x86/boot/e820: Remove e820__range_remove()'s unused return parameter
Date: Mon, 21 Apr 2025 20:52:06 +0200	[thread overview]
Message-ID: <20250421185210.3372306-27-mingo@kernel.org> (raw)
In-Reply-To: <20250421185210.3372306-1-mingo@kernel.org>

None of the usage sites make use of the 'real_removed_size'
return parameter of e820__range_remove(), and it's hard
to contemplate much constructive use: E820 maps can have
holes, and removing a fixed range may result in removal
of any number of bytes from 0 to the requested size.

So remove this pointless calculation. This simplifies
the function a bit:

   text       data        bss        dec        hex    filename
   7645      44072          0      51717       ca05    e820.o.before
   7597      44072          0      51669       c9d5    e820.o.after

Signed-off-by: Ingo Molnar <mingo@kernel.org>
Cc: Andy Shevchenko <andy@kernel.org>
Cc: Arnd Bergmann <arnd@kernel.org>
Cc: David Woodhouse <dwmw@amazon.co.uk>
Cc: H. Peter Anvin <hpa@zytor.com>
Cc: Kees Cook <keescook@chromium.org>
Cc: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Mike Rapoport (Microsoft) <rppt@kernel.org>
---
 arch/x86/include/asm/e820/api.h | 2 +-
 arch/x86/kernel/e820.c          | 8 +-------
 2 files changed, 2 insertions(+), 8 deletions(-)

diff --git a/arch/x86/include/asm/e820/api.h b/arch/x86/include/asm/e820/api.h
index 54427b77bc19..9cf416f7a84f 100644
--- a/arch/x86/include/asm/e820/api.h
+++ b/arch/x86/include/asm/e820/api.h
@@ -16,7 +16,7 @@ extern bool e820__mapped_all(u64 start, u64 end, enum e820_type type);
 
 extern void e820__range_add   (u64 start, u64 size, enum e820_type type);
 extern u64  e820__range_update(u64 start, u64 size, enum e820_type old_type, enum e820_type new_type);
-extern u64  e820__range_remove(u64 start, u64 size, enum e820_type old_type, bool check_type);
+extern void e820__range_remove(u64 start, u64 size, enum e820_type old_type, bool check_type);
 extern u64  e820__range_update_table(struct e820_table *t, u64 start, u64 size, enum e820_type old_type, enum e820_type new_type);
 
 extern int  e820__update_table(struct e820_table *table);
diff --git a/arch/x86/kernel/e820.c b/arch/x86/kernel/e820.c
index 27bc45a65807..2f9aecb9911c 100644
--- a/arch/x86/kernel/e820.c
+++ b/arch/x86/kernel/e820.c
@@ -590,11 +590,10 @@ __init u64 e820__range_update_table(struct e820_table *t, u64 start, u64 size,
 }
 
 /* Remove a range of memory from the E820 table: */
-__init u64 e820__range_remove(u64 start, u64 size, enum e820_type old_type, bool check_type)
+__init void e820__range_remove(u64 start, u64 size, enum e820_type old_type, bool check_type)
 {
 	u32 idx;
 	u64 end;
-	u64 real_removed_size = 0;
 
 	if (size > (ULLONG_MAX - start))
 		size = ULLONG_MAX - start;
@@ -617,7 +616,6 @@ __init u64 e820__range_remove(u64 start, u64 size, enum e820_type old_type, bool
 
 		/* Completely covered? */
 		if (entry->addr >= start && entry_end <= end) {
-			real_removed_size += entry->size;
 			memset(entry, 0, sizeof(*entry));
 			continue;
 		}
@@ -626,7 +624,6 @@ __init u64 e820__range_remove(u64 start, u64 size, enum e820_type old_type, bool
 		if (entry->addr < start && entry_end > end) {
 			e820__range_add(end, entry_end - end, entry->type);
 			entry->size = start - entry->addr;
-			real_removed_size += size;
 			continue;
 		}
 
@@ -636,8 +633,6 @@ __init u64 e820__range_remove(u64 start, u64 size, enum e820_type old_type, bool
 		if (final_start >= final_end)
 			continue;
 
-		real_removed_size += final_end - final_start;
-
 		/*
 		 * Left range could be head or tail, so need to update
 		 * the size first:
@@ -648,7 +643,6 @@ __init u64 e820__range_remove(u64 start, u64 size, enum e820_type old_type, bool
 
 		entry->addr = final_end;
 	}
-	return real_removed_size;
 }
 
 __init void e820__update_table_print(void)
-- 
2.45.2


  parent reply	other threads:[~2025-04-21 18:54 UTC|newest]

Thread overview: 68+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-21 18:51 [PATCH 00/29] x86/boot/e820: Assorted E820 table handling features and cleanups Ingo Molnar
2025-04-21 18:51 ` [PATCH 01/29] x86/boot/e820: Remove inverted boolean logic from the e820_nomerge() function name, rename it to e820_type_mergeable() Ingo Molnar
2025-04-21 18:51 ` [PATCH 02/29] x86/boot/e820: Simplify e820__print_table() a bit Ingo Molnar
2025-04-22  5:56   ` Mike Rapoport
2025-05-15 10:15     ` Ingo Molnar
2025-04-21 18:51 ` [PATCH 03/29] x86/boot/e820: Simplify the PPro Erratum #50 workaround Ingo Molnar
2025-04-22  6:29   ` Andy Shevchenko
2025-05-15 10:20     ` Ingo Molnar
2025-04-21 18:51 ` [PATCH 04/29] x86/boot/e820: Mark e820__print_table() static Ingo Molnar
2025-04-21 18:51 ` [PATCH 05/29] x86/boot/e820: Print gaps in the E820 table Ingo Molnar
2025-04-22  6:00   ` Mike Rapoport
2025-04-22  6:26     ` Andy Shevchenko
2025-05-15 10:23       ` Ingo Molnar
2025-04-22  6:42   ` Andy Shevchenko
2025-05-15 10:28     ` Ingo Molnar
2025-05-16  9:13       ` Andy Shevchenko
2025-04-21 18:51 ` [PATCH 06/29] x86/boot/e820: Make the field separator space character part of e820_print_type() Ingo Molnar
2025-04-21 18:51 ` [PATCH 07/29] x86/boot/e820: Print out sizes of E820 memory ranges Ingo Molnar
2025-04-22  6:38   ` Andy Shevchenko
2025-05-15 10:44     ` Ingo Molnar
2025-05-15 10:50       ` Ingo Molnar
2025-05-16  9:15       ` Andy Shevchenko
2025-04-22  6:53   ` Mike Rapoport
2025-05-15 11:00     ` Ingo Molnar
2025-04-21 18:51 ` [PATCH 08/29] x86/boot/e820: Print E820_TYPE_RAM entries as ... RAM entries Ingo Molnar
2025-04-22  6:31   ` Andy Shevchenko
2025-04-22  6:43     ` Mike Rapoport
2025-05-15 11:04       ` Ingo Molnar
2025-04-22  7:06   ` Mike Rapoport
2025-05-15 11:19     ` [PATCH 30/29] x86/boot/e820: Unify e820_print_type() and e820_type_to_string() Ingo Molnar
2025-04-21 18:51 ` [PATCH 09/29] x86/boot/e820: Call the PCI gap a 'gap' in the boot log printout Ingo Molnar
2025-04-21 18:51 ` [PATCH 10/29] x86/boot/e820: Use 'u64' consistently instead of 'unsigned long long' Ingo Molnar
2025-04-22  6:44   ` Andy Shevchenko
2025-05-15 11:20     ` Ingo Molnar
2025-04-21 18:51 ` [PATCH 11/29] x86/boot/e820: Remove pointless early_panic() indirection Ingo Molnar
2025-04-21 18:51 ` [PATCH 12/29] x86/boot/e820: Clean up confusing and self-contradictory verbiage around E820 related resource allocations Ingo Molnar
2025-04-21 18:51 ` [PATCH 13/29] x86/boot/e820: Improve e820_print_type() messages Ingo Molnar
2025-04-21 18:51 ` [PATCH 14/29] x86/boot/e820: Clean up __e820__range_add() a bit Ingo Molnar
2025-04-22 10:10   ` Andy Shevchenko
2025-05-15 11:21     ` Ingo Molnar
2025-04-21 18:51 ` [PATCH 15/29] x86/boot/e820: Clean up __refdata use " Ingo Molnar
2025-04-21 18:51 ` [PATCH 16/29] x86/boot/e820: Remove unnecessary header inclusions Ingo Molnar
2025-04-21 18:51 ` [PATCH 17/29] x86/boot/e820: Standardize e820 table index variable names under 'idx' Ingo Molnar
2025-04-22 10:23   ` Andy Shevchenko
2025-05-15 11:32     ` [PATCH 31/29] x86/boot/e820: Move index increments outside accessors in e820__update_table() Ingo Molnar
2025-05-15 11:37     ` [PATCH 17/29] x86/boot/e820: Standardize e820 table index variable names under 'idx' Ingo Molnar
2025-04-21 18:51 ` [PATCH 18/29] x86/boot/e820: Change struct e820_table::nr_entries type from __u32 to u32 Ingo Molnar
2025-04-21 18:51 ` [PATCH 19/29] x86/boot/e820: Standardize e820 table index variable types under 'u32' Ingo Molnar
2025-04-22 15:13   ` Andy Shevchenko
2025-05-15 11:39     ` Ingo Molnar
2025-04-21 18:52 ` [PATCH 20/29] x86/boot/e820: Clean up e820__setup_pci_gap()/e820_search_gap() a bit Ingo Molnar
2025-04-22 16:37   ` Andy Shevchenko
2025-05-15 11:44     ` Ingo Molnar
2025-04-21 18:52 ` [PATCH 21/29] x86/boot/e820: Change e820_search_gap() to search for the highest-address PCI gap Ingo Molnar
2025-04-21 18:52 ` [PATCH 22/29] x86/boot/e820: Rename gap_start/gap_size to max_gap_start/max_gap_start in e820_search_gap() et al Ingo Molnar
2025-04-21 18:52 ` [PATCH 23/29] x86/boot/e820: Simplify & clarify __e820__range_add() a bit Ingo Molnar
2025-04-21 18:52 ` [PATCH 24/29] x86/boot/e820: Standardize __init/__initdata tag placement Ingo Molnar
2025-04-21 18:52 ` [PATCH 25/29] x86/boot/e820: Simplify append_e820_table() and remove restriction on single-entry tables Ingo Molnar
2025-04-21 18:52 ` Ingo Molnar [this message]
2025-04-21 18:52 ` [PATCH 27/29] x86/boot/e820: Simplify the e820__range_remove() API Ingo Molnar
2025-04-22 16:41   ` Andy Shevchenko
2025-05-15 11:49     ` Ingo Molnar
2025-04-21 18:52 ` [PATCH 28/29] x86/boot/e820: Make sure e820_search_gap() finds all gaps Ingo Molnar
2025-04-21 18:52 ` [PATCH 29/29] x86/boot/e820: Treat non-type-2 'reserved' E820 region types as E820_TYPE_RESERVED Ingo Molnar
2025-04-25  3:55   ` H. Peter Anvin
2025-05-15 10:04     ` [PATCH -v2 29/29] x86/boot/e820: Introduce E820_TYPE_13 and treat it as a device region Ingo Molnar
2025-04-22  6:58 ` [PATCH 00/29] x86/boot/e820: Assorted E820 table handling features and cleanups Arnd Bergmann
2025-05-15 11:56   ` Ingo Molnar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250421185210.3372306-27-mingo@kernel.org \
    --to=mingo@kernel.org \
    --cc=andy@kernel.org \
    --cc=arnd@kernel.org \
    --cc=bp@alien8.de \
    --cc=dwmw@amazon.co.uk \
    --cc=hpa@zytor.com \
    --cc=jgross@suse.com \
    --cc=keescook@chromium.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=peterz@infradead.org \
    --cc=pmenzel@molgen.mpg.de \
    --cc=rppt@kernel.org \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®