mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andy Shevchenko <andy@kernel.org>
To: Ingo Molnar <mingo@kernel.org>
Cc: linux-kernel@vger.kernel.org, Arnd Bergmann <arnd@kernel.org>,
	Borislav Petkov <bp@alien8.de>, Juergen Gross <jgross@suse.com>,
	"H . Peter Anvin" <hpa@zytor.com>,
	Kees Cook <keescook@chromium.org>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Mike Rapoport <rppt@kernel.org>,
	Paul Menzel <pmenzel@molgen.mpg.de>,
	Peter Zijlstra <peterz@infradead.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	David Woodhouse <dwmw@amazon.co.uk>
Subject: Re: [PATCH 27/29] x86/boot/e820: Simplify the e820__range_remove() API
Date: Tue, 22 Apr 2025 19:41:53 +0300	[thread overview]
Message-ID: <aAfG0fSVFVNciAqi@smile.fi.intel.com> (raw)
In-Reply-To: <20250421185210.3372306-28-mingo@kernel.org>

On Mon, Apr 21, 2025 at 08:52:07PM +0200, Ingo Molnar wrote:
> Right now e820__range_remove() has two parameters to control the
> E820 type of the range removed:
> 
> 	extern void e820__range_remove(u64 start, u64 size, enum e820_type old_type, bool check_type);
> 
> Since E820 types start at 1, zero has a natural meaning of 'no type.
> 
> Consolidate the (old_type,check_type) parameters into a single (filter_type)
> parameter:
> 
> 	extern void e820__range_remove(u64 start, u64 size, enum e820_type filter_type);
> 
> Note that both e820__mapped_raw_any() and e820__mapped_any()
> already have such semantics for their 'type' parameter, although
> it's currently not used with '0' by in-kernel code.
> 
> Also, the __e820__mapped_all() internal helper already has such
> semantics implemented as well, and the e820__get_entry_type() API
> uses the '0' type to such effect.
> 
> This simplifies not just e820__range_remove(), and synchronizes its
> use of type filters with other E820 API functions, but simplifies
> usage sites as well, such as parse_memmap_one(), beyond the reduction
> of the number of parameters:
> 
>   -               else if (from)
>   -                       e820__range_remove(start_at, mem_size, from, 1);
>                   else
>   -                       e820__range_remove(start_at, mem_size, 0, 0);
>   +                       e820__range_remove(start_at, mem_size, from);
> 
> The generated code gets smaller as well:
> 
> 	add/remove: 0/0 grow/shrink: 0/5 up/down: 0/-66 (-66)
> 
> 	Function                                     old     new   delta
> 	parse_memopt                                 112     107      -5
> 	efi_init                                    1048    1039      -9
> 	setup_arch                                  2719    2709     -10
> 	e820__range_remove                           283     273     -10
> 	parse_memmap_opt                             559     527     -32
> 
> 	Total: Before=22,675,600, After=22,675,534, chg -0.00%

>  extern void e820__range_add   (u64 start, u64 size, enum e820_type type);
>  extern u64  e820__range_update(u64 start, u64 size, enum e820_type old_type, enum e820_type new_type);
> -extern void e820__range_remove(u64 start, u64 size, enum e820_type old_type, bool check_type);
> +extern void e820__range_remove(u64 start, u64 size, enum e820_type filter_type);
>  extern u64  e820__range_update_table(struct e820_table *t, u64 start, u64 size, enum e820_type old_type, enum e820_type new_type);
>  
>  extern int  e820__update_table(struct e820_table *table);

Wondering if are going to get rid of 'extern' for the functions...

-- 
With Best Regards,
Andy Shevchenko



  reply	other threads:[~2025-04-22 16:42 UTC|newest]

Thread overview: 68+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-21 18:51 [PATCH 00/29] x86/boot/e820: Assorted E820 table handling features and cleanups Ingo Molnar
2025-04-21 18:51 ` [PATCH 01/29] x86/boot/e820: Remove inverted boolean logic from the e820_nomerge() function name, rename it to e820_type_mergeable() Ingo Molnar
2025-04-21 18:51 ` [PATCH 02/29] x86/boot/e820: Simplify e820__print_table() a bit Ingo Molnar
2025-04-22  5:56   ` Mike Rapoport
2025-05-15 10:15     ` Ingo Molnar
2025-04-21 18:51 ` [PATCH 03/29] x86/boot/e820: Simplify the PPro Erratum #50 workaround Ingo Molnar
2025-04-22  6:29   ` Andy Shevchenko
2025-05-15 10:20     ` Ingo Molnar
2025-04-21 18:51 ` [PATCH 04/29] x86/boot/e820: Mark e820__print_table() static Ingo Molnar
2025-04-21 18:51 ` [PATCH 05/29] x86/boot/e820: Print gaps in the E820 table Ingo Molnar
2025-04-22  6:00   ` Mike Rapoport
2025-04-22  6:26     ` Andy Shevchenko
2025-05-15 10:23       ` Ingo Molnar
2025-04-22  6:42   ` Andy Shevchenko
2025-05-15 10:28     ` Ingo Molnar
2025-05-16  9:13       ` Andy Shevchenko
2025-04-21 18:51 ` [PATCH 06/29] x86/boot/e820: Make the field separator space character part of e820_print_type() Ingo Molnar
2025-04-21 18:51 ` [PATCH 07/29] x86/boot/e820: Print out sizes of E820 memory ranges Ingo Molnar
2025-04-22  6:38   ` Andy Shevchenko
2025-05-15 10:44     ` Ingo Molnar
2025-05-15 10:50       ` Ingo Molnar
2025-05-16  9:15       ` Andy Shevchenko
2025-04-22  6:53   ` Mike Rapoport
2025-05-15 11:00     ` Ingo Molnar
2025-04-21 18:51 ` [PATCH 08/29] x86/boot/e820: Print E820_TYPE_RAM entries as ... RAM entries Ingo Molnar
2025-04-22  6:31   ` Andy Shevchenko
2025-04-22  6:43     ` Mike Rapoport
2025-05-15 11:04       ` Ingo Molnar
2025-04-22  7:06   ` Mike Rapoport
2025-05-15 11:19     ` [PATCH 30/29] x86/boot/e820: Unify e820_print_type() and e820_type_to_string() Ingo Molnar
2025-04-21 18:51 ` [PATCH 09/29] x86/boot/e820: Call the PCI gap a 'gap' in the boot log printout Ingo Molnar
2025-04-21 18:51 ` [PATCH 10/29] x86/boot/e820: Use 'u64' consistently instead of 'unsigned long long' Ingo Molnar
2025-04-22  6:44   ` Andy Shevchenko
2025-05-15 11:20     ` Ingo Molnar
2025-04-21 18:51 ` [PATCH 11/29] x86/boot/e820: Remove pointless early_panic() indirection Ingo Molnar
2025-04-21 18:51 ` [PATCH 12/29] x86/boot/e820: Clean up confusing and self-contradictory verbiage around E820 related resource allocations Ingo Molnar
2025-04-21 18:51 ` [PATCH 13/29] x86/boot/e820: Improve e820_print_type() messages Ingo Molnar
2025-04-21 18:51 ` [PATCH 14/29] x86/boot/e820: Clean up __e820__range_add() a bit Ingo Molnar
2025-04-22 10:10   ` Andy Shevchenko
2025-05-15 11:21     ` Ingo Molnar
2025-04-21 18:51 ` [PATCH 15/29] x86/boot/e820: Clean up __refdata use " Ingo Molnar
2025-04-21 18:51 ` [PATCH 16/29] x86/boot/e820: Remove unnecessary header inclusions Ingo Molnar
2025-04-21 18:51 ` [PATCH 17/29] x86/boot/e820: Standardize e820 table index variable names under 'idx' Ingo Molnar
2025-04-22 10:23   ` Andy Shevchenko
2025-05-15 11:32     ` [PATCH 31/29] x86/boot/e820: Move index increments outside accessors in e820__update_table() Ingo Molnar
2025-05-15 11:37     ` [PATCH 17/29] x86/boot/e820: Standardize e820 table index variable names under 'idx' Ingo Molnar
2025-04-21 18:51 ` [PATCH 18/29] x86/boot/e820: Change struct e820_table::nr_entries type from __u32 to u32 Ingo Molnar
2025-04-21 18:51 ` [PATCH 19/29] x86/boot/e820: Standardize e820 table index variable types under 'u32' Ingo Molnar
2025-04-22 15:13   ` Andy Shevchenko
2025-05-15 11:39     ` Ingo Molnar
2025-04-21 18:52 ` [PATCH 20/29] x86/boot/e820: Clean up e820__setup_pci_gap()/e820_search_gap() a bit Ingo Molnar
2025-04-22 16:37   ` Andy Shevchenko
2025-05-15 11:44     ` Ingo Molnar
2025-04-21 18:52 ` [PATCH 21/29] x86/boot/e820: Change e820_search_gap() to search for the highest-address PCI gap Ingo Molnar
2025-04-21 18:52 ` [PATCH 22/29] x86/boot/e820: Rename gap_start/gap_size to max_gap_start/max_gap_start in e820_search_gap() et al Ingo Molnar
2025-04-21 18:52 ` [PATCH 23/29] x86/boot/e820: Simplify & clarify __e820__range_add() a bit Ingo Molnar
2025-04-21 18:52 ` [PATCH 24/29] x86/boot/e820: Standardize __init/__initdata tag placement Ingo Molnar
2025-04-21 18:52 ` [PATCH 25/29] x86/boot/e820: Simplify append_e820_table() and remove restriction on single-entry tables Ingo Molnar
2025-04-21 18:52 ` [PATCH 26/29] x86/boot/e820: Remove e820__range_remove()'s unused return parameter Ingo Molnar
2025-04-21 18:52 ` [PATCH 27/29] x86/boot/e820: Simplify the e820__range_remove() API Ingo Molnar
2025-04-22 16:41   ` Andy Shevchenko [this message]
2025-05-15 11:49     ` Ingo Molnar
2025-04-21 18:52 ` [PATCH 28/29] x86/boot/e820: Make sure e820_search_gap() finds all gaps Ingo Molnar
2025-04-21 18:52 ` [PATCH 29/29] x86/boot/e820: Treat non-type-2 'reserved' E820 region types as E820_TYPE_RESERVED Ingo Molnar
2025-04-25  3:55   ` H. Peter Anvin
2025-05-15 10:04     ` [PATCH -v2 29/29] x86/boot/e820: Introduce E820_TYPE_13 and treat it as a device region Ingo Molnar
2025-04-22  6:58 ` [PATCH 00/29] x86/boot/e820: Assorted E820 table handling features and cleanups Arnd Bergmann
2025-05-15 11:56   ` Ingo Molnar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aAfG0fSVFVNciAqi@smile.fi.intel.com \
    --to=andy@kernel.org \
    --cc=arnd@kernel.org \
    --cc=bp@alien8.de \
    --cc=dwmw@amazon.co.uk \
    --cc=hpa@zytor.com \
    --cc=jgross@suse.com \
    --cc=keescook@chromium.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=peterz@infradead.org \
    --cc=pmenzel@molgen.mpg.de \
    --cc=rppt@kernel.org \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®