From: Sean Christopherson <seanjc@google.com>
To: Paolo Bonzini <pbonzini@redhat.com>
Cc: kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
Sean Christopherson <seanjc@google.com>
Subject: [GIT PULL] KVM: x86: SEV changes for 6.17
Date: Fri, 25 Jul 2025 15:07:10 -0700 [thread overview]
Message-ID: <20250725220713.264711-11-seanjc@google.com> (raw)
In-Reply-To: <20250725220713.264711-1-seanjc@google.com>
Note! This pull request is based on tags/x86_core_for_kvm from the tip tree.
Unless you merge that first (I don't think you'll do that?), merging this will
also suck in:
4fdc3431e03b x86/lib: Add WBINVD and WBNOINVD helpers to target multiple CPUs
07f99c3fbe6e x86/lib: Add WBNOINVD helper functions
e638081751a2 x86/lib: Drop the unused return value from wbinvd_on_all_cpus()
1d738dbb252f drm/gpu: Remove dead checks on wbinvd_on_all_cpus()'s return value
Holler if you want the full diff stat, or if you want me to handle dependencies
like this differently in the future.
The following changes since commit 4fdc3431e03b9c11803f399f91837fca487029a1:
x86/lib: Add WBINVD and WBNOINVD helpers to target multiple CPUs (2025-07-10 13:30:17 +0200)
are available in the Git repository at:
https://github.com/kvm-x86/linux.git tags/kvm-x86-sev-6.17
for you to fetch changes up to 6f38f8c574642a822f2e85f079fa29a49176c49c:
KVM: SVM: Flush cache only on CPUs running SEV guest (2025-07-14 15:14:02 -0700)
----------------------------------------------------------------
KVM SEV cache maintenance changes for 6.17
- Drop a superfluous WBINVD (on all CPUs!) when destroying a VM.
- Use WBNOINVD instead of WBINVD when possible, for SEV cache maintenance,
e.g. to minimize collateral damage when reclaiming memory from an SEV guest.
- When reclaiming memory from an SEV guest, only do cache flushes on CPUs that
have ever run a vCPU for the guest, i.e. don't flush the caches for CPUs
that can't possibly have cache lines with dirty, encrypted data.
----------------------------------------------------------------
Kevin Loughlin (1):
KVM: SEV: Prefer WBNOINVD over WBINVD for cache maintenance efficiency
Sean Christopherson (1):
KVM: x86: Use wbinvd_on_cpu() instead of an open-coded equivalent
Zheyun Shen (2):
KVM: SVM: Remove wbinvd in sev_vm_destroy()
KVM: SVM: Flush cache only on CPUs running SEV guest
arch/x86/kvm/svm/sev.c | 110 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++----------------------------
arch/x86/kvm/svm/svm.h | 1 +
arch/x86/kvm/x86.c | 8 +-------
3 files changed, 84 insertions(+), 35 deletions(-)
next prev parent reply other threads:[~2025-07-25 22:07 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-25 22:07 [GIT PULL] KVM: x86: Changes " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: x86: Local APIC refactoring " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: Dirty Ring changes " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: Generic " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: IRQ " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: x86: Misc " Sean Christopherson
2025-07-28 15:11 ` Paolo Bonzini
2025-07-25 22:07 ` [GIT PULL] KVM: x86: MMIO State Data mitigation " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: x86: MMU " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: Device assignment accounting " Sean Christopherson
2025-07-28 15:08 ` Paolo Bonzini
2025-07-25 22:07 ` [GIT PULL] KVM: x86: Selftests " Sean Christopherson
2025-07-25 22:07 ` Sean Christopherson [this message]
2025-07-25 22:07 ` [GIT PULL] KVM: x86: SVM " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: x86: VMX " Sean Christopherson
2025-07-28 15:47 ` Paolo Bonzini
2025-07-29 19:44 ` Sean Christopherson
2025-07-30 17:55 ` Paolo Bonzini
2025-07-28 15:50 ` [GIT PULL] KVM: x86: Changes " Paolo Bonzini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250725220713.264711-11-seanjc@google.com \
--to=seanjc@google.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®