From: Sean Christopherson <seanjc@google.com>
To: Paolo Bonzini <pbonzini@redhat.com>
Cc: kvm@vger.kernel.org, linux-kernel@vger.kernel.org,
Sean Christopherson <seanjc@google.com>
Subject: [GIT PULL] KVM: x86: Local APIC refactoring for 6.17
Date: Fri, 25 Jul 2025 15:07:01 -0700 [thread overview]
Message-ID: <20250725220713.264711-2-seanjc@google.com> (raw)
In-Reply-To: <20250725220713.264711-1-seanjc@google.com>
Move most of KVM's local APIC helpers to common x86 (with new names that are
better suited for global symbols) so that they can be shared by Secure AVIC
(guest side) support[*]. The actual Secure AVIC support is likely destined
for 6.18 or later, and will go through the tip tree (shouldn't have to touch
anything KVM related).
[*] https://lore.kernel.org/all/20250709033242.267892-1-Neeraj.Upadhyay@amd.com
The following changes since commit d7b8f8e20813f0179d8ef519541a3527e7661d3a:
Linux 6.16-rc5 (2025-07-06 14:10:26 -0700)
are available in the Git repository at:
https://github.com/kvm-x86/linux.git tags/kvm-x86-apic-6.17
for you to fetch changes up to b95a9d313642c9f3abebb77a04b41bb7bdd0feef:
x86/apic: Rename 'reg_off' to 'reg' (2025-07-10 09:44:44 -0700)
----------------------------------------------------------------
KVM local APIC changes for 6.17
Extract many of KVM's helpers for accessing architectural local APIC state
to common x86 so that they can be shared by guest-side code for Secure AVIC.
----------------------------------------------------------------
Neeraj Upadhyay (13):
KVM: x86: Open code setting/clearing of bits in the ISR
KVM: x86: Remove redundant parentheses around 'bitmap'
KVM: x86: Rename VEC_POS/REG_POS macro usages
KVM: x86: Change lapic regs base address to void pointer
KVM: x86: Rename find_highest_vector()
KVM: x86: Rename lapic get/set_reg() helpers
KVM: x86: Rename lapic get/set_reg64() helpers
KVM: x86: Rename lapic set/clear vector helpers
x86/apic: KVM: Move apic_find_highest_vector() to a common header
x86/apic: KVM: Move lapic get/set helpers to common code
x86/apic: KVM: Move lapic set/clear_vector() helpers to common code
x86/apic: KVM: Move apic_test)vector() to common code
x86/apic: Rename 'reg_off' to 'reg'
Sean Christopherson (1):
x86/apic: KVM: Deduplicate APIC vector => register+bit math
arch/x86/include/asm/apic.h | 66 +++++++++++++++++++++++++++++-
arch/x86/kvm/lapic.c | 97 ++++++++++++---------------------------------
arch/x86/kvm/lapic.h | 24 ++---------
3 files changed, 94 insertions(+), 93 deletions(-)
next prev parent reply other threads:[~2025-07-25 22:07 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-25 22:07 [GIT PULL] KVM: x86: Changes " Sean Christopherson
2025-07-25 22:07 ` Sean Christopherson [this message]
2025-07-25 22:07 ` [GIT PULL] KVM: Dirty Ring changes " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: Generic " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: IRQ " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: x86: Misc " Sean Christopherson
2025-07-28 15:11 ` Paolo Bonzini
2025-07-25 22:07 ` [GIT PULL] KVM: x86: MMIO State Data mitigation " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: x86: MMU " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: Device assignment accounting " Sean Christopherson
2025-07-28 15:08 ` Paolo Bonzini
2025-07-25 22:07 ` [GIT PULL] KVM: x86: Selftests " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: x86: SEV " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: x86: SVM " Sean Christopherson
2025-07-25 22:07 ` [GIT PULL] KVM: x86: VMX " Sean Christopherson
2025-07-28 15:47 ` Paolo Bonzini
2025-07-29 19:44 ` Sean Christopherson
2025-07-30 17:55 ` Paolo Bonzini
2025-07-28 15:50 ` [GIT PULL] KVM: x86: Changes " Paolo Bonzini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250725220713.264711-2-seanjc@google.com \
--to=seanjc@google.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®