From: Lee Jones <lee@kernel.org>
To: Linus Walleij <linus.walleij@linaro.org>
Cc: Aleksandrs Vinarskis <alex@vinarskis.com>,
Hans de Goede <hansg@kernel.org>, Pavel Machek <pavel@kernel.org>,
Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Bryan O'Donoghue <bryan.odonoghue@linaro.org>,
linux-leds@vger.kernel.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org,
Andy Shevchenko <andy.shevchenko@gmail.com>
Subject: Re: [PATCH 2/2] leds: led-class: Add devicetree support to led_get()
Date: Wed, 3 Sep 2025 07:58:41 +0100 [thread overview]
Message-ID: <20250903065841.GX2163762@google.com> (raw)
In-Reply-To: <CACRpkdanKRPHOzpUV5muwCkNraRDZgoGJnEJ+_=udrtBrqVxwA@mail.gmail.com>
On Wed, 03 Sep 2025, Linus Walleij wrote:
> On Tue, Sep 2, 2025 at 1:10 PM Aleksandrs Vinarskis <alex@vinarskis.com> wrote:
>
> > From: Hans de Goede <hansg@kernel.org>
> >
> > Turn of_led_get() into a more generic __of_led_get() helper function,
> > which can lookup LEDs in devicetree by either name or index.
>
> I don't really like __inner_function() as naming since it
> is easily confused with __COMPILER_FLAGS__ and also
> with __non_atomic_bitset().
>
> I would name it of_led_get_inner() simply.
I'm personally okay with '__' to mean private. There are many examples
of this already. I'm generally less happy with '__' functions being
exported or otherwise used outside of the subsystem / core that they
reside in.
--
Lee Jones [李琼斯]
next prev parent reply other threads:[~2025-09-03 6:58 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20250902-leds-v1-0-4a31e125276b@vinarskis.com>
2025-09-02 11:10 ` [PATCH 1/2] dt-bindings: leds: add generic LED consumer documentation Aleksandrs Vinarskis
2025-09-02 17:57 ` Rob Herring (Arm)
2025-09-02 18:21 ` Rob Herring
2025-09-03 23:56 ` Aleksandrs Vinarskis
2025-09-04 6:41 ` Krzysztof Kozlowski
2025-09-04 7:26 ` Hans de Goede
2025-09-04 9:45 ` Krzysztof Kozlowski
2025-09-04 10:29 ` Hans de Goede
2025-09-04 10:47 ` Krzysztof Kozlowski
2025-09-04 11:47 ` Hans de Goede
2025-09-04 12:05 ` Hans de Goede
2025-09-04 14:10 ` Rob Herring
2025-09-04 22:52 ` Aleksandrs Vinarskis
2025-09-02 11:10 ` [PATCH 2/2] leds: led-class: Add devicetree support to led_get() Aleksandrs Vinarskis
2025-09-02 12:25 ` Hans de Goede
2025-09-03 23:01 ` Aleksandrs Vinarskis
2025-09-04 7:08 ` Hans de Goede
2025-09-02 22:22 ` Linus Walleij
2025-09-03 6:58 ` Lee Jones [this message]
2025-09-03 3:31 ` kernel test robot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250903065841.GX2163762@google.com \
--to=lee@kernel.org \
--cc=alex@vinarskis.com \
--cc=andy.shevchenko@gmail.com \
--cc=bryan.odonoghue@linaro.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=hansg@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=linus.walleij@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-leds@vger.kernel.org \
--cc=pavel@kernel.org \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®