From: Oleg Nesterov <oleg@redhat.com>
To: Jiri Olsa <jolsa@kernel.org>
Cc: Masami Hiramatsu <mhiramat@kernel.org>,
Peter Zijlstra <peterz@infradead.org>,
Andrii Nakryiko <andrii@kernel.org>,
bpf@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-trace-kernel@vger.kernel.org, x86@kernel.org,
Song Liu <songliubraving@fb.com>, Yonghong Song <yhs@fb.com>,
John Fastabend <john.fastabend@gmail.com>,
Hao Luo <haoluo@google.com>, Steven Rostedt <rostedt@goodmis.org>,
Ingo Molnar <mingo@kernel.org>
Subject: Re: [PATCH perf/core 01/11] uprobes: Add unique flag to uprobe consumer
Date: Wed, 3 Sep 2025 12:49:33 +0200 [thread overview]
Message-ID: <20250903104933.GB18799@redhat.com> (raw)
In-Reply-To: <20250902143504.1224726-2-jolsa@kernel.org>
On 09/02, Jiri Olsa wrote:
>
> +static bool consumer_can_add(struct list_head *head, struct uprobe_consumer *uc)
> +{
> + /* Uprobe has no consumer, we can add any. */
> + if (list_empty(head))
> + return true;
> + /* Uprobe has consumer/s, we can't add unique one. */
> + if (uc->is_unique)
> + return false;
> + /*
> + * Uprobe has consumer/s, we can add nother consumer only if the
> + * current consumer is not unique.
> + **/
> + return !list_first_entry(head, struct uprobe_consumer, cons_node)->is_unique;
> +}
Since you are going to send V2 anyway... purely cosmetic and subjective nit,
but somehow I can't resist,
bool consumer_can_add(struct list_head *head, struct uprobe_consumer *new)
{
struct uprobe_consumer *old = list_first_entry_or_null(...);
return !old || (!old->exclusive && !new->exclusive);
}
looks a bit more readable to me. Please ignore if you like your version more.
Oleg.
next prev parent reply other threads:[~2025-09-03 10:51 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-02 14:34 [PATCH perf/core 00/11] uprobes: Add unique uprobe Jiri Olsa
2025-09-02 14:34 ` [PATCH perf/core 01/11] uprobes: Add unique flag to uprobe consumer Jiri Olsa
2025-09-02 15:11 ` Masami Hiramatsu
2025-09-03 6:35 ` Jiri Olsa
2025-09-03 10:49 ` Oleg Nesterov [this message]
2025-09-03 12:02 ` Jiri Olsa
2025-09-02 14:34 ` [PATCH perf/core 02/11] uprobes: Skip emulate/sstep on unique uprobe when ip is changed Jiri Olsa
2025-09-03 11:26 ` Oleg Nesterov
2025-09-03 18:20 ` Andrii Nakryiko
2025-09-03 19:57 ` Jiri Olsa
2025-09-03 19:50 ` Jiri Olsa
2025-09-04 8:49 ` Oleg Nesterov
2025-09-04 10:46 ` Jiri Olsa
2025-09-04 11:23 ` Oleg Nesterov
2025-09-04 15:01 ` Alexei Starovoitov
2025-09-04 18:06 ` Andrii Nakryiko
2025-09-04 18:55 ` Oleg Nesterov
2025-09-04 19:42 ` Andrii Nakryiko
2025-09-05 8:51 ` Oleg Nesterov
2025-09-02 14:34 ` [PATCH perf/core 03/11] perf: Add support to attach standard unique uprobe Jiri Olsa
2025-09-02 16:13 ` Alexei Starovoitov
2025-09-03 3:32 ` kernel test robot
2025-09-03 11:59 ` Oleg Nesterov
2025-09-03 13:03 ` Jiri Olsa
2025-09-03 13:22 ` Oleg Nesterov
2025-09-02 14:34 ` [PATCH perf/core 04/11] bpf: Add support to attach uprobe_multi " Jiri Olsa
2025-09-02 16:11 ` Alexei Starovoitov
2025-09-03 6:35 ` Jiri Olsa
2025-09-03 15:32 ` Alexei Starovoitov
2025-09-03 19:55 ` Jiri Olsa
2025-09-02 14:34 ` [PATCH perf/core 05/11] bpf: Allow uprobe program to change context registers Jiri Olsa
2025-09-02 14:34 ` [PATCH perf/core 06/11] libbpf: Add support to attach unique uprobe_multi uprobe Jiri Olsa
2025-09-02 14:35 ` [PATCH perf/core 07/11] libbpf: Add support to attach generic unique uprobe Jiri Olsa
2025-09-03 18:26 ` Andrii Nakryiko
2025-09-02 14:35 ` [PATCH perf/core 08/11] selftests/bpf: Add uprobe multi context registers changes test Jiri Olsa
2025-09-02 14:35 ` [PATCH perf/core 09/11] selftests/bpf: Add uprobe multi context ip register change test Jiri Olsa
2025-09-02 14:35 ` [PATCH perf/core 10/11] selftests/bpf: Add uprobe multi unique attach test Jiri Olsa
2025-09-02 14:35 ` [PATCH perf/core 11/11] selftests/bpf: Add uprobe " Jiri Olsa
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250903104933.GB18799@redhat.com \
--to=oleg@redhat.com \
--cc=andrii@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=haoluo@google.com \
--cc=john.fastabend@gmail.com \
--cc=jolsa@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-trace-kernel@vger.kernel.org \
--cc=mhiramat@kernel.org \
--cc=mingo@kernel.org \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
--cc=songliubraving@fb.com \
--cc=x86@kernel.org \
--cc=yhs@fb.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®