* [PATCH 0/3] block: replace wq users and add WQ_PERCPU to alloc_workqueue() users
@ 2025-09-05 8:51 Marco Crivellari
2025-09-05 8:51 ` [PATCH 1/3] drivers/block: replace use of system_wq with system_percpu_wq Marco Crivellari
` (3 more replies)
0 siblings, 4 replies; 6+ messages in thread
From: Marco Crivellari @ 2025-09-05 8:51 UTC (permalink / raw)
To: linux-kernel, linux-block
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
Jens Axboe
Hi!
Below is a summary of a discussion about the Workqueue API and cpu isolation
considerations. Details and more information are available here:
"workqueue: Always use wq_select_unbound_cpu() for WORK_CPU_UNBOUND."
https://lore.kernel.org/all/20250221112003.1dSuoGyc@linutronix.de/
=== Current situation: problems ===
Let's consider a nohz_full system with isolated CPUs: wq_unbound_cpumask is
set to the housekeeping CPUs, for !WQ_UNBOUND the local CPU is selected.
This leads to different scenarios if a work item is scheduled on an isolated
CPU where "delay" value is 0 or greater then 0:
schedule_delayed_work(, 0);
This will be handled by __queue_work() that will queue the work item on the
current local (isolated) CPU, while:
schedule_delayed_work(, 1);
Will move the timer on an housekeeping CPU, and schedule the work there.
Currently if a user enqueue a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.
This lack of consistentcy cannot be addressed without refactoring the API.
=== Plan and future plans ===
This patchset is the first stone on a refactoring needed in order to
address the points aforementioned; it will have a positive impact also
on the cpu isolation, in the long term, moving away percpu workqueue in
favor to an unbound model.
These are the main steps:
1) API refactoring (that this patch is introducing)
- Make more clear and uniform the system wq names, both per-cpu and
unbound. This to avoid any possible confusion on what should be
used.
- Introduction of WQ_PERCPU: this flag is the complement of WQ_UNBOUND,
introduced in this patchset and used on all the callers that are not
currently using WQ_UNBOUND.
WQ_UNBOUND will be removed in a future release cycle.
Most users don't need to be per-cpu, because they don't have
locality requirements, because of that, a next future step will be
make "unbound" the default behavior.
2) Check who really needs to be per-cpu
- Remove the WQ_PERCPU flag when is not strictly required.
3) Add a new API (prefer local cpu)
- There are users that don't require a local execution, like mentioned
above; despite that, local execution yeld to performance gain.
This new API will prefer the local execution, without requiring it.
=== Introduced Changes by this series ===
1) [P 1-2] Replace use of system_wq and system_unbound_wq
system_wq is a per-CPU workqueue, but his name is not clear.
system_unbound_wq is to be used when locality is not required.
Because of that, system_wq has been renamed in system_percpu_wq, and
system_unbound_wq has been renamed in system_dfl_wq.
2) [P 3] add WQ_PERCPU to remaining alloc_workqueue() users
Every alloc_workqueue() caller should use one among WQ_PERCPU or
WQ_UNBOUND. This is actually enforced warning if both or none of them
are present at the same time.
WQ_UNBOUND will be removed in a next release cycle.
=== For Maintainers ===
There are prerequisites for this series, already merged in the master branch.
The commits are:
128ea9f6ccfb6960293ae4212f4f97165e42222d ("workqueue: Add system_percpu_wq and
system_dfl_wq")
930c2ea566aff59e962c50b2421d5fcc3b98b8be ("workqueue: Add new WQ_PERCPU flag")
Thanks!
Marco Crivellari (3):
drivers/block: replace use of system_wq with system_percpu_wq
drivers/block: replace use of system_unbound_wq with system_dfl_wq
drivers/block: WQ_PERCPU added to alloc_workqueue users
drivers/block/aoe/aoemain.c | 2 +-
drivers/block/nbd.c | 2 +-
drivers/block/rbd.c | 2 +-
drivers/block/rnbd/rnbd-clt.c | 2 +-
drivers/block/sunvdc.c | 4 ++--
drivers/block/virtio_blk.c | 2 +-
drivers/block/zram/zram_drv.c | 2 +-
7 files changed, 8 insertions(+), 8 deletions(-)
--
2.51.0
^ permalink raw reply [flat|nested] 6+ messages in thread
* [PATCH 1/3] drivers/block: replace use of system_wq with system_percpu_wq
2025-09-05 8:51 [PATCH 0/3] block: replace wq users and add WQ_PERCPU to alloc_workqueue() users Marco Crivellari
@ 2025-09-05 8:51 ` Marco Crivellari
2025-09-05 8:51 ` [PATCH 2/3] drivers/block: replace use of system_unbound_wq with system_dfl_wq Marco Crivellari
` (2 subsequent siblings)
3 siblings, 0 replies; 6+ messages in thread
From: Marco Crivellari @ 2025-09-05 8:51 UTC (permalink / raw)
To: linux-kernel, linux-block
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
Jens Axboe
Currently if a user enqueue a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.
This lack of consistentcy cannot be addressed without refactoring the API.
system_unbound_wq should be the default workqueue so as not to enforce
locality constraints for random work whenever it's not required.
Adding system_dfl_wq to encourage its use when unbound work should be used.
queue_work() / queue_delayed_work() / mod_delayed_work() will now use the
new unbound wq: whether the user still use the old wq a warn will be
printed along with a wq redirect to the new one.
The old system_unbound_wq will be kept for a few release cycles.
Suggested-by: Tejun Heo <tj@kernel.org>
Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
---
drivers/block/nbd.c | 2 +-
drivers/block/sunvdc.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/block/nbd.c b/drivers/block/nbd.c
index 7bdc7eb808ea..7738fce177fa 100644
--- a/drivers/block/nbd.c
+++ b/drivers/block/nbd.c
@@ -311,7 +311,7 @@ static void nbd_mark_nsock_dead(struct nbd_device *nbd, struct nbd_sock *nsock,
if (args) {
INIT_WORK(&args->work, nbd_dead_link_work);
args->index = nbd->index;
- queue_work(system_wq, &args->work);
+ queue_work(system_percpu_wq, &args->work);
}
}
if (!nsock->dead) {
diff --git a/drivers/block/sunvdc.c b/drivers/block/sunvdc.c
index b5727dea15bd..442546b05df8 100644
--- a/drivers/block/sunvdc.c
+++ b/drivers/block/sunvdc.c
@@ -1187,7 +1187,7 @@ static void vdc_ldc_reset(struct vdc_port *port)
}
if (port->ldc_timeout)
- mod_delayed_work(system_wq, &port->ldc_reset_timer_work,
+ mod_delayed_work(system_percpu_wq, &port->ldc_reset_timer_work,
round_jiffies(jiffies + HZ * port->ldc_timeout));
mod_timer(&port->vio.timer, round_jiffies(jiffies + HZ));
return;
--
2.51.0
^ permalink raw reply [flat|nested] 6+ messages in thread
* [PATCH 2/3] drivers/block: replace use of system_unbound_wq with system_dfl_wq
2025-09-05 8:51 [PATCH 0/3] block: replace wq users and add WQ_PERCPU to alloc_workqueue() users Marco Crivellari
2025-09-05 8:51 ` [PATCH 1/3] drivers/block: replace use of system_wq with system_percpu_wq Marco Crivellari
@ 2025-09-05 8:51 ` Marco Crivellari
2025-09-05 8:51 ` [PATCH 3/3] drivers/block: WQ_PERCPU added to alloc_workqueue users Marco Crivellari
2025-09-09 15:12 ` [PATCH 0/3] block: replace wq users and add WQ_PERCPU to alloc_workqueue() users Jens Axboe
3 siblings, 0 replies; 6+ messages in thread
From: Marco Crivellari @ 2025-09-05 8:51 UTC (permalink / raw)
To: linux-kernel, linux-block
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
Jens Axboe
Currently if a user enqueue a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.
This lack of consistentcy cannot be addressed without refactoring the API.
system_unbound_wq should be the default workqueue so as not to enforce
locality constraints for random work whenever it's not required.
Adding system_dfl_wq to encourage its use when unbound work should be used.
queue_work() / queue_delayed_work() / mod_delayed_work() will now use the
new unbound wq: whether the user still use the old wq a warn will be
printed along with a wq redirect to the new one.
The old system_unbound_wq will be kept for a few release cycles.
Suggested-by: Tejun Heo <tj@kernel.org>
Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
---
drivers/block/zram/zram_drv.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/block/zram/zram_drv.c b/drivers/block/zram/zram_drv.c
index fda7d8624889..c7e0fa29a572 100644
--- a/drivers/block/zram/zram_drv.c
+++ b/drivers/block/zram/zram_drv.c
@@ -975,7 +975,7 @@ static int read_from_bdev_sync(struct zram *zram, struct page *page,
work.entry = entry;
INIT_WORK_ONSTACK(&work.work, zram_sync_read);
- queue_work(system_unbound_wq, &work.work);
+ queue_work(system_dfl_wq, &work.work);
flush_work(&work.work);
destroy_work_on_stack(&work.work);
--
2.51.0
^ permalink raw reply [flat|nested] 6+ messages in thread
* [PATCH 3/3] drivers/block: WQ_PERCPU added to alloc_workqueue users
2025-09-05 8:51 [PATCH 0/3] block: replace wq users and add WQ_PERCPU to alloc_workqueue() users Marco Crivellari
2025-09-05 8:51 ` [PATCH 1/3] drivers/block: replace use of system_wq with system_percpu_wq Marco Crivellari
2025-09-05 8:51 ` [PATCH 2/3] drivers/block: replace use of system_unbound_wq with system_dfl_wq Marco Crivellari
@ 2025-09-05 8:51 ` Marco Crivellari
2025-09-09 15:12 ` [PATCH 0/3] block: replace wq users and add WQ_PERCPU to alloc_workqueue() users Jens Axboe
3 siblings, 0 replies; 6+ messages in thread
From: Marco Crivellari @ 2025-09-05 8:51 UTC (permalink / raw)
To: linux-kernel, linux-block
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
Jens Axboe
Currently if a user enqueue a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.
This lack of consistentcy cannot be addressed without refactoring the API.
alloc_workqueue() treats all queues as per-CPU by default, while unbound
workqueues must opt-in via WQ_UNBOUND.
This default is suboptimal: most workloads benefit from unbound queues,
allowing the scheduler to place worker threads where they’re needed and
reducing noise when CPUs are isolated.
This default is suboptimal: most workloads benefit from unbound queues,
allowing the scheduler to place worker threads where they’re needed and
reducing noise when CPUs are isolated.
This patch adds a new WQ_PERCPU flag to explicitly request the use of
the per-CPU behavior. Both flags coexist for one release cycle to allow
callers to transition their calls.
Once migration is complete, WQ_UNBOUND can be removed and unbound will
become the implicit default.
With the introduction of the WQ_PERCPU flag (equivalent to !WQ_UNBOUND),
any alloc_workqueue() caller that doesn’t explicitly specify WQ_UNBOUND
must now use WQ_PERCPU.
All existing users have been updated accordingly.
Suggested-by: Tejun Heo <tj@kernel.org>
Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
---
drivers/block/aoe/aoemain.c | 2 +-
drivers/block/rbd.c | 2 +-
drivers/block/rnbd/rnbd-clt.c | 2 +-
drivers/block/sunvdc.c | 2 +-
drivers/block/virtio_blk.c | 2 +-
5 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/block/aoe/aoemain.c b/drivers/block/aoe/aoemain.c
index cdf6e4041bb9..3b21750038ee 100644
--- a/drivers/block/aoe/aoemain.c
+++ b/drivers/block/aoe/aoemain.c
@@ -44,7 +44,7 @@ aoe_init(void)
{
int ret;
- aoe_wq = alloc_workqueue("aoe_wq", 0, 0);
+ aoe_wq = alloc_workqueue("aoe_wq", WQ_PERCPU, 0);
if (!aoe_wq)
return -ENOMEM;
diff --git a/drivers/block/rbd.c b/drivers/block/rbd.c
index faafd7ff43d6..af0e21149dbc 100644
--- a/drivers/block/rbd.c
+++ b/drivers/block/rbd.c
@@ -7389,7 +7389,7 @@ static int __init rbd_init(void)
* The number of active work items is limited by the number of
* rbd devices * queue depth, so leave @max_active at default.
*/
- rbd_wq = alloc_workqueue(RBD_DRV_NAME, WQ_MEM_RECLAIM, 0);
+ rbd_wq = alloc_workqueue(RBD_DRV_NAME, WQ_MEM_RECLAIM | WQ_PERCPU, 0);
if (!rbd_wq) {
rc = -ENOMEM;
goto err_out_slab;
diff --git a/drivers/block/rnbd/rnbd-clt.c b/drivers/block/rnbd/rnbd-clt.c
index 15627417f12e..b3a0470f9e80 100644
--- a/drivers/block/rnbd/rnbd-clt.c
+++ b/drivers/block/rnbd/rnbd-clt.c
@@ -1809,7 +1809,7 @@ static int __init rnbd_client_init(void)
unregister_blkdev(rnbd_client_major, "rnbd");
return err;
}
- rnbd_clt_wq = alloc_workqueue("rnbd_clt_wq", 0, 0);
+ rnbd_clt_wq = alloc_workqueue("rnbd_clt_wq", WQ_PERCPU, 0);
if (!rnbd_clt_wq) {
pr_err("Failed to load module, alloc_workqueue failed.\n");
rnbd_clt_destroy_sysfs_files();
diff --git a/drivers/block/sunvdc.c b/drivers/block/sunvdc.c
index 442546b05df8..851763e5dd18 100644
--- a/drivers/block/sunvdc.c
+++ b/drivers/block/sunvdc.c
@@ -1215,7 +1215,7 @@ static int __init vdc_init(void)
{
int err;
- sunvdc_wq = alloc_workqueue("sunvdc", 0, 0);
+ sunvdc_wq = alloc_workqueue("sunvdc", WQ_PERCPU, 0);
if (!sunvdc_wq)
return -ENOMEM;
diff --git a/drivers/block/virtio_blk.c b/drivers/block/virtio_blk.c
index 7cffea01d868..a5a48f976a20 100644
--- a/drivers/block/virtio_blk.c
+++ b/drivers/block/virtio_blk.c
@@ -1683,7 +1683,7 @@ static int __init virtio_blk_init(void)
{
int error;
- virtblk_wq = alloc_workqueue("virtio-blk", 0, 0);
+ virtblk_wq = alloc_workqueue("virtio-blk", WQ_PERCPU, 0);
if (!virtblk_wq)
return -ENOMEM;
--
2.51.0
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 0/3] block: replace wq users and add WQ_PERCPU to alloc_workqueue() users
2025-09-05 8:51 [PATCH 0/3] block: replace wq users and add WQ_PERCPU to alloc_workqueue() users Marco Crivellari
` (2 preceding siblings ...)
2025-09-05 8:51 ` [PATCH 3/3] drivers/block: WQ_PERCPU added to alloc_workqueue users Marco Crivellari
@ 2025-09-09 15:12 ` Jens Axboe
2025-09-18 8:59 ` Marco Crivellari
3 siblings, 1 reply; 6+ messages in thread
From: Jens Axboe @ 2025-09-09 15:12 UTC (permalink / raw)
To: linux-kernel, linux-block, Marco Crivellari
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Michal Hocko
On Fri, 05 Sep 2025 10:51:38 +0200, Marco Crivellari wrote:
> Below is a summary of a discussion about the Workqueue API and cpu isolation
> considerations. Details and more information are available here:
>
> "workqueue: Always use wq_select_unbound_cpu() for WORK_CPU_UNBOUND."
> https://lore.kernel.org/all/20250221112003.1dSuoGyc@linutronix.de/
>
> === Current situation: problems ===
>
> [...]
Applied, thanks!
[1/3] drivers/block: replace use of system_wq with system_percpu_wq
commit: 51723bf92679427bba09a76fc13e1b0a93b680bc
[2/3] drivers/block: replace use of system_unbound_wq with system_dfl_wq
commit: 456cefcb312d90d12dbcf7eaf6b3f7cfae6f622b
[3/3] drivers/block: WQ_PERCPU added to alloc_workqueue users
commit: d7b1cdc9108f46f47a0899597d6fa270f64dd98c
Best regards,
--
Jens Axboe
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 0/3] block: replace wq users and add WQ_PERCPU to alloc_workqueue() users
2025-09-09 15:12 ` [PATCH 0/3] block: replace wq users and add WQ_PERCPU to alloc_workqueue() users Jens Axboe
@ 2025-09-18 8:59 ` Marco Crivellari
0 siblings, 0 replies; 6+ messages in thread
From: Marco Crivellari @ 2025-09-18 8:59 UTC (permalink / raw)
To: Jens Axboe
Cc: linux-kernel, linux-block, Tejun Heo, Lai Jiangshan,
Frederic Weisbecker, Sebastian Andrzej Siewior, Michal Hocko
On Tue, Sep 9, 2025 at 5:12 PM Jens Axboe <axboe@kernel.dk> wrote:
> Applied, thanks!
>
> [1/3] drivers/block: replace use of system_wq with system_percpu_wq
> commit: 51723bf92679427bba09a76fc13e1b0a93b680bc
> [2/3] drivers/block: replace use of system_unbound_wq with system_dfl_wq
> commit: 456cefcb312d90d12dbcf7eaf6b3f7cfae6f622b
> [3/3] drivers/block: WQ_PERCPU added to alloc_workqueue users
> commit: d7b1cdc9108f46f47a0899597d6fa270f64dd98c
Many thanks, Jens!
--
Marco Crivellari
L3 Support Engineer, Technology & Product
^ permalink raw reply [flat|nested] 6+ messages in thread
end of thread, other threads:[~2025-09-18 8:59 UTC | newest]
Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-09-05 8:51 [PATCH 0/3] block: replace wq users and add WQ_PERCPU to alloc_workqueue() users Marco Crivellari
2025-09-05 8:51 ` [PATCH 1/3] drivers/block: replace use of system_wq with system_percpu_wq Marco Crivellari
2025-09-05 8:51 ` [PATCH 2/3] drivers/block: replace use of system_unbound_wq with system_dfl_wq Marco Crivellari
2025-09-05 8:51 ` [PATCH 3/3] drivers/block: WQ_PERCPU added to alloc_workqueue users Marco Crivellari
2025-09-09 15:12 ` [PATCH 0/3] block: replace wq users and add WQ_PERCPU to alloc_workqueue() users Jens Axboe
2025-09-18 8:59 ` Marco Crivellari
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®