mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/1] closures: replace wq users and add WQ_PERCPU to alloc_workqueue() users
@ 2025-09-05  8:56 Marco Crivellari
  2025-09-05  8:56 ` [PATCH 1/1] closure: replace use of system_wq with system_percpu_wq Marco Crivellari
  0 siblings, 1 reply; 4+ messages in thread
From: Marco Crivellari @ 2025-09-05  8:56 UTC (permalink / raw)
  To: linux-kernel, linux-bcachefs
  Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
	Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
	Kent Overstreet

Hi!

Below is a summary of a discussion about the Workqueue API and cpu isolation
considerations. Details and more information are available here:

        "workqueue: Always use wq_select_unbound_cpu() for WORK_CPU_UNBOUND."
        https://lore.kernel.org/all/20250221112003.1dSuoGyc@linutronix.de/

=== Current situation: problems ===

Let's consider a nohz_full system with isolated CPUs: wq_unbound_cpumask is
set to the housekeeping CPUs, for !WQ_UNBOUND the local CPU is selected.

This leads to different scenarios if a work item is scheduled on an isolated
CPU where "delay" value is 0 or greater then 0:
        schedule_delayed_work(, 0);

This will be handled by __queue_work() that will queue the work item on the
current local (isolated) CPU, while:

        schedule_delayed_work(, 1);

Will move the timer on an housekeeping CPU, and schedule the work there.

Currently if a user enqueue a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.

This lack of consistentcy cannot be addressed without refactoring the API.

=== Plan and future plans ===

This patchset is the first stone on a refactoring needed in order to
address the points aforementioned; it will have a positive impact also
on the cpu isolation, in the long term, moving away percpu workqueue in
favor to an unbound model.

These are the main steps:
1)  API refactoring (that this patch is introducing)
    -   Make more clear and uniform the system wq names, both per-cpu and
        unbound. This to avoid any possible confusion on what should be
        used.

    -   Introduction of WQ_PERCPU: this flag is the complement of WQ_UNBOUND,
        introduced in this patchset and used on all the callers that are not
        currently using WQ_UNBOUND.

        WQ_UNBOUND will be removed in a future release cycle.

        Most users don't need to be per-cpu, because they don't have
        locality requirements, because of that, a next future step will be
        make "unbound" the default behavior.

2)  Check who really needs to be per-cpu
    -   Remove the WQ_PERCPU flag when is not strictly required.

3)  Add a new API (prefer local cpu)
    -   There are users that don't require a local execution, like mentioned
        above; despite that, local execution yeld to performance gain.

        This new API will prefer the local execution, without requiring it.

=== Introduced Changes by this series ===

1) [P 1] Replace use of system_wq

        system_wq is a per-CPU workqueue, but his name is not clear.

        Because of that, system_wq has been renamed in system_percpu_wq.


=== For Maintainers ===

There are prerequisites for this series, already merged in the master branch.
The commits are:

128ea9f6ccfb6960293ae4212f4f97165e42222d ("workqueue: Add system_percpu_wq and
system_dfl_wq")

930c2ea566aff59e962c50b2421d5fcc3b98b8be ("workqueue: Add new WQ_PERCPU flag")


Thanks!

Marco Crivellari (1):
  closure: replace use of system_wq with system_percpu_wq

 include/linux/closure.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

-- 
2.51.0


^ permalink raw reply	[flat|nested] 4+ messages in thread

* [PATCH 1/1] closure: replace use of system_wq with system_percpu_wq
  2025-09-05  8:56 [PATCH 0/1] closures: replace wq users and add WQ_PERCPU to alloc_workqueue() users Marco Crivellari
@ 2025-09-05  8:56 ` Marco Crivellari
  2025-09-06 18:53   ` Kent Overstreet
  0 siblings, 1 reply; 4+ messages in thread
From: Marco Crivellari @ 2025-09-05  8:56 UTC (permalink / raw)
  To: linux-kernel, linux-bcachefs
  Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
	Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
	Kent Overstreet

Currently if a user enqueue a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.

This lack of consistentcy cannot be addressed without refactoring the API.

system_wq is a per-CPU worqueue, yet nothing in its name tells about that
CPU affinity constraint, which is very often not required by users. Make
it clear by adding a system_percpu_wq.

queue_work() / queue_delayed_work() mod_delayed_work() will now use the
new per-cpu wq: whether the user still stick on the old name a warn will
be printed along a wq redirect to the new one.

This patch add the new system_percpu_wq except for mm, fs and net
subsystem, whom are handled in separated patches.

The old wq will be kept for a few release cylces.

Suggested-by: Tejun Heo <tj@kernel.org>
Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
---
 include/linux/closure.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/linux/closure.h b/include/linux/closure.h
index 880fe85e35e9..959b3c584254 100644
--- a/include/linux/closure.h
+++ b/include/linux/closure.h
@@ -58,7 +58,7 @@
  * bio2->bi_endio = foo_endio;
  * bio_submit(bio2);
  *
- * continue_at(cl, complete_some_read, system_wq);
+ * continue_at(cl, complete_some_read, system_percpu_wq);
  *
  * If closure's refcount started at 0, complete_some_read() could run before the
  * second bio was submitted - which is almost always not what you want! More
-- 
2.51.0


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/1] closure: replace use of system_wq with system_percpu_wq
  2025-09-05  8:56 ` [PATCH 1/1] closure: replace use of system_wq with system_percpu_wq Marco Crivellari
@ 2025-09-06 18:53   ` Kent Overstreet
  2025-09-09 10:11     ` Marco Crivellari
  0 siblings, 1 reply; 4+ messages in thread
From: Kent Overstreet @ 2025-09-06 18:53 UTC (permalink / raw)
  To: Marco Crivellari
  Cc: linux-kernel, linux-bcachefs, Tejun Heo, Lai Jiangshan,
	Frederic Weisbecker, Sebastian Andrzej Siewior, Michal Hocko

On Fri, Sep 05, 2025 at 10:56:25AM +0200, Marco Crivellari wrote:
> Currently if a user enqueue a work item using schedule_delayed_work() the
> used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
> WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
> schedule_work() that is using system_wq and queue_work(), that makes use
> again of WORK_CPU_UNBOUND.
> 
> This lack of consistentcy cannot be addressed without refactoring the API.
> 
> system_wq is a per-CPU worqueue, yet nothing in its name tells about that
> CPU affinity constraint, which is very often not required by users. Make
> it clear by adding a system_percpu_wq.
> 
> queue_work() / queue_delayed_work() mod_delayed_work() will now use the
> new per-cpu wq: whether the user still stick on the old name a warn will
> be printed along a wq redirect to the new one.
> 
> This patch add the new system_percpu_wq except for mm, fs and net
> subsystem, whom are handled in separated patches.
> 
> The old wq will be kept for a few release cylces.
> 
> Suggested-by: Tejun Heo <tj@kernel.org>
> Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
> ---
>  include/linux/closure.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/include/linux/closure.h b/include/linux/closure.h
> index 880fe85e35e9..959b3c584254 100644
> --- a/include/linux/closure.h
> +++ b/include/linux/closure.h
> @@ -58,7 +58,7 @@
>   * bio2->bi_endio = foo_endio;
>   * bio_submit(bio2);
>   *
> - * continue_at(cl, complete_some_read, system_wq);
> + * continue_at(cl, complete_some_read, system_percpu_wq);
>   *
>   * If closure's refcount started at 0, complete_some_read() could run before the
>   * second bio was submitted - which is almost always not what you want! More
> -- 
> 2.51.0
> 

I was confused until I realized you're updating a comment.

Acked-by: Kent Overstreet <kent.overstreet@linux.dev>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH 1/1] closure: replace use of system_wq with system_percpu_wq
  2025-09-06 18:53   ` Kent Overstreet
@ 2025-09-09 10:11     ` Marco Crivellari
  0 siblings, 0 replies; 4+ messages in thread
From: Marco Crivellari @ 2025-09-09 10:11 UTC (permalink / raw)
  To: Kent Overstreet
  Cc: linux-kernel, linux-bcachefs, Tejun Heo, Lai Jiangshan,
	Frederic Weisbecker, Sebastian Andrzej Siewior, Michal Hocko

On Sat, Sep 6, 2025 at 8:54 PM Kent Overstreet
<kent.overstreet@linux.dev> wrote:
> I was confused until I realized you're updating a comment.
>
> Acked-by: Kent Overstreet <kent.overstreet@linux.dev>

Hello Kent,

Yes, sorry for the confusion.

Thanks!

--

Marco Crivellari

L3 Support Engineer, Technology & Product

marco.crivellari@suse.com

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2025-09-09 10:12 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-09-05  8:56 [PATCH 0/1] closures: replace wq users and add WQ_PERCPU to alloc_workqueue() users Marco Crivellari
2025-09-05  8:56 ` [PATCH 1/1] closure: replace use of system_wq with system_percpu_wq Marco Crivellari
2025-09-06 18:53   ` Kent Overstreet
2025-09-09 10:11     ` Marco Crivellari

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®