From: Steven Rostedt <rostedt@goodmis.org>
To: Menglong Dong <menglong8.dong@gmail.com>
Cc: mhiramat@kernel.org, mathieu.desnoyers@efficios.com,
linux-kernel@vger.kernel.org, linux-trace-kernel@vger.kernel.org,
bpf@vger.kernel.org
Subject: Re: [PATCH 1/2] tracing: fprobe: rename fprobe_entry to fprobe_fgraph_entry
Date: Tue, 23 Sep 2025 05:38:03 -0400 [thread overview]
Message-ID: <20250923053803.0adee9a0@batman.local.home> (raw)
In-Reply-To: <20250923092001.1087678-1-dongml2@chinatelecom.cn>
On Tue, 23 Sep 2025 17:20:00 +0800
Menglong Dong <menglong8.dong@gmail.com> wrote:
> The fprobe_entry() is used by fgraph_ops, so rename it to
> fprobe_fgraph_entry to be more distinctive.
The change log should be more specific and state that this will allow
to have fprobes to use ftrace too. I didn't know why you did this until
I saw the second patch. As change logs should be self contain, it
should have enough information to not rely on knowing other commits to
understand why the patch is made.
-- Steve
next prev parent reply other threads:[~2025-09-23 9:38 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-23 9:20 Menglong Dong
2025-09-23 9:20 ` [PATCH 2/2] tracing: fprobe: optimization for entry only case Menglong Dong
2025-09-23 11:10 ` Jiri Olsa
2025-09-23 11:16 ` menglong.dong
2025-09-23 12:25 ` Jiri Olsa
2025-09-23 13:34 ` Menglong Dong
2025-09-23 16:25 ` Jiri Olsa
2025-09-24 0:23 ` Masami Hiramatsu
2025-09-24 1:33 ` menglong.dong
2025-09-23 9:38 ` Steven Rostedt [this message]
2025-09-23 10:27 ` [PATCH 1/2] tracing: fprobe: rename fprobe_entry to fprobe_fgraph_entry menglong.dong
2025-09-23 23:07 ` Masami Hiramatsu
2025-09-24 0:17 ` Menglong Dong
2025-09-24 8:13 ` Masami Hiramatsu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250923053803.0adee9a0@batman.local.home \
--to=rostedt@goodmis.org \
--cc=bpf@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-trace-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=menglong8.dong@gmail.com \
--cc=mhiramat@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®