From: Masami Hiramatsu (Google) <mhiramat@kernel.org>
To: Menglong Dong <menglong.dong@linux.dev>
Cc: Menglong Dong <menglong8.dong@gmail.com>,
rostedt@goodmis.org, mathieu.desnoyers@efficios.com,
linux-kernel@vger.kernel.org, linux-trace-kernel@vger.kernel.org,
bpf@vger.kernel.org
Subject: Re: [PATCH 1/2] tracing: fprobe: rename fprobe_entry to fprobe_fgraph_entry
Date: Wed, 24 Sep 2025 17:13:12 +0900 [thread overview]
Message-ID: <20250924171312.5790795400c78d87d5309333@kernel.org> (raw)
In-Reply-To: <5056228.31r3eYUQgx@7950hx>
On Wed, 24 Sep 2025 08:17:45 +0800
Menglong Dong <menglong.dong@linux.dev> wrote:
> On 2025/9/24 07:07, Masami Hiramatsu wrote:
> > On Tue, 23 Sep 2025 17:20:00 +0800
> > Menglong Dong <menglong8.dong@gmail.com> wrote:
> >
> > > The fprobe_entry() is used by fgraph_ops, so rename it to
> > > fprobe_fgraph_entry to be more distinctive.
> >
> > Sorry, NAK. fprobe is based on fgraph by design.
> > So "fprobe_fgraph" sounds redundant.
>
> Hi, Masami. Did you see my next patch that use ftrace
> for the fprobe to obtain better performance?
>
> Hmm, it seems that the cover-letter is necessary :/
Yeah, I missed [2/2]. And anyway I think this should be
merged to [2/2].
Thank you,
>
> Thanks!
> Menglong Dong
>
> >
> > Thanks,
> >
> > >
> > > Signed-off-by: Menglong Dong <dongml2@chinatelecom.cn>
> > > ---
> > > kernel/trace/fprobe.c | 8 ++++----
> > > 1 file changed, 4 insertions(+), 4 deletions(-)
> > >
> > > diff --git a/kernel/trace/fprobe.c b/kernel/trace/fprobe.c
> > > index 6a205903b1ed..1785fba367c9 100644
> > > --- a/kernel/trace/fprobe.c
> > > +++ b/kernel/trace/fprobe.c
> > > @@ -254,8 +254,8 @@ static inline int __fprobe_kprobe_handler(unsigned long ip, unsigned long parent
> > > return ret;
> > > }
> > >
> > > -static int fprobe_entry(struct ftrace_graph_ent *trace, struct fgraph_ops *gops,
> > > - struct ftrace_regs *fregs)
> > > +static int fprobe_fgraph_entry(struct ftrace_graph_ent *trace, struct fgraph_ops *gops,
> > > + struct ftrace_regs *fregs)
> > > {
> > > unsigned long *fgraph_data = NULL;
> > > unsigned long func = trace->func;
> > > @@ -340,7 +340,7 @@ static int fprobe_entry(struct ftrace_graph_ent *trace, struct fgraph_ops *gops,
> > > /* If any exit_handler is set, data must be used. */
> > > return used != 0;
> > > }
> > > -NOKPROBE_SYMBOL(fprobe_entry);
> > > +NOKPROBE_SYMBOL(fprobe_fgraph_entry);
> > >
> > > static void fprobe_return(struct ftrace_graph_ret *trace,
> > > struct fgraph_ops *gops,
> > > @@ -379,7 +379,7 @@ static void fprobe_return(struct ftrace_graph_ret *trace,
> > > NOKPROBE_SYMBOL(fprobe_return);
> > >
> > > static struct fgraph_ops fprobe_graph_ops = {
> > > - .entryfunc = fprobe_entry,
> > > + .entryfunc = fprobe_fgraph_entry,
> > > .retfunc = fprobe_return,
> > > };
> > > static int fprobe_graph_active;
> >
> >
> >
>
>
>
>
--
Masami Hiramatsu (Google) <mhiramat@kernel.org>
prev parent reply other threads:[~2025-09-24 8:13 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-09-23 9:20 Menglong Dong
2025-09-23 9:20 ` [PATCH 2/2] tracing: fprobe: optimization for entry only case Menglong Dong
2025-09-23 11:10 ` Jiri Olsa
2025-09-23 11:16 ` menglong.dong
2025-09-23 12:25 ` Jiri Olsa
2025-09-23 13:34 ` Menglong Dong
2025-09-23 16:25 ` Jiri Olsa
2025-09-24 0:23 ` Masami Hiramatsu
2025-09-24 1:33 ` menglong.dong
2025-09-23 9:38 ` [PATCH 1/2] tracing: fprobe: rename fprobe_entry to fprobe_fgraph_entry Steven Rostedt
2025-09-23 10:27 ` menglong.dong
2025-09-23 23:07 ` Masami Hiramatsu
2025-09-24 0:17 ` Menglong Dong
2025-09-24 8:13 ` Masami Hiramatsu [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250924171312.5790795400c78d87d5309333@kernel.org \
--to=mhiramat@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-trace-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=menglong.dong@linux.dev \
--cc=menglong8.dong@gmail.com \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®