mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* Semantic conflict around CONFIG_CFI_CLANG between Linus's tree and x86/core
@ 2025-10-03 22:10 Nathan Chancellor
  0 siblings, 0 replies; only message in thread
From: Nathan Chancellor @ 2025-10-03 22:10 UTC (permalink / raw)
  To: Ingo Molnar, x86; +Cc: Kees Cook, Linus Torvalds, linux-kernel

Hi Ingo and other x86 folks,

Just a heads up, there will be a semantic conflict (for somewhat obvious
reasons) between

  23ef9d439769 ("kcfi: Rename CONFIG_CFI_CLANG to CONFIG_CFI")

that went into Linus's tree via the hardening tree and

  038c7dc66e27 ("compiler_types.h: Move __nocfi out of compiler-specific header")

which is currently in x86/core. I noticed this while kexec'ing under a
CFI kernel, which needs __nocfi as a result of

  2114796ca041 ("x86/kexec: Mark machine_kexec() with __nocfi")

otherwise there is a nice big splat and the machine dies :)

Cheers,
Nathan

diff --git a/include/linux/compiler_types.h b/include/linux/compiler_types.h
index 41c16fb8eb40..59288a2c1ad2 100644
--- a/include/linux/compiler_types.h
+++ b/include/linux/compiler_types.h
@@ -455,7 +455,7 @@ struct ftrace_likely_data {
 # define __noscs
 #endif
 
-#if defined(CONFIG_CFI_CLANG)
+#if defined(CONFIG_CFI)
 # define __nocfi		__attribute__((__no_sanitize__("kcfi")))
 #else
 # define __nocfi

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2025-10-03 22:10 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-10-03 22:10 Semantic conflict around CONFIG_CFI_CLANG between Linus's tree and x86/core Nathan Chancellor

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®