From: Markus Probst <markus.probst@posteo.de>
To: Danilo Krummrich <dakr@kernel.org>,
Miguel Ojeda <ojeda@kernel.org>,
Alex Gaynor <alex.gaynor@gmail.com>, Lee Jones <lee@kernel.org>,
Pavel Machek <pavel@kernel.org>
Cc: Lorenzo Stoakes <lorenzo.stoakes@oracle.com>,
Vlastimil Babka <vbabka@suse.cz>,
"Liam R. Howlett" <Liam.Howlett@oracle.com>,
Uladzislau Rezki <urezki@gmail.com>,
Boqun Feng <boqun.feng@gmail.com>, Gary Guo <gary@garyguo.net>,
bjorn3_gh@protonmail.com, Benno Lossin <lossin@kernel.org>,
Andreas Hindborg <a.hindborg@kernel.org>,
Alice Ryhl <aliceryhl@google.com>,
Trevor Gross <tmgross@umich.edu>,
Markus Probst <markus.probst@posteo.de>,
rust-for-linux@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-leds@vger.kernel.org
Subject: [PATCH v4 0/2] rust: leds: add led classdev abstractions
Date: Sun, 12 Oct 2025 14:52:36 +0000 [thread overview]
Message-ID: <20251012145221.172116-1-markus.probst@posteo.de> (raw)
This patch series has previously been contained in
https://lore.kernel.org/rust-for-linux/20251008181027.662616-1-markus.probst@posteo.de/T/#t
which added a rust written led driver for a microcontroller via i2c.
As the reading and writing to the i2c client via the register!
macro has not been implemented yet [1], the patch series will only
contain the additional abstractions required.
[1] https://lore.kernel.org/rust-for-linux/DDDS2V0V2NVJ.16ZKXCKUA1HUV@kernel.org/
The following changes were made:
* add basic Pin<Vec<T, A>> abstractions, that allow to initialize PinInit items with
the guarantee that these will never be moved.
* add basic led classdev abstractions to register and unregister leds
Changes since v3:
* fixed kunit tests failing because of example in documentation
Changes since v2:
* return `Devres` on `led::Device` creation
* replace KBox<T> with T in struct definition
* increment and decrement reference-count of fwnode
* make a device parent mandatory for led classdev creation
* rename `led::Handler` to `led::LedOps`
* add optional `brightness_get` function to `led::LedOps`
* use `#[vtable]` instead of `const BLINK: bool`
* use `Opaque::cast_from` instead of casting a pointer
* improve documentation
* improve support for older rust versions
* use `&Device<Bound>` for parent
Changes since v1:
* fixed typos noticed by Onur Özkan
Markus Probst (2):
rust: add basic Pin<Vec<T, A>> abstractions
rust: leds: add basic led classdev abstractions
rust/kernel/alloc.rs | 1 +
rust/kernel/alloc/kvec.rs | 86 ++++++++++
rust/kernel/led.rs | 333 ++++++++++++++++++++++++++++++++++++++
rust/kernel/lib.rs | 1 +
rust/kernel/prelude.rs | 2 +-
5 files changed, 422 insertions(+), 1 deletion(-)
create mode 100644 rust/kernel/led.rs
--
2.49.1
next reply other threads:[~2025-10-12 14:52 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-10-12 14:52 Markus Probst [this message]
2025-10-12 14:52 ` [PATCH v4 1/2] rust: add basic Pin<Vec<T, A>> abstractions Markus Probst
2025-10-12 16:26 ` Benno Lossin
2025-10-12 16:57 ` Markus Probst
2025-10-12 21:31 ` Benno Lossin
2025-10-12 22:11 ` Markus Probst
2025-10-13 8:03 ` Benno Lossin
2025-10-13 9:22 ` Alice Ryhl
2025-10-13 9:39 ` Benno Lossin
2025-10-13 13:43 ` Markus Probst
2025-10-13 14:47 ` Benno Lossin
2025-10-14 14:15 ` Markus Probst
2025-10-12 14:52 ` [PATCH v4 2/2] rust: leds: add basic led classdev abstractions Markus Probst
2025-10-13 18:34 ` Alice Ryhl
2025-10-13 20:11 ` Danilo Krummrich
2025-10-14 14:46 ` Markus Probst
2025-10-15 13:44 ` Markus Probst
2025-10-15 14:52 ` Danilo Krummrich
2025-10-15 15:02 ` Markus Probst
2025-10-15 17:27 ` Danilo Krummrich
2025-10-12 16:27 ` [PATCH v4 0/2] rust: leds: add " Benno Lossin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20251012145221.172116-1-markus.probst@posteo.de \
--to=markus.probst@posteo.de \
--cc=Liam.Howlett@oracle.com \
--cc=a.hindborg@kernel.org \
--cc=alex.gaynor@gmail.com \
--cc=aliceryhl@google.com \
--cc=bjorn3_gh@protonmail.com \
--cc=boqun.feng@gmail.com \
--cc=dakr@kernel.org \
--cc=gary@garyguo.net \
--cc=lee@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-leds@vger.kernel.org \
--cc=lorenzo.stoakes@oracle.com \
--cc=lossin@kernel.org \
--cc=ojeda@kernel.org \
--cc=pavel@kernel.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=tmgross@umich.edu \
--cc=urezki@gmail.com \
--cc=vbabka@suse.cz \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®