* [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue
@ 2025-11-05 10:35 Marco Crivellari
2025-11-05 10:35 ` [PATCH 1/4] Input: gpio_keys - replace use of system_wq with system_percpu_wq Marco Crivellari
` (4 more replies)
0 siblings, 5 replies; 7+ messages in thread
From: Marco Crivellari @ 2025-11-05 10:35 UTC (permalink / raw)
To: linux-kernel
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
Dmitry Torokhov
Hi,
=== Current situation: problems ===
Let's consider a nohz_full system with isolated CPUs: wq_unbound_cpumask is
set to the housekeeping CPUs, for !WQ_UNBOUND the local CPU is selected.
This leads to different scenarios if a work item is scheduled on an
isolated CPU where "delay" value is 0 or greater then 0:
schedule_delayed_work(, 0);
This will be handled by __queue_work() that will queue the work item on the
current local (isolated) CPU, while:
schedule_delayed_work(, 1);
Will move the timer on an housekeeping CPU, and schedule the work there.
Currently if a user enqueue a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.
This lack of consistency cannot be addressed without refactoring the API.
=== Recent changes to the WQ API ===
The following, address the recent changes in the Workqueue API:
- commit 128ea9f6ccfb ("workqueue: Add system_percpu_wq and system_dfl_wq")
- commit 930c2ea566af ("workqueue: Add new WQ_PERCPU flag")
The old workqueues will be removed in a future release cycle.
=== Introduced Changes by this series ===
1) [P 1-2-3] Replace uses of system_wq and system_unbound_wq
system_wq is a per-CPU workqueue, but his name is not clear.
Because of that, system_wq has been replaced with system_percpu_wq.
2) [P 4] add WQ_PERCPU to alloc_workqueue()
This change adds a new WQ_PERCPU flag to explicitly request
alloc_workqueue() to be per-cpu when WQ_UNBOUND has not been specified.
Thanks!
Marco Crivellari (4):
Input: gpio_keys - replace use of system_wq with system_percpu_wq
Input: palmas-pwrbutton - replace use of system_wq with
system_percpu_wq
Input: mouse - replace use of system_wq with system_percpu_wq
Input: psmouse-smbus - add WQ_PERCPU to alloc_workqueue users
drivers/input/keyboard/gpio_keys.c | 2 +-
drivers/input/misc/palmas-pwrbutton.c | 2 +-
drivers/input/mouse/psmouse-smbus.c | 2 +-
drivers/input/mouse/synaptics_i2c.c | 8 ++++----
4 files changed, 7 insertions(+), 7 deletions(-)
--
2.51.1
^ permalink raw reply [flat|nested] 7+ messages in thread
* [PATCH 1/4] Input: gpio_keys - replace use of system_wq with system_percpu_wq
2025-11-05 10:35 [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue Marco Crivellari
@ 2025-11-05 10:35 ` Marco Crivellari
2025-11-05 10:35 ` [PATCH 2/4] Input: palmas-pwrbutton " Marco Crivellari
` (3 subsequent siblings)
4 siblings, 0 replies; 7+ messages in thread
From: Marco Crivellari @ 2025-11-05 10:35 UTC (permalink / raw)
To: linux-kernel
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
Dmitry Torokhov
Currently if a user enqueues a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.
This lack of consistency cannot be addressed without refactoring the API.
This patch continues the effort to refactor worqueue APIs, which has begun
with the change introducing new workqueues and a new alloc_workqueue flag:
commit 128ea9f6ccfb ("workqueue: Add system_percpu_wq and system_dfl_wq")
commit 930c2ea566af ("workqueue: Add new WQ_PERCPU flag")
system_wq should be the per-cpu workqueue, yet in this name nothing makes
that clear, so replace system_wq with system_percpu_wq.
The old wq (system_wq) will be kept for a few release cycles.
Suggested-by: Tejun Heo <tj@kernel.org>
Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
---
drivers/input/keyboard/gpio_keys.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/input/keyboard/gpio_keys.c b/drivers/input/keyboard/gpio_keys.c
index f9db86da0818..f3fcb1f4d26f 100644
--- a/drivers/input/keyboard/gpio_keys.c
+++ b/drivers/input/keyboard/gpio_keys.c
@@ -434,7 +434,7 @@ static irqreturn_t gpio_keys_gpio_isr(int irq, void *dev_id)
ms_to_ktime(bdata->software_debounce),
HRTIMER_MODE_REL);
} else {
- mod_delayed_work(system_wq,
+ mod_delayed_work(system_percpu_wq,
&bdata->work,
msecs_to_jiffies(bdata->software_debounce));
}
--
2.51.1
^ permalink raw reply [flat|nested] 7+ messages in thread
* [PATCH 2/4] Input: palmas-pwrbutton - replace use of system_wq with system_percpu_wq
2025-11-05 10:35 [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue Marco Crivellari
2025-11-05 10:35 ` [PATCH 1/4] Input: gpio_keys - replace use of system_wq with system_percpu_wq Marco Crivellari
@ 2025-11-05 10:35 ` Marco Crivellari
2025-11-05 10:35 ` [PATCH 3/4] Input: mouse " Marco Crivellari
` (2 subsequent siblings)
4 siblings, 0 replies; 7+ messages in thread
From: Marco Crivellari @ 2025-11-05 10:35 UTC (permalink / raw)
To: linux-kernel
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
Dmitry Torokhov
Currently if a user enqueues a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.
This lack of consistency cannot be addressed without refactoring the API.
This patch continues the effort to refactor worqueue APIs, which has begun
with the change introducing new workqueues and a new alloc_workqueue flag:
commit 128ea9f6ccfb ("workqueue: Add system_percpu_wq and system_dfl_wq")
commit 930c2ea566af ("workqueue: Add new WQ_PERCPU flag")
system_wq should be the per-cpu workqueue, yet in this name nothing makes
that clear, so replace system_wq with system_percpu_wq.
The old wq (system_wq) will be kept for a few release cycles.
Suggested-by: Tejun Heo <tj@kernel.org>
Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
---
drivers/input/misc/palmas-pwrbutton.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/input/misc/palmas-pwrbutton.c b/drivers/input/misc/palmas-pwrbutton.c
index 39fc451c56e9..2d471165334a 100644
--- a/drivers/input/misc/palmas-pwrbutton.c
+++ b/drivers/input/misc/palmas-pwrbutton.c
@@ -91,7 +91,7 @@ static irqreturn_t pwron_irq(int irq, void *palmas_pwron)
pm_wakeup_event(input_dev->dev.parent, 0);
input_sync(input_dev);
- mod_delayed_work(system_wq, &pwron->input_work,
+ mod_delayed_work(system_percpu_wq, &pwron->input_work,
msecs_to_jiffies(PALMAS_PWR_KEY_Q_TIME_MS));
return IRQ_HANDLED;
--
2.51.1
^ permalink raw reply [flat|nested] 7+ messages in thread
* [PATCH 3/4] Input: mouse - replace use of system_wq with system_percpu_wq
2025-11-05 10:35 [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue Marco Crivellari
2025-11-05 10:35 ` [PATCH 1/4] Input: gpio_keys - replace use of system_wq with system_percpu_wq Marco Crivellari
2025-11-05 10:35 ` [PATCH 2/4] Input: palmas-pwrbutton " Marco Crivellari
@ 2025-11-05 10:35 ` Marco Crivellari
2025-11-05 10:35 ` [PATCH 4/4] Input: psmouse-smbus - add WQ_PERCPU to alloc_workqueue users Marco Crivellari
2025-11-05 22:08 ` [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue Dmitry Torokhov
4 siblings, 0 replies; 7+ messages in thread
From: Marco Crivellari @ 2025-11-05 10:35 UTC (permalink / raw)
To: linux-kernel
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
Dmitry Torokhov
Currently if a user enqueues a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.
This lack of consistency cannot be addressed without refactoring the API.
This patch continues the effort to refactor worqueue APIs, which has begun
with the change introducing new workqueues and a new alloc_workqueue flag:
commit 128ea9f6ccfb ("workqueue: Add system_percpu_wq and system_dfl_wq")
commit 930c2ea566af ("workqueue: Add new WQ_PERCPU flag")
system_wq should be the per-cpu workqueue, yet in this name nothing makes
that clear, so replace system_wq with system_percpu_wq.
The old wq (system_wq) will be kept for a few release cycles.
Suggested-by: Tejun Heo <tj@kernel.org>
Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
---
drivers/input/mouse/synaptics_i2c.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/input/mouse/synaptics_i2c.c b/drivers/input/mouse/synaptics_i2c.c
index a0d707e47d93..d42c562c05e3 100644
--- a/drivers/input/mouse/synaptics_i2c.c
+++ b/drivers/input/mouse/synaptics_i2c.c
@@ -372,7 +372,7 @@ static irqreturn_t synaptics_i2c_irq(int irq, void *dev_id)
{
struct synaptics_i2c *touch = dev_id;
- mod_delayed_work(system_wq, &touch->dwork, 0);
+ mod_delayed_work(system_percpu_wq, &touch->dwork, 0);
return IRQ_HANDLED;
}
@@ -448,7 +448,7 @@ static void synaptics_i2c_work_handler(struct work_struct *work)
* We poll the device once in THREAD_IRQ_SLEEP_SECS and
* if error is detected, we try to reset and reconfigure the touchpad.
*/
- mod_delayed_work(system_wq, &touch->dwork, delay);
+ mod_delayed_work(system_percpu_wq, &touch->dwork, delay);
}
static int synaptics_i2c_open(struct input_dev *input)
@@ -461,7 +461,7 @@ static int synaptics_i2c_open(struct input_dev *input)
return ret;
if (polling_req)
- mod_delayed_work(system_wq, &touch->dwork,
+ mod_delayed_work(system_percpu_wq, &touch->dwork,
msecs_to_jiffies(NO_DATA_SLEEP_MSECS));
return 0;
@@ -620,7 +620,7 @@ static int synaptics_i2c_resume(struct device *dev)
if (ret)
return ret;
- mod_delayed_work(system_wq, &touch->dwork,
+ mod_delayed_work(system_percpu_wq, &touch->dwork,
msecs_to_jiffies(NO_DATA_SLEEP_MSECS));
return 0;
--
2.51.1
^ permalink raw reply [flat|nested] 7+ messages in thread
* [PATCH 4/4] Input: psmouse-smbus - add WQ_PERCPU to alloc_workqueue users
2025-11-05 10:35 [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue Marco Crivellari
` (2 preceding siblings ...)
2025-11-05 10:35 ` [PATCH 3/4] Input: mouse " Marco Crivellari
@ 2025-11-05 10:35 ` Marco Crivellari
2025-11-05 22:08 ` [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue Dmitry Torokhov
4 siblings, 0 replies; 7+ messages in thread
From: Marco Crivellari @ 2025-11-05 10:35 UTC (permalink / raw)
To: linux-kernel
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
Dmitry Torokhov
Currently if a user enqueue a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.
This lack of consistentcy cannot be addressed without refactoring the API.
alloc_workqueue() treats all queues as per-CPU by default, while unbound
workqueues must opt-in via WQ_UNBOUND.
This default is suboptimal: most workloads benefit from unbound queues,
allowing the scheduler to place worker threads where they’re needed and
reducing noise when CPUs are isolated.
This patch continues the effort to refactor worqueue APIs, which has begun
with the change introducing new workqueues and a new alloc_workqueue flag:
commit 128ea9f6ccfb ("workqueue: Add system_percpu_wq and system_dfl_wq")
commit 930c2ea566af ("workqueue: Add new WQ_PERCPU flag")
This change adds a new WQ_PERCPU flag to explicitly request alloc_workqueue()
to be per-cpu when WQ_UNBOUND has not been specified.
With the introduction of the WQ_PERCPU flag (equivalent to !WQ_UNBOUND),
any alloc_workqueue() caller that doesn’t explicitly specify WQ_UNBOUND
must now use WQ_PERCPU.
Once migration is complete, WQ_UNBOUND can be removed and unbound will
become the implicit default.
Suggested-by: Tejun Heo <tj@kernel.org>
Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
---
drivers/input/mouse/psmouse-smbus.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/input/mouse/psmouse-smbus.c b/drivers/input/mouse/psmouse-smbus.c
index 93420f07b7d0..5d6a4909ccbf 100644
--- a/drivers/input/mouse/psmouse-smbus.c
+++ b/drivers/input/mouse/psmouse-smbus.c
@@ -299,7 +299,7 @@ int __init psmouse_smbus_module_init(void)
{
int error;
- psmouse_smbus_wq = alloc_workqueue("psmouse-smbus", 0, 0);
+ psmouse_smbus_wq = alloc_workqueue("psmouse-smbus", WQ_PERCPU, 0);
if (!psmouse_smbus_wq)
return -ENOMEM;
--
2.51.1
^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue
2025-11-05 10:35 [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue Marco Crivellari
` (3 preceding siblings ...)
2025-11-05 10:35 ` [PATCH 4/4] Input: psmouse-smbus - add WQ_PERCPU to alloc_workqueue users Marco Crivellari
@ 2025-11-05 22:08 ` Dmitry Torokhov
2025-11-06 13:55 ` Marco Crivellari
4 siblings, 1 reply; 7+ messages in thread
From: Dmitry Torokhov @ 2025-11-05 22:08 UTC (permalink / raw)
To: Marco Crivellari
Cc: linux-kernel, Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Michal Hocko
Hi Marco,
On Wed, Nov 05, 2025 at 11:35:19AM +0100, Marco Crivellari wrote:
> Hi,
>
> === Current situation: problems ===
>
> Let's consider a nohz_full system with isolated CPUs: wq_unbound_cpumask is
> set to the housekeeping CPUs, for !WQ_UNBOUND the local CPU is selected.
>
> This leads to different scenarios if a work item is scheduled on an
> isolated CPU where "delay" value is 0 or greater then 0:
> schedule_delayed_work(, 0);
>
> This will be handled by __queue_work() that will queue the work item on the
> current local (isolated) CPU, while:
>
> schedule_delayed_work(, 1);
>
> Will move the timer on an housekeeping CPU, and schedule the work there.
>
> Currently if a user enqueue a work item using schedule_delayed_work() the
> used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
> WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
> schedule_work() that is using system_wq and queue_work(), that makes use
> again of WORK_CPU_UNBOUND.
>
> This lack of consistency cannot be addressed without refactoring the API.
>
> === Recent changes to the WQ API ===
>
> The following, address the recent changes in the Workqueue API:
>
> - commit 128ea9f6ccfb ("workqueue: Add system_percpu_wq and system_dfl_wq")
> - commit 930c2ea566af ("workqueue: Add new WQ_PERCPU flag")
>
> The old workqueues will be removed in a future release cycle.
>
> === Introduced Changes by this series ===
>
> 1) [P 1-2-3] Replace uses of system_wq and system_unbound_wq
>
> system_wq is a per-CPU workqueue, but his name is not clear.
>
> Because of that, system_wq has been replaced with system_percpu_wq.
>
> 2) [P 4] add WQ_PERCPU to alloc_workqueue()
>
> This change adds a new WQ_PERCPU flag to explicitly request
> alloc_workqueue() to be per-cpu when WQ_UNBOUND has not been specified.
So neither of these 4 need percpu workqueue and instead are fine to use
"whatever is free". Maybe we can switch them to use unbound workqueues
instead?
Thanks.
--
Dmitry
^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue
2025-11-05 22:08 ` [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue Dmitry Torokhov
@ 2025-11-06 13:55 ` Marco Crivellari
0 siblings, 0 replies; 7+ messages in thread
From: Marco Crivellari @ 2025-11-06 13:55 UTC (permalink / raw)
To: Dmitry Torokhov
Cc: linux-kernel, Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Michal Hocko
Hi Dmitry,
On Wed, Nov 5, 2025 at 11:08 PM Dmitry Torokhov
<dmitry.torokhov@gmail.com> wrote:
> So neither of these 4 need percpu workqueue and instead are fine to use
> "whatever is free". Maybe we can switch them to use unbound workqueues
> instead?
Sure, I will send the v2 with the unbound workqueue.
Thanks!
--
Marco Crivellari
L3 Support Engineer, Technology & Product
^ permalink raw reply [flat|nested] 7+ messages in thread
end of thread, other threads:[~2025-11-06 13:56 UTC | newest]
Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-11-05 10:35 [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue Marco Crivellari
2025-11-05 10:35 ` [PATCH 1/4] Input: gpio_keys - replace use of system_wq with system_percpu_wq Marco Crivellari
2025-11-05 10:35 ` [PATCH 2/4] Input: palmas-pwrbutton " Marco Crivellari
2025-11-05 10:35 ` [PATCH 3/4] Input: mouse " Marco Crivellari
2025-11-05 10:35 ` [PATCH 4/4] Input: psmouse-smbus - add WQ_PERCPU to alloc_workqueue users Marco Crivellari
2025-11-05 22:08 ` [PATCH 0/4] replace system_wq with system_percpu_wq, added WQ_PERCPU to alloc_workqueue Dmitry Torokhov
2025-11-06 13:55 ` Marco Crivellari
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®