* [PATCH v2] drm/sched: Replace use of system_wq with system_percpu_wq
@ 2025-11-06 15:01 Marco Crivellari
2025-11-06 15:37 ` Philipp Stanner
2025-11-07 8:28 ` Philipp Stanner
0 siblings, 2 replies; 5+ messages in thread
From: Marco Crivellari @ 2025-11-06 15:01 UTC (permalink / raw)
To: linux-kernel, dri-devel
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
Matthew Brost, Danilo Krummrich, Philipp Stanner,
Christian Konig, Maarten Lankhorst, Maxime Ripard,
Thomas Zimmermann, David Airlie, Simona Vetter
In the general workqueue implementation, if a user enqueues a work item
using schedule_delayed_work() the used wq is "system_wq" (per-cpu wq)
while queue_delayed_work() use WORK_CPU_UNBOUND (used when a cpu is not
specified). The same applies to schedule_work() that is using system_wq
and queue_work(), that makes use again of WORK_CPU_UNBOUND.
This lack of consistency cannot be addressed without refactoring the API.
For more details see the Link tag below.
This continues the effort to refactor worqueue APIs, which has begun
with the change introducing new workqueues and a new alloc_workqueue flag:
commit 128ea9f6ccfb ("workqueue: Add system_percpu_wq and system_dfl_wq")
commit 930c2ea566af ("workqueue: Add new WQ_PERCPU flag")
Use the successor of system_wq, system_percpu_wq, for the scheduler's
default timeout_wq. system_wq will be removed in a few release cycles.
Link: https://lore.kernel.org/all/20250221112003.1dSuoGyc@linutronix.de/
Suggested-by: Tejun Heo <tj@kernel.org>
Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
---
drivers/gpu/drm/scheduler/sched_main.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/scheduler/sched_main.c b/drivers/gpu/drm/scheduler/sched_main.c
index c39f0245e3a9..13192e99637a 100644
--- a/drivers/gpu/drm/scheduler/sched_main.c
+++ b/drivers/gpu/drm/scheduler/sched_main.c
@@ -1315,7 +1315,7 @@ int drm_sched_init(struct drm_gpu_scheduler *sched, const struct drm_sched_init_
sched->name = args->name;
sched->timeout = args->timeout;
sched->hang_limit = args->hang_limit;
- sched->timeout_wq = args->timeout_wq ? args->timeout_wq : system_wq;
+ sched->timeout_wq = args->timeout_wq ? args->timeout_wq : system_percpu_wq;
sched->score = args->score ? args->score : &sched->_score;
sched->dev = args->dev;
--
2.51.1
^ permalink raw reply [flat|nested] 5+ messages in thread
* Re: [PATCH v2] drm/sched: Replace use of system_wq with system_percpu_wq
2025-11-06 15:01 [PATCH v2] drm/sched: Replace use of system_wq with system_percpu_wq Marco Crivellari
@ 2025-11-06 15:37 ` Philipp Stanner
2025-11-06 15:54 ` Marco Crivellari
2025-11-07 8:28 ` Philipp Stanner
1 sibling, 1 reply; 5+ messages in thread
From: Philipp Stanner @ 2025-11-06 15:37 UTC (permalink / raw)
To: Marco Crivellari, linux-kernel, dri-devel
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Michal Hocko, Matthew Brost,
Danilo Krummrich, Philipp Stanner, Christian Konig,
Maarten Lankhorst, Maxime Ripard, Thomas Zimmermann,
David Airlie, Simona Vetter
On Thu, 2025-11-06 at 16:01 +0100, Marco Crivellari wrote:
> In the general workqueue implementation, if a user enqueues a work item
> using schedule_delayed_work() the used wq is "system_wq" (per-cpu wq)
> while queue_delayed_work() use WORK_CPU_UNBOUND (used when a cpu is not
> specified). The same applies to schedule_work() that is using system_wq
> and queue_work(), that makes use again of WORK_CPU_UNBOUND.
Alright, just to be sure:
Behavior doesn't change and system_percpu_wq is then still a workqueue
where we can submit normal delayed_work?
The scheduler's timeout mechanism relies on scheduling and canceling
delayed work items.
>
> This lack of consistency cannot be addressed without refactoring the API.
> For more details see the Link tag below.
>
> This continues the effort to refactor worqueue APIs, which has begun
> with the change introducing new workqueues and a new alloc_workqueue flag:
>
> commit 128ea9f6ccfb ("workqueue: Add system_percpu_wq and system_dfl_wq")
> commit 930c2ea566af ("workqueue: Add new WQ_PERCPU flag")
>
> Use the successor of system_wq, system_percpu_wq, for the scheduler's
> default timeout_wq. system_wq will be removed in a few release cycles.
>
> Link: https://lore.kernel.org/all/20250221112003.1dSuoGyc@linutronix.de/
> Suggested-by: Tejun Heo <tj@kernel.org>
> Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
Thanks for the updated commit message, looks great.
P.
> ---
> drivers/gpu/drm/scheduler/sched_main.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/scheduler/sched_main.c b/drivers/gpu/drm/scheduler/sched_main.c
> index c39f0245e3a9..13192e99637a 100644
> --- a/drivers/gpu/drm/scheduler/sched_main.c
> +++ b/drivers/gpu/drm/scheduler/sched_main.c
> @@ -1315,7 +1315,7 @@ int drm_sched_init(struct drm_gpu_scheduler *sched, const struct drm_sched_init_
> sched->name = args->name;
> sched->timeout = args->timeout;
> sched->hang_limit = args->hang_limit;
> - sched->timeout_wq = args->timeout_wq ? args->timeout_wq : system_wq;
> + sched->timeout_wq = args->timeout_wq ? args->timeout_wq : system_percpu_wq;
> sched->score = args->score ? args->score : &sched->_score;
> sched->dev = args->dev;
>
^ permalink raw reply [flat|nested] 5+ messages in thread
* Re: [PATCH v2] drm/sched: Replace use of system_wq with system_percpu_wq
2025-11-06 15:37 ` Philipp Stanner
@ 2025-11-06 15:54 ` Marco Crivellari
0 siblings, 0 replies; 5+ messages in thread
From: Marco Crivellari @ 2025-11-06 15:54 UTC (permalink / raw)
To: phasta
Cc: linux-kernel, dri-devel, Tejun Heo, Lai Jiangshan,
Frederic Weisbecker, Sebastian Andrzej Siewior, Michal Hocko,
Matthew Brost, Danilo Krummrich, Christian Konig,
Maarten Lankhorst, Maxime Ripard, Thomas Zimmermann,
David Airlie, Simona Vetter
On Thu, Nov 6, 2025 at 4:37 PM Philipp Stanner <phasta@mailbox.org> wrote:
>
> On Thu, 2025-11-06 at 16:01 +0100, Marco Crivellari wrote:
> > In the general workqueue implementation, if a user enqueues a work item
> > using schedule_delayed_work() the used wq is "system_wq" (per-cpu wq)
> > while queue_delayed_work() use WORK_CPU_UNBOUND (used when a cpu is not
> > specified). The same applies to schedule_work() that is using system_wq
> > and queue_work(), that makes use again of WORK_CPU_UNBOUND.
>
> Alright, just to be sure:
> Behavior doesn't change and system_percpu_wq is then still a workqueue
> where we can submit normal delayed_work?
>
> The scheduler's timeout mechanism relies on scheduling and canceling
> delayed work items.
Correct, system_percpu_wq is the replacement of system_wq. They are the same.
We chosen to add a new workqueue instead of rename system_wq, to make the
transition process smooth, but you can look at all of this as a rename
of system_wq
into system_percpu_wq, basically.
You can confirm by looking at the header file
"include/linux/workqueue.h", and search for
system_wq. There is only its definition, everything has been replaced
with system_percpu_wq.
> Thanks for the updated commit message, looks great.
Perfect! :-)
Thanks!
--
Marco Crivellari
L3 Support Engineer, Technology & Product
^ permalink raw reply [flat|nested] 5+ messages in thread
* Re: [PATCH v2] drm/sched: Replace use of system_wq with system_percpu_wq
2025-11-06 15:01 [PATCH v2] drm/sched: Replace use of system_wq with system_percpu_wq Marco Crivellari
2025-11-06 15:37 ` Philipp Stanner
@ 2025-11-07 8:28 ` Philipp Stanner
2025-11-07 8:42 ` Marco Crivellari
1 sibling, 1 reply; 5+ messages in thread
From: Philipp Stanner @ 2025-11-07 8:28 UTC (permalink / raw)
To: Marco Crivellari, linux-kernel, dri-devel
Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
Sebastian Andrzej Siewior, Michal Hocko, Matthew Brost,
Danilo Krummrich, Philipp Stanner, Christian Konig,
Maarten Lankhorst, Maxime Ripard, Thomas Zimmermann,
David Airlie, Simona Vetter
On Thu, 2025-11-06 at 16:01 +0100, Marco Crivellari wrote:
> In the general workqueue implementation, if a user enqueues a work item
> using schedule_delayed_work() the used wq is "system_wq" (per-cpu wq)
> while queue_delayed_work() use WORK_CPU_UNBOUND (used when a cpu is not
> specified). The same applies to schedule_work() that is using system_wq
> and queue_work(), that makes use again of WORK_CPU_UNBOUND.
>
> This lack of consistency cannot be addressed without refactoring the API.
> For more details see the Link tag below.
>
> This continues the effort to refactor worqueue APIs, which has begun
> with the change introducing new workqueues and a new alloc_workqueue flag:
>
> commit 128ea9f6ccfb ("workqueue: Add system_percpu_wq and system_dfl_wq")
> commit 930c2ea566af ("workqueue: Add new WQ_PERCPU flag")
>
> Use the successor of system_wq, system_percpu_wq, for the scheduler's
> default timeout_wq. system_wq will be removed in a few release cycles.
>
> Link: https://lore.kernel.org/all/20250221112003.1dSuoGyc@linutronix.de/
> Suggested-by: Tejun Heo <tj@kernel.org>
> Signed-off-by: Marco Crivellari <marco.crivellari@suse.com>
Applied to drm-misc-next.
Thanks a lot
P.
> ---
> drivers/gpu/drm/scheduler/sched_main.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/scheduler/sched_main.c b/drivers/gpu/drm/scheduler/sched_main.c
> index c39f0245e3a9..13192e99637a 100644
> --- a/drivers/gpu/drm/scheduler/sched_main.c
> +++ b/drivers/gpu/drm/scheduler/sched_main.c
> @@ -1315,7 +1315,7 @@ int drm_sched_init(struct drm_gpu_scheduler *sched, const struct drm_sched_init_
> sched->name = args->name;
> sched->timeout = args->timeout;
> sched->hang_limit = args->hang_limit;
> - sched->timeout_wq = args->timeout_wq ? args->timeout_wq : system_wq;
> + sched->timeout_wq = args->timeout_wq ? args->timeout_wq : system_percpu_wq;
> sched->score = args->score ? args->score : &sched->_score;
> sched->dev = args->dev;
>
^ permalink raw reply [flat|nested] 5+ messages in thread
* Re: [PATCH v2] drm/sched: Replace use of system_wq with system_percpu_wq
2025-11-07 8:28 ` Philipp Stanner
@ 2025-11-07 8:42 ` Marco Crivellari
0 siblings, 0 replies; 5+ messages in thread
From: Marco Crivellari @ 2025-11-07 8:42 UTC (permalink / raw)
To: phasta
Cc: linux-kernel, dri-devel, Tejun Heo, Lai Jiangshan,
Frederic Weisbecker, Sebastian Andrzej Siewior, Michal Hocko,
Matthew Brost, Danilo Krummrich, Christian Konig,
Maarten Lankhorst, Maxime Ripard, Thomas Zimmermann,
David Airlie, Simona Vetter
On Fri, Nov 7, 2025 at 9:28 AM Philipp Stanner <phasta@mailbox.org> wrote:
>[...]
> Applied to drm-misc-next.
>
> Thanks a lot
> P.
Many thanks!
--
Marco Crivellari
L3 Support Engineer, Technology & Product
^ permalink raw reply [flat|nested] 5+ messages in thread
end of thread, other threads:[~2025-11-07 8:42 UTC | newest]
Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-11-06 15:01 [PATCH v2] drm/sched: Replace use of system_wq with system_percpu_wq Marco Crivellari
2025-11-06 15:37 ` Philipp Stanner
2025-11-06 15:54 ` Marco Crivellari
2025-11-07 8:28 ` Philipp Stanner
2025-11-07 8:42 ` Marco Crivellari
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®