mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH V10 00/19] virtio_ring in order support
@ 2025-12-24  0:32 Jason Wang
  2025-12-24  0:32 ` [PATCH V10 01/19] virtio_ring: rename virtqueue_reinit_xxx to virtqueue_reset_xxx() Jason Wang
                   ` (18 more replies)
  0 siblings, 19 replies; 22+ messages in thread
From: Jason Wang @ 2025-12-24  0:32 UTC (permalink / raw)
  To: mst, jasowang, xuanzhuo, eperezma, virtualization, linux-kernel

Hello all:

This sereis tries to implement the VIRTIO_F_IN_ORDER to
virtio_ring. This is done by introducing virtqueue ops so we can
implement separate helpers for different virtqueue layout/features
then the in-order were implemented on top.

Tests shows 2%-19% imporvment with packed virtqueue PPS with KVM guest
vhost-net/testpmd on the host.

Changes sinve v9:

- Fix the total_len calcuation and count only in buffer length
- Fix the comment for the condtiion when batching is not detected

Changes since v8:

- Rebase to vhost.git linux-next branch
- Fix issue when indirect descriptor is disabled
- use UINT_MAX instead of vq->num to indicate no batching is pending
- Tweak the comments for used_entry
- Various coding style tweaks and typo fixes
- Try to use in_order varianet in in_order ops

Changes since v7:

- Rebase on vhost.git linux-next branch
- Tweak the comment to explain the usage of free_head

Changes since v6:

- Rebase on vhost.git linux-next branch
- Fix poking packed virtqueue in more_used_split_in_order()
- Fix calling detach_buf_packed_in_order() unconditonally in
  virtqueue_detach_unused_buf_packed()
- Typo and indentation fixes
- Fix wrong changelog of patch 7

Changes since v5:

- rebase on vhost.git linux-next branch
- reorder the total_len to reduce memory comsuming

Changes since v4:

- Fix build error when DEBUG is enabled
- Fix function duplications
- Remove unnecessary new lines

Changes since v3:

- Re-benchmark with the recent vhost-net in order support
- Rename the batched used id and length
- Other minor tweaks

Changes since v2:

- Fix build warning when DEBUG is enabled

Changes since v1:

- use const global array of function pointers to avoid indirect
  branches to eliminate retpoline when mitigation is enabled
- fix used length calculation when processing used ids in a batch
- fix sparse warnings

Jason Wang (19):
  virtio_ring: rename virtqueue_reinit_xxx to virtqueue_reset_xxx()
  virtio_ring: switch to use vring_virtqueue in virtqueue_poll variants
  virtio_ring: unify logic of virtqueue_poll() and more_used()
  virtio_ring: switch to use vring_virtqueue for virtqueue resize
    variants
  virtio_ring: switch to use vring_virtqueue for virtqueue_kick_prepare
    variants
  virtio_ring: switch to use vring_virtqueue for virtqueue_add variants
  virtio: switch to use vring_virtqueue for virtqueue_get variants
  virtio_ring: switch to use vring_virtqueue for enable_cb_prepare
    variants
  virtio_ring: use vring_virtqueue for enable_cb_delayed variants
  virtio_ring: switch to use vring_virtqueue for disable_cb variants
  virtio_ring: switch to use vring_virtqueue for detach_unused_buf
    variants
  virtio_ring: switch to use unsigned int for virtqueue_poll_packed()
  virtio_ring: introduce virtqueue ops
  virtio_ring: determine descriptor flags at one time
  virtio_ring: factor out core logic of buffer detaching
  virtio_ring: factor out core logic for updating last_used_idx
  virtio_ring: factor out split indirect detaching logic
  virtio_ring: factor out split detaching logic
  virtio_ring: add in order support

 drivers/virtio/virtio_ring.c | 931 +++++++++++++++++++++++++++--------
 1 file changed, 717 insertions(+), 214 deletions(-)

-- 
2.31.1


^ permalink raw reply	[flat|nested] 22+ messages in thread

end of thread, other threads:[~2025-12-25  4:20 UTC | newest]

Thread overview: 22+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-12-24  0:32 [PATCH V10 00/19] virtio_ring in order support Jason Wang
2025-12-24  0:32 ` [PATCH V10 01/19] virtio_ring: rename virtqueue_reinit_xxx to virtqueue_reset_xxx() Jason Wang
2025-12-24  0:32 ` [PATCH V10 02/19] virtio_ring: switch to use vring_virtqueue in virtqueue_poll variants Jason Wang
2025-12-24  0:32 ` [PATCH V10 03/19] virtio_ring: unify logic of virtqueue_poll() and more_used() Jason Wang
2025-12-24  0:32 ` [PATCH V10 04/19] virtio_ring: switch to use vring_virtqueue for virtqueue resize variants Jason Wang
2025-12-24  0:32 ` [PATCH V10 05/19] virtio_ring: switch to use vring_virtqueue for virtqueue_kick_prepare variants Jason Wang
2025-12-24  0:32 ` [PATCH V10 06/19] virtio_ring: switch to use vring_virtqueue for virtqueue_add variants Jason Wang
2025-12-24  0:32 ` [PATCH V10 07/19] virtio: switch to use vring_virtqueue for virtqueue_get variants Jason Wang
2025-12-24  0:32 ` [PATCH V10 08/19] virtio_ring: switch to use vring_virtqueue for enable_cb_prepare variants Jason Wang
2025-12-24  0:32 ` [PATCH V10 09/19] virtio_ring: use vring_virtqueue for enable_cb_delayed variants Jason Wang
2025-12-24  0:33 ` [PATCH V10 10/19] virtio_ring: switch to use vring_virtqueue for disable_cb variants Jason Wang
2025-12-24  0:33 ` [PATCH V10 11/19] virtio_ring: switch to use vring_virtqueue for detach_unused_buf variants Jason Wang
2025-12-24  0:33 ` [PATCH V10 12/19] virtio_ring: switch to use unsigned int for virtqueue_poll_packed() Jason Wang
2025-12-24  0:33 ` [PATCH V10 13/19] virtio_ring: introduce virtqueue ops Jason Wang
2025-12-24  0:33 ` [PATCH V10 14/19] virtio_ring: determine descriptor flags at one time Jason Wang
2025-12-24  0:33 ` [PATCH V10 15/19] virtio_ring: factor out core logic of buffer detaching Jason Wang
2025-12-24  0:33 ` [PATCH V10 16/19] virtio_ring: factor out core logic for updating last_used_idx Jason Wang
2025-12-24  0:33 ` [PATCH V10 17/19] virtio_ring: factor out split indirect detaching logic Jason Wang
2025-12-24  0:33 ` [PATCH V10 18/19] virtio_ring: factor out split " Jason Wang
2025-12-24  0:33 ` [PATCH V10 19/19] virtio_ring: add in order support Jason Wang
2025-12-24  8:05   ` Eugenio Perez Martin
2025-12-25  4:20     ` Jason Wang

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®